Network Hangs... and then works after 5-10 Minutes

I have a 3 PC network at home using a NetGear DG814 ADSL Router. All 3 PCs are using Windows XP.

The problem lies in Windows Networking. When I try accessing a shared directory on another pc (OR EVEN MY OWN), the windows explorer hangs for 5-10 minutes. It then wakes up and displays the contents of the directory. From that point on file access in that shared directory is working perfectly and is in fact very fast.

This behavious also happens whey I try to access one of my shared directories through My Network Places. It hangs for a few minutes and it then works perfectly.

I have to say that an Internet Connection from the router is always available to all 3 PCs with no problems. Also we had no problems playing games like Networked Serious Sam 2.

In our network conenctions We all have:
Clients for Microsoft Networks
    configured to use:
       Windows Locator
QoS Packet Scheduler
File and Printer Sharing for Microsoft Networks
Internet Protocol (TCP/IP)
    which is configured as:
       getting an ip from the router's DHCP server
       using the DNS server of the router
       gateway being the Router's ip again
       Enable LMHOSTS lookup
       and Enable NetBIOS over TCP/IP

My NIC is an Allied Telesyn AT-2500TX Series PCI Ethernet Adapter (which is my main suspicion of the problem - however all other network uses eg internet connection or gaming work)

This is configured as
APM Wakeup - Disable
Early Tx Threshold - 38
Line Speed/Duplex Mode - Auto Detect
Link Down WakeUp - Disable
Magic Packet - Enable
Network Address (LAA) - Not Present
Receive Buffer SIze - 64K bytes


Any ideas ? I cannot understand why everything works except for Microsoft Networking
MadSectorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tomwsfCommented:
This is because everytime you want to find a network share file, pc will send the broadcast packet to the whole lan and waiting for reply. This is the behaviour of micrsoft network. Because of lacking of master browser and WINS server, it needs time to browser the target computer and shared resoruces. The browsing servies is not so good in any windows product.
You can improve it by using static private ip address for each pc. You will have a few minutes wait for each computer to browse network resources. But the information will be cached in the pc for next time. That will improve the browsing time.
lrmooreCommented:
tomwsf is on the right track. It is a netbios name resolution issue. There are a couple of things you can do to dramatically improve the performance
1. Enable Netbios - in TCP/IP properties, Advanced button, WINS tab, choose the middle selection "enable" versus the "default"
2. Create a master hosts file and copy it to all PC's. All you need in the host file is:

127.0.0.0 localhost
<ip add of PC1>  PC1
<ip add of PC2>  PC2

etc. Be sure save the file as hosts. and not hosts.txt (no file extension) and save it in \WINDOWS\system32\drivers\etc

After you copy the hosts file, open a DOS prompt and type:
C:> ipconfig /flushdns

Now you should see a dramatic improvement in performance.
stevenlewisCommented:
>Enable LMHOSTS lookup
did you create lmhosts files?
ip address machine1   machine1  #PRE
where
ip address machine 1 is the ip address assigned to machine1
and mcahine1 is the NetBIOS name of the machine
note the spaces between the two, and use the #PRE tag
for more info on lmhosts files see here
http://www.realcomputerguy.com/lmhosts.htm
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

globetrotterCommented:
Explorer in XP does a lot of stuff it didn't do under w2k. Try if setting your XP for best performance:
right-click desktop > Properties > Advanced > Performance > Settings > "Adjust for best Performance"

XP will then look and feel like W2K. See if that improves performance, else forget about explorer and use the command prompt, you will notice things go a lot faster there.
MadSectorAuthor Commented:
Thank you very much for your help. Unfortunately the problem was NOT SOLVED :(

I created both HOSTS and LMHOSTS files and flushed my dns records. However I do not thing that is the problem. Using GFI's LanGuard I used the DNS lookup for the computers in my network and the DNS reply is instantaneous.

The explorer performance is definitely not the problem.

<b>FURTHER QUESTIONS</b>

What is a MASTER BROWSER ? Do we need one ?
What is a Computer Browser ? Do we need one ?
Why does computer minas access my PC (doros) with NO DELAY and I wait for a huge delay before accessing the minas PC ?

using GFI's LANguard I created the following report you can find on http://www.kounoupi.com/screencap.jpg

<img src="http://www.kounoupi.com/screencap.jpg" width="376" height="914">

Can anyone see any broblems ?
stevenlewisCommented:
the master browser keeps a list of resources that are available on the network, and yes you need one
the computer browser is a service that allows it to query the master browser
and you need it
>Line Speed/Duplex Mode - Auto Detect
try setting it to 10 mbps half duplex as a test (to start) and then try it at 100 mbps half, then force it to 100 mbps full
MadSectorAuthor Commented:
thx for insisting with me (12 hours end on) but setting the speed to 10mbps half duplex again did not eliminate the long hangs.

I think this problem started when I installed Exceed 7.1.1

Could this have anything to do with it ?
stevenlewisCommented:
could have, try uninstalling it, and then use the system restore to go back to before you installed it and see if that helps
SysExpertCommented:
In addition. Update the Network Card drivers on all of your machines !!

I hope this helps !
MadSectorAuthor Commented:
I am incredibly angry with Windows XP because of this Networking problems. Nothing I tried all of the above. Nothing seems to solve the problem. P.S I could not restore the system to pre Exceed state since it's been some time now
SysExpertCommented:
You are not the only one...

Are you using mapped drives ?

This can speed things up.

net use X:  \\computer\sharename

 I hope this helps !

bigALCommented:
These are the things I would check.

1. First thing first, can you ping all three of you machines with out losing packets?
     ( I’m betting you can because you can eventually connect to the other PC)

2. If you can ping with out losing any packets Don’t mess with the physical layer of you network!!! If all three computers share Internet connection and can ping each other YOUR PROBLEM WILL NOT BE YOU NETWORK CARDS!!!! Or network wire, or you Network card’s driver. Oh and I would remove you LMHOST and HOST file since you are using DHCP clients and no static clients or servers!! LMHOST and HOST file are to point to systems with STATIC IP addresses only.

3. Do you have any grayed out mapped drives in windows explorer? (old drive mappings listed in windows explorer that point to shares that don't exist anymore) If so remove the mapped drive. Windows could be looking for something that isn’t there any more.

4. Does this problem happen when you try and connect to another PC from Start-->Run Try this by both computer name and by IP address, (syntax =  \\computername or \\Ipaddress)

Step 4 should show you where your problem is, if connecting by IP address takes along time (but you don’t lose packets) you have a routing problem, Odds are you’ll get your connection fast and that routing is not your issue, So If the computer name takes along time to connect, but IP addresses connect quickly, you have a name resolution problem which isn’t fun to fix.

Since you are using DHCP, LMHOST files and HOST files will not work and should be removed ASAP! And you say the router is also a DNS server. How about WINS? In your tcpip settings for you Network card I would see if there is a setting for Use DHCP for WINS resolution and if so Use it. Or plug your routers IP in for the WINS server. And See what happens

Ok. I hope this helped, and fyi you Microsoft computer resolves computers via tcpip in the following order.

1.     Cache
2.     Wins
3.     Broadcast    
4.     Lmhost
5.     Host
6.     DNS

globetrotterCommented:
sorry to contradict you bigAl, but in Windows 2000 and Xp it goes cache, dns, wins, broadcast, ...

I think exactly here lies the problem. Probably MadSectors XP Clients are trying to find some work group information, they only find IPaddresses and names in the netbios cache and move on to the DNS Server trying to find it there. Since your netgear box looks for that info on a DNS Server on the internet it doesn't find any info either. Only then it will broadcast and find the local information. What you are looking at is the wait for all the tímeouts when it can't find the info.

Things you could still try:
check the network provider order in "My Network Places Properties", Advanced, Advanced Settings.
On the "Adapters and Bindings Tab move the LAN Interface up to the Top (unless it's the only interface showing)
Then go to the "Provider Order" Tab, under "Network Providers" move "Microsoft Windows Network" to the Top.
Now test the behaviour again.

MFDMCommented:
sorry to contradict your contradiction, but NetBIOS name resolution is the same on all the family of windows depending on the node type. bigAL is describing a H-node or hybrid node type.
globetrotterCommented:
Hi MFDM, I don't feel any need to argue.
If you don't believe me, start a Network Monitor on a W2K Machine that shows as an h-node and send a ping to a nonexisting NetBIOS Name. Even if the client has a WINS Server defined, the first query if the name is not in cache is DNS, NBT you will see only afterwards.

I have one more suggestion for MadSector, if changing the Network Provider Order does not help, go and stop the WebClient Services. That should do it. This will not interfere with your ability to surf the internet. This only disables HTTP over SMB.

There is also a SP1 Fix for XP that addresses issues like that, don't worry about the fact that the article speaks about a problem on DFS, it has been seen on normal shares as well since then:
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q312181

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bigALCommented:
Hi Globetrotter,
But MFDM is right I was describing a Hybrid node type. Please show the MS Q article that shows says Microsoft has change name resolution in XP and Win2k, it would be cool know who is right. As for is problem with DFS, is he really in an environment with 2 or more Win 2k Servers that are using DFS???  I thought he only had 3 XP boxes. (but it could be related It is a Microsoft OS and it is  a problem with shares) Oh ya if he is using command prompt he will still have the same problem unless he uses the IP address to connect to the other computer instead of using the computer name. But unless mad sector posts back with what happens when he changes things we’ll really never know what is going on, or what his current configuration is. PS did you play ball in college too? Globetrotter..
bigALCommented:
Hi Globetrotter,
But MFDM is right I was describing a Hybrid node type. Please show the MS Q article that shows says Microsoft has change name resolution in XP and Win2k, it would be cool know who is right. As for is problem with DFS, is he really in an environment with 2 or more Win 2k Servers that are using DFS???  I thought he only had 3 XP boxes. (but it could be related It is a Microsoft OS and it is  a problem with shares) Oh ya if he is using command prompt he will still have the same problem unless he uses the IP address to connect to the other computer instead of using the computer name. But unless mad sector posts back with what happens when he changes things we’ll really never know what is going on, or what his current configuration is. PS did you play ball in college too? Globetrotter..
globetrotterCommented:
Hi Big AL,
I didn't expect MadSector to be using DFS, wouldn't make much sense on a 3 machine network. As I already said, the article mentions this problem on DFS, but I have seen the same problem on machines that had nothing to do with DFS. XP seems to put the WebClient first in the network provider order. That one sends a http request at bootup (either to the local web server if there is one, or to it's gateway to the internet, don't ask why, I haven't found the reason for it yet)and 3 requests whenever opening a new session. If it doesn't get any answer you have to wait for it to time out. That can take quite a while. That is also why he only sees the problem when opening Explorer or Network Places for the first time.

The only place I have seen the changed name resolution printed somewhere is a German MS Pressbook "Windows 2000 in the Network", I have searched the Windows 2000 Resourcekit up and down but didn't see it documented anywhere there. If I still come across an MS Q-article I will post it. The way I verified it was by Networkmonitor using a machine that was set to h-node, sending a ping to a non existing NetBios name, so it would go through the whole process and it did DNS before NBT name queries.

PS: By the way, I dislike ball games.
globetrotterCommented:
Almost forgot, this site gives a few more valid points to troubleshoot slow browsing:
http://www.practicallynetworked.com/sharing/troubleshoot/slowbrowse02.htm
0byteCommented:
like some one said disable lmhost setting , plus xp sp2 is out if iam not wrong , sp3 plus presp4 for w2k is also available , so apply them to applicable systems and try again . also  if applicable disable the following settings and try
1.    disable "register this connection address in dns"
2.     remove the tick from append parent suffixes of primary dns suffix.
this might sound far fetched but ry any way if nothing else worked. :)

good luck
MadSectorAuthor Commented:
First of all Sorry I took so long to answer back. Thanx for the whopping response !!! I am indeed amazed.

I am starting to answer bigAL's msg point 4 ! I was amazed that it did indeed work !!! I can access shared directories on other pc's by going to run and typing \\192.168.0.4\something which is a pc i had trouble accessing otherwise. Accessing the \\computername\something causes the usual hang... that means we are in a name resolution problem...

I then went on to Move the Microsoft Network on the top of the list as globetrotter said. I thought that solved the problem but the complete solution to the problem came by DISABLING THE WebClient SERVICE. My network works fine now EXCEPT That I cannot "View Network Computers". I Do not mind that since I know which PC's we have at home and NOW I can finally access the files on them !

200 of my expert points go to Globetrotter. Special thanx to BigAl and stevenlewis for insisting with me ! And of course a big thanx to everybody for all the suggestions.

P.S if anyone knows of a tweak that will also let me "View Network Computers" please go ahead and post it
MadSectorAuthor Commented:
Globetrotter's previous comment on moving the Microsoft Network on Top of the List and Disabling the WebClient Service did the job. I do not still get what causes this problem to arise. If anyone cares to explain please mail me on epp479@hotmail.com

Thanx a lot.

MadSector
MSGeekCommented:
MadSector...Your atatement about IP address working beutifully narrows your issue to name resolution.  You could confirm this going to a Command prompt and typing "ping computername."  If you get an unknown host response, that settles the issue.

DNS is your answer here and XP and 2000 both look to DNS first. This was a change made starting with 2000.  The browser service is not related, that is from the days of NetBios and Wins.  

If you created a lmhosts file, clear out any entries.

Create a hosts file!  For name resolution your PC looks to entries in the hosts file first and then to cache and then to DNS servers being pushed out through DHCP.

That should solve your problem.
MSGeekCommented:
MadSector...I left one item out, an important one at that.  The statement above that using static IPs is crucial to a hosts file working properly is correct.  

Can you disable DHCP on the router and manually configure each clients' IP address with the default gateway being the address of the router.  IP addresses should have same subnet-mask as inside interface on router, usualy interface zero.  You could actually use the same address information on each computer that is being handed out through DHCP currently, including DNS server addresses.  Hopefully these are not changed too frequently by your ISP.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.