Termination based on Idle time

kachanti
kachanti used Ask the Experts™
on
I am trying to terminate a client connection based on idle time.

I have tried to use FORMS60_TIMEOUT and heartBeat as described on metalink (ID 109471.1) and in this site with the title "Web forms session terminated by closing the browser".

I am using forms version 6.0.8.11.3
This is what I did. I set
i) FORMS60_TIMEOUT = 1  (on the Forms server)
ii) heartBeat = 2  (in Basejini.htm)

I have stopped and started the forms server and the admin stopped and started apache.

It is not timing out. What am I missing?

Thanks,

Kiran
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dear Kiran,

Have you set the FORMS60_TIMEOUT in the right oracle home? If you have an 9ias installation you actually have a multihome installation (9ias in Home0 .. Forms in Home1) .. so you will need to set this key in the \software\oracle\Home1 and not in \software\oracle !

Cheers,
Stefan

Author

Commented:
Hi Stefan,

We are using 9ias. The Admin could not find the home you were describing. Are we missing something?

Is there a diferent syntax for solaris?

Thanks,

Kiran

Author

Commented:
Hi Stefan,

We are using 9ias on a Solaris box. The Admin could not find the home you were describing. Are we missing something?

Is there a diferent syntax for solaris?

Thanks,

Kiran
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

ok, i see ...

then ignore my previous mail, i was talking about Windows platform!

ok, so you set your FORMS60_TIMEOUT as an environment variable (in unix this is case sensitive by the way!) and then started the Formslistener? .. or are you using the Forms servlet implementation?

Cheers,
Stefan

Author

Commented:
'FORMS60_TIMEOUT' is in caps.

Yes we did stop and start the forms server
forms60_server stop
forms60_serve start

We are using the forms servlet implementation

Thanks,

Kiran
nhmm ... servlet implementation is little bit different.

I am not deadsure about configuration of servlet mode, but please try to set this parameter in the forms60\server\default.env file instead of als environment variable!

Cheers, Stefan

Author

Commented:
Thanks for the ideas.

I put it in as  "FORMS60_TIMEOUT=1" in
forms60\server\default.env  

That did not fix it.

Let me know if you come up with something else

Kiran
Sorry Kiran,

also running out of ideas ;-/!

i did a search on the paramater and found this website:

http://www.rchath.com/members/sysad/sysad_2.htm

an excerpt:
>>>>>
* Create an environment variable FORMS50_TIMEOUT. (FORMS45_TIMEOUT, FORMS60_TIMEOUT for 1.6, 6.0 respectively)
* Give it an integer value representing the length of time in minutes until timeout between 3 and 1440 (1 Day) inclusive.


so there they say, give it a value between 3 and 1440 ... sbut you give it a value of 1 ... maybe that's the problem?!

Cheers, Stefan

Author

Commented:
Hi Stefan,

That did work after I put 3.

For some reason I had to put the FORMS60_TIMEOUT = 5 in the .profile file.

Thanks,

Kiran


Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial