Redhat 8.0 & Java virtual machine

MichaelVB
MichaelVB used Ask the Experts™
on
Hello,

I have RedHat 8.0 and I have just installed j2re-1_4_0_02-linux-i586.bin

This is the exact directory structure of the location where it is installed,
copied from the location bar:

/home/mike/java/j2re1.4.0_02/bin

The installation went fine. However I am trying to run the Limewire installer and I get this message:

* No Java virtual machine could be found from your PATH environment variable

I have tried editting the .bash_Profile file at least 15 times. This is what it currently looks like


----------------------------------------------------
# Get the aliases and functions
if [ -f ~/.bashrc ]; then
     . ~/.bashrc
fi

# User specific environment and startup programs

export PATH=/usr/java/j2re1.4.0_02/bin:$PATH
# export PATH
unset USERNAME
-----------------------------------------------------


I correctly set the PATH variable for Java in a 98 & 2K machine in a matter of minutes. I've tried for hours to figure out what I am doing wrong with no luck. Can someone tell me how to cure this?

I'm guessing that it's something simple... But, I'm awarding 200 points because it's driving me %#@!^#$ CRAZY!

Thanks a TON!

Mike
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2005
Commented:
You say that the JRE is installed in /home/mike/java/j2re1.4.0_02, but you are setting the path to include /usr/java/j2re1.4.0_02. I'd guess that there isn't a /usr/java/j2re1.4.0_02 at all. I think you'd have better luck executing:

export PATH=/home/mike/java/j2re1.4.0_02/bin:$PATH

and then trying the limewire install. If that works then include that statement in your .bashrc for subsequent login sessions.

Author

Commented:
THANK YOU!

I swear, I thought I had tried that.  Give the man 200 points.

Thanks again.

Mike

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial