Linksys Wireless Router and FTP/POP mail

roverm
roverm used Ask the Experts™
on
Hi all!

Got a problem with my Linksys BEFW11S2 v.2 Wireles router/gateway.

I am connected to the internet using Cable.
After the modem the router is connected. I work from my laptop which connects wireless to the router.
Everything works fine, but I can't get WS_FTP to work!
When I connect my laptop direct to the cable modem everything works fine.
When I connect via the router, the connection to the FTP site can be made, but after that the 'LIST' command is not understood.
Very strange!

Is this a setting that needs to be changed by the FTP site-provider ?
Is it a setting in the router ?

Second:
One of my POP mail account is very slow via the router.
Finding the server: less than 1 sec
Connecting: less than 1 sec
Getting email: about 30 secs! Even when there is no mail!

My OS is Windows 2000 Pro/SP2. I use DHCP.

Thanks!

D'Mzzl!
RoverM
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Sr. Systems Engineer
Top Expert 2008
Commented:
Open up the configuration page to your Linksys:
http://192.168.1.1
If your Firmware Version # is 1.42.7, FTP is broke in that code. If you upgrade to 1.43, all should be well. A friend of mine just went through this...and the upgrade fixed it.

Author

Commented:
Ok, thanks, I will check this in 3 hrs (when I'm home).

Mark

Author

Commented:
Couldn't wait, went home and tried it!
YESSSS! FTP works! GREAT!!!

But, still got the POP problem. Any suggestions on that ?

(btw: the points are yours!)
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Nope, the adjustment of the MTU didn't work.
The kb articles didn't help either.
But: the connecting is working fine, it's getting the emails!

Any other suggestions ?

Mark

Author

Commented:
Well, it's seems to be working most of the time.
I asked my provider what MTU value their are using. Guess it will make the difference.

Thanks for all your help!

D'Mzzl!
Mark

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial