Export Display Problem on Linux

s_mis
s_mis used Ask the Experts™
on
I have installed Linuxon my machine but I not able to Export Display of one machine to another.Tried out with Exporting Display and setenv.

Regards
santosh
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
On the machine where you want the display to appear you need to run "xhost" to allow connections from the other machine ie

xhost +<machine name> to allow access from a particular machine

or xhost + to allow access from any machine.

Hope this helps
# csh, tcsh syntax
setenv DISPLAY remotehost:0

# bash, sh and many more syntax:
DISPLAY=remotehost:0
export DISPLAY

Author

Commented:
I have tried with xhost +<machine name> and setenv DISPLAY remotehost:0. But problem is still there.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
Use "xhost +" on your local host and "export DISPLAY=localhost:0" an your remote host.

xhost give's access to the X-server of the host, were the command was given. Changing your DISPLAY variable set's the target host, were new windows will open.
please post result of
  xhost
executed on your local host
and post result of
  echo $DISPLAY
executed on your remote host
and result od
  w|grep ^$user
executed on remote host

Commented:
Make sure that the X server is listening for TCP connections.  Run 'netstat -na |grep LISTEN' and look for something listening on port 6000.  As root, you can run with the options -nap and look for the X process.  If it is listed, I'm going to guess you have some sort of firewall issue.  If it is not listed, your X server is probably being passed the '-nolisten tcp' argument.  Remove this argument from the configuration file that runs X (if you're using ?dm).  The easiest way to find this is probably an 'rgrep nolisten /etc/X11'
Mihai BarbosTrying to tame bits. They're nasty.

Commented:
Try
    export DISPLAY=<remotehost>:0.0
if you are using bash or sh or
    setenv DISPLAY <remotehost>:0.0
if you are using tcsh or csh, as ahoffmann said.
<remotehost> is the name of the machine you want to send the display to. Also make sure you have allowed access to the X server on this machine (xhost +)

Sorry for repeating what others have said, but I've got a strange feeling that there is a small typing mistake somewhere.
s_mis:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
PAQ / No refund
Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

TheWeakestLink
EE Cleanup Volunteer
I still see no problem with first 2 suggestions
The original questioner is the ultimate arbiter of how this will get resolved.  

I'm hoping that the PAQ/No refund might prompt some action.  I don't think it will - s_mis has only ever asked this one question and doesn't seem to be active any more.

ahoffman - are you suggesting a split between yourself and garethwebbley?
I don't care about the points, I just think that we have valid and usefull answers to the question, so no reason for a 0 points PAQ.

If this question show grade, 50-50 splitting may be fair.
Most other comments just summarize the first 2.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial