RH8.0 and Apache 2.0.43

rog2054
rog2054 used Ask the Experts™
on
HI,

Fresh install of Redhat 8.0, without the bundled apache rpm.

Downloaded and compiled the apache 2.0.43 source, as per the instructions on the apache site - in the documentation section; ./configure, make, make install,...

when i run apachectl start i get a msg saying that it was unable to find a fqdn, and is using 127.0.0.1

As the machine is on a LAN, and does not have a domain pointing to it (at the moment), what should i set the fqdn to be? (and where do i set this?, i've looked in httpd.conf but couldnt find it)

I have added Listen 192.168.0.4:80 to the httpd.conf file, but i still get the same msg.

When i try to access the default website, either locally or over the LAN (same subnet) i get 'connection refused'.

This is not a firewall issue as i have tried it with the firewall set to 'allow all' on all interfaces in&out bound (obviously only a temporary setup until i get apache working!)

A list of running processes shows that httpd isnt running, which explains why i could not access the website...the question is why isnt it running? What do i need to change?
-i've only been using linux a few months so give a few details or links to more info as part of the answer please :)


Cheers
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
you can configure your FQDN in /etc/hosts. enter or change a line like this:

192.168.0.4    <hostname>.<domainname>    <hostname>

you can check your success with the command dnsdomainname.

--asem

Commented:
The ServerName directive is what is giving you trouble.  Set it to 192.168.0.4 and apache should startup just fine.
Jacob
Asem, spot on. Thanks a lot.

picoj, had already set the ServerName directive to 192.168.0.4, forgot to mention that in my original post. Thanks anyway.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial