Windows XP access troubles

rmacdear
rmacdear used Ask the Experts™
on
I have 3 PC's networked into a GVC router with print server. PC1 is a Win 98SE machine. PC2 is a Win 2000 Pro machine. PC3 is a Win XP Pro that is from work. I can access PC's 1 and 2 from PC3, but cannot access PC3 from either PC1 or 2. I can "see" PC3 from both PC1 and 2 using "find" or "search" for Computers. When I try to access PC3, a dialog box pops up asking for a password. The box has a message that a password is required to access resource "\\PC3\IPC$". I have tried to enter every password that I have, to no avail. I have looked through all the settings I can think of, to no avail. PC3 is from my work and has only a few user profiles, mostly for the administrators. I use a program called Netswitcher to change the network settings from work to home, and use Cisco VPN client to access my work e-mail from home. Any help would be a lifesaver. Thank you.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Because you use an workgroup and not a domain there is no central point to identify and authorize users. That's mean that each computer has to know who is allowed and who's not. If you need to access XP machine from win98 or Win2000 computers you will have to connect on these machines as one of the users already created on XP .
Logon on Win98 or Win2k with the same username/password as one of the existing users on the XP and it will work, or create on the XP machine a new user as the one used to logon on Win98 and another one as the one used on the Win2000 machine.

To logog on the Win98 as this user will be simple. Just enter username/password and it's done.
For Win2000 you will have to create this user on the 2000 machine . same username same password.

Mishou

Top Expert 2004

Commented:
disable simplified file sharing on the xp box
http://www.microsoft.com/windowsxp/expertzone/tips/september/stevens1.asp
then right click on the folder you want to share, choose sharing, share it, then click security, and add the user account from the w98 box and the w2k box

Commented:
You can get around this by enabling the "Guest" account on your XP machine (PC3).

Do enable the guest account, do the following :-

1) Click Start->Control Panel
2) Go into "Administrative Tools"
3) Go into "Computer Management"
4) Expand "System Tools"
5) Expand "Local Users and Groups"
6) Click on the "Users" Folder
7) In the right hand pane, select the "Guest" User
8) Right click and select properties
9) De-tick "Account Disabled"
10) Click "OK"

Now see if you can access PC3 from the other machines.

You will still need to make the permissions on the shares on PC3 either "Everyone" or do as Mishou says and create a user on PC3 and login as thet user on PC1 or PC2
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
Im inclined to agree with Mishou. Your problem exists because each computer has its own authentication system setup. You need to configure the same user on each of the pc's.

This is because each NT based platform (2k and XP) when in workgroup mode act in similar fashion to a domain with its own user accounts and passwords.

To overcome the problem create exactly the same user account and password on each box. You will then be able to map drives etc across each box using pass through authentication.

When you login on each box with this account your drive mappings will pass the currently logged on credentials to the LSA (Local Security Authority) of the box your connecting to. The connection will be seemless and no accounts information will be requested.

For your reference the IPC$ share is a hidden share setup on all MS boxes. You can use this share to authenticate to the entire box. When connecting to the IPC$ share you need to pass both the username and the password in your connections. ie. net use \\xxxx\ipc$ /user:administrator then when it attempts to connect it will ask for a password. (you most likely will not need to use this IPC$ connection for what you are after.)

rmacdear:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.

Author

Commented:
The condidtions have changed in this instance. PC1, formerly Win2K Pro, is now XP Pro. PC3, the laptop from work, is now on DHCP instead of Netswitcher. I have tried all suggestions here and still cannot get it to work. I would like to either delete this question and refund points, or resubmit with this revised set of parameters. Is it possible that my work adminstrators have diabled some setting that is preventing these suggestions from being successful? I have read very similar suggestions elsewhere, so I believe that they should work, any of them. Of note is that I cannot enable the guest account.
PAQed, with points refunded (50)

SpazMODic
EE Moderator

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial