Boot issue after breaking mirror

whynot
whynot used Ask the Experts™
on
My server will not boot to the OS.  I have SBS2000, and in
Drive Management, I had a mirror set as follows:

Drive 0: C:\
Drive 1: Mirror of C:\

I then removed the mirror and left the drive 1 with the
C:\ volume - thus drive 0 had nothing.  The system was
operating fine for the past week, and then I had to reboot
it last night - now it will not boot.  I get past the SCSI
post, and then where I should get the OS selection from
the Boot.ini, I get a post from the BIOS I believe - F1 to
Retry or F2 to enter setup.  That is it.  I do not have an
ERD that is valid, so I have been getting in through the
SBS2000 setup/repair/console to edit the boot.ini, but I
have not been lucky thus far.  Ideas?

Thanks in advance!

Casey
.

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
hello,

You have 3 options:

modify the boot.ini to reflect the change in the disk order
or
modify the SCSI ID of the disk that you use now to be the same ID as the disk that's empty now (ID 0 i suppose )
or
modify the boot order in the SCSI BIOS and specify to boot from ID 1 (or whatever ID is assigned to the working disk)

Try option 2.

Mishou

Author

Commented:
Mishou,

Thanks for the advice.  I think you may be on to something.  The first thing I did after this occured was to swap LUNs from what I believed to be the drives, then try and boot, but nothing.  Then I swapped them back and edited the ini, but nothing yet.  I believe the SCSI BIOS must point to the correct boot drive for it to boot regardless of the boot.ini correct?

Casey

Commented:
yes the SCSI BIOS have to know from what ID to boot.

When the machine boot pay attention to the IDs detected and then try them on your SCSI BIOS.

Mishou
OWASP: Forgery and Phishing

Learn the techniques to avoid forgery and phishing attacks and the types of attacks an application or network may face.

Author

Commented:
My BIOS will not let me change the boot drive - I have to make the boot LUN 0 to perform this change.

Casey

Commented:
well do it by changing the jumpers on the disk.
What SCSI controller do you have ?

Mishou

Author

Commented:
So I have reconfigured the jumpers so that the drive with the c volume is lun 0.  The SCSI BIOS now passes through the prompt (no prompt), but then it just hangs - no errors or anything.  I have edited the boot.ini numerous times trying to guess the appropriate arc settings, but to no avail.  Any more ideas?  Is there a way I can tell what the appropriate partition number I should use?  Thanks again!

Casey
Commented:
if nothing is working you might try as a last step measure to do a paralele install (use another folder for NT say WINNT2) just to be able to start winNT on that machine. Then you will edit your boot.ini and point it to your original winnt folder.

This in case you don't have the posibility to edit boot.ini from a floppy or disk.

If you do then do a boot.ini with many lines in it with diferent options for disk or partition and just boot until you find the right one

Mishou
<cleanup>-----------------------------------------------------------
whynot, please DO NOT accept this comment as an answer.
No comment has been added in the last 280 days.

RECOMMENDATION: Award points to Mishou http:#7460053

Please leave any further comments here within 7 days.
Thank you,

bkoehler-mpr
EE Cleanup Volunteer
</cleanup>----------------------------------------------------------

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial