DNS weirdness

MAVERICK
MAVERICK used Ask the Experts™
on
I have a standalone Win2000 server in a workgroup. The server uses external DNS servers and has an external IP.

The problem is that because the domain name is a fully registered domain name, when I perform an NSlookup, it automatically adds the mydomain.com suffix, even though the domain is a 2nd level TLD.

eg. looking when up google.com, nslookup looks up & returns the IP for www.google.com.mydomain.com

Can anyone shed light on this issue?

Regards,
Maverick
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2007
Commented:
IS this only happening in NSlookup ?

Is it only on this one server ?

Have you tried to remove the domain suffix from the TCPIP options ?

I hope this helps !
Hi!

Try this: Start nslookup. Type "set type=all" into the command line. Enter "www.google.com". Post the answer here. Then somebody perhaps can help you. (X-out your domain, if you wish).

Make a screenshot or write down the settings in the DNS section of the network settings on that server.

Lutz
Commented:
when do an nslookup, put a "." after the FQDN.  ie:  www.google.com.

Author

Commented:
Hi,

I actually didn't realize this Question was still open.

Please accept my humble appologies.

Sysexpert: This happens on multiple servers.

This only affects nslookup. Ping is normal.

I will try and remove the suffix when I am doing the next round of maintainance.

The network settings are pointing to our two unix servers.

Matt023: Your suggestion does work.

Regards,
--John
HiVelocity Support

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial