Can ping, cannot telnet

vic010
vic010 used Ask the Experts™
on
Hi

I can ping my RED HAT server but I cannot telnet from my XP PC, Networking has been set up (using GUI for now) and all seems ok. In the network configuration in settings I think I have done all that is needed.

Any other ideas?
I might not have started the telnet daemon, but I'm not too sure how to do it.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
awoodbySenior Technical Analyst

Commented:
you probably hit the nail on the head, by default telnet is disabled because it's insecure.  To reenable it,

you need to edit (with a text editor, i use vi from a terminal window but I'm sure there's a text editor gui)

/etc/xinetd.d/telnet

and change the line where it says

disable  yes

to

disable  no


write out your changes, then
service xinetd restart

from a terminal window, telnet will now work.

--alex
Gabriel OrozcoSolution Architect

Commented:
well, all distributions of redhat have the telnet service disabled by default, because it is extremely unsecure.

try to download the putty software, which is a free telnet/ssh client, and then try to connect specifying putty to use ssh. it will work and you will be able even to signin as root.

the link to download putty is:
http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
I use setup to configure any system service, at least most of them.

> setup

Choose services configuration and you can choose whatever services you want to enable or disable.

Redimido, I think when you use putty, you still need to have an ssh server installed on the server. Signing in as root can also be disabled just like doing so in telnet.
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

Gabriel OrozcoSolution Architect

Commented:
lloco_lloco: yes, but RedHat has ssh enabled by default, as most of the distros (I cannot remember of one that does not)

and because it is secure.

he can also use scp instead of ftp, and then he'll have al transfers and connections secure as long as he has his linux up to date.
If you want to telnet to your linux box, first you need to enable the service, go to /etc/xinet.d/ and open the proper file (telnet.d) and change the disable = yes to disable = no and then restart the xinet.d server
(go to /etc/rc.d/init.d/xinet.d restart)

But as Redimido said, keep it with ssh, and download a ssh client for windows like putty.

Regards,
Commented:
i think if you tried all their suggestions and still can't telnet your linux box, try looking at the file /etc/hosts.allow and /etc/hosts.deny.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial