DHCPD errors

forfarj
forfarj used Ask the Experts™
on
I am installing dhcpd 3.0.1 on a Redhat 8.0 box and can't seem to get the config file right. I have read the man pages and even tried ripping off some configs from the net just to see what is going on. To no avail. When I do a service dhcpd --full-restart to reread the dhcpd.conf file, it throws errors saying "command not found". It throws the errors on things like "network" and  "options". These from what I have found are very common commands. Help!

Justin
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2005

Commented:
Could we see your dhcpd.conf file?

Author

Commented:
Here is my first attempt at a dhcpd.conf file. As you can see I bastardized someone elses after getting nowhere on my own. Doesn't seem like it should be this difficult.

# dhcpd.conf
#
# Configuration file for ISC dhcpd
# KA ETHZ 03.12.2001

# Put PID file somewhere useful
# This can be used by scripts to kill the running DHCP server
pid-file-name "/var/run/dhcpd.pid" ;

# Log everything on this channel
log-facility local7 ;

# This server is authoritative for all subnets
# This means that if a client tries to renew an address that this server thinks
# is inappropriate, this server will send a DHCPNAK.
authoritative ;

# We should NOT do DNS updates
#ddns-update-style none ;

# Talk to omshell on this port.
# This is actually the default, but if you don't set it, OMAPI is disabled.
#omapi-port 7911 ;

# All clients get this domain name, unless overridden in subnet scope
option domain-name "stjohns.k12.fl.us";

# All clients get these domain name servers, unless overridden
option domain-name-servers 169.139.251.10, 169.139.251.15, ;

# The default lease-time is the lease time if nothing specific is requested
default-lease-time 57600;

# If a client requests more than the maximum lease-time, it gets the maximum.
max-lease-time 172800;

# Clients will be sent the DNS name associated with their allocated address
get-lease-hostnames true ;

# The server should check whether an address is in use before allocating it
# This is a simple and by no means foolproof way of avoiding address conflicts
ping-check true ;

# Do NOT support bootp unless overridden in a subnet scope
# Note that this doesn't satisfy the requirement to "deny dynamic bootp
# clients" in subnet pools if you are using failover.
deny bootp ;

# This is a locally defined option. The ETHZ is using Cisco VoIP; the Cisco
# phones get this option. Note that the name is irrelevant, the number, type
# and evential value are what count for the client. We could have called this
# option "freddy" if we wanted to.
#option ipphone code 150 = ip-address ;

#
# Our server hardware has two interfaces, one in subnet 129.132.1.0/24 and
# one on 129.132.98.0/24. We need to tell the DHCP server about at least one
# of them. For completeness, we tell it about both. Because we are using DHCP
# relays, and no clients are actually on the two subnets, we define no pools in
# these subnets, so no addresses can be allocated on these subnets.
#

# We want to listen on this network, but won't be allocating any addresses
# in it.
subnet 10.41.76.0 netmask 255.255.252.0
{
}

# We want to listen on this network, but won't be allocating any addresses
# in it.
#subnet 129.132.98.0 netmask 255.255.255.0
#{
#}

# Addresses for VLAN100, kom-id
# This is a "simple" DHCP scope; all the addresses in the subnet are managed
# by DHCP except the router and the broadcast address.
#subnet 129.132.40.0 netmask 255.255.255.0
#{
   # If you put the routers option (or any other option) inside the pool
   # declaration, it wil only apply to addresses given out from that pool.
   # By putting it in the subnet scope, it applies to all addresses served
   # out of this subnet.
   option routers 10.41.79.1 ;

   pool
   {
      # You MUST have this line if you are doing failover.
      # You MUST NOT have this line if you are not doing failover
      failover peer "dhcp" ;

      # You MUST have this line if you are doing failover.
      # You MAY have this line if you are not doing failover
      deny dynamic bootp clients ;

      range 10.41.79.20 10.41.79.25 ;
   }
}
Top Expert 2005
Commented:
You are on a private networ, so it is unlikely that your name servers will accept DNS updates for your hosts. So, you should uncomment the line that reads:

#ddns-update-style none ;

And in a like manner, you are unlikley to get host names for addresses in you private network from those name servers and should commnet out the line that reads:

get-lease-hostnames true ;

There's a syntax error in the file that's keeping dhcpd from starting. You commented out the line that starts with:

subnet 129.132.40.0

and the open { that is associated with that line. Which leaves your pool declaration inside of the that block. So there's a closing } that's on it's own. The solution to that is to move the pool declaration block outside of the subnet block and comment out the lone }. And inside of the pool you need to comment out the 'failover peer..." line.

You don't specify a default router for your clients. That can be done within a subnet declaration. So you need to create a subnet declaration something like:

subnet 10.41.79.0 netmask 255.255.255.0 {
  option subne-mask 255.255.255.0;
  option broadcast-address 10.41.79.20.255;
  option routers 10.41.79.N;
}

replacing 10.41.79.N with the gateway IP for your network.

I think that should do it.


Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

forfarj:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
Top Expert 2005

Commented:
Although it looks like we'll never know for sure I believe my comment addresses what was wrong with the configuration.
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is to:

Accept jlevie's Comments as answer

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Paul
EE Cleanup Volunteer

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial