problem "ELF file data encoding not little-endian"

victorli
victorli used Ask the Experts™
on
I installed Apache 1.3.27 binary and used mod_jk to connect it to Tomcat 4.1.12. They worked very well but when I tried to add modules by changing the configuration file httpd.conf , I got the erroe message "Cannot load xxx.so into server, ELF file data encoding not little-endian".

What is the problem and how to fix it?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
that is ok
please tell us which document you are confused about? apache or tomcat?
i found the document of tomcat4.1.12 on apache website is not good for reading...
:(

i used warp to connect apache with tomcat
wish to share the experience with you, victorli

:)

Author

Commented:
freshmeat, thanks for your reply.

I changed my question because I have got the connection going just after I posted the question.

Now I have got a new problem and hope you will give me some ideas.
victorli, i haven't met such problem as you described in your question.

but i may can help you if you can post some text of your httpd.conf, such as about xxx.so

thanks
:-)
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

Author

Commented:
I download the apache binary from apache website. I put "mod_jk-1.3-noeapi.so" to /usr/local/apache/libexec/ as "mod_jk.so". Also "workers.properties", "mod_jk.conf" etc under /usr/local/apache/conf directory. I found I just cannot add any modules by adding sth like:
....
LoadModule info_module libexec/mod_info.so
AddModule mod_info.c
....
I tried other modules such as mod_rewrite.so, mod_alias.so,  all have the same error. But if I did not add any modules, the apache can be started correctly and even worked with Tomcat.

Actually I want to install a RPM version of Apache1.3.27 binary to my Redhat system. It's strange I can not find one in Redhat official website. I found one in other website but the problem is the installation requires a "libdb3.2" package to be installed first. RPM refused to install this package because my system has got a newer version.

I am not sure if I need to compile the source instead of using the binary versions.  
oh, sorry, victor, i am afraid i can't help you more.
u'd better compile the source code instead.

i have met such "bad RPM" problem once, too, about tomcat.
at last i gave up that RPM of tomcat4.1.12


good luck!

Author

Commented:
The httpd.conf is like this:


....
Listen 80
#LoadModule rewrite_module libexec/mod_rewrite.so

#AddModule mod_rewrite.c
LoadModule info_module libexec/mod_info.so

AddModule mod_info.c

Include /usr/local/apache/conf/mod_jk.conf
#Include /usr/local/apache/conf/httpd_local.conf


Port 80
...

Author

Commented:
compile from soure than everything is OK

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial