Can't Ping Self

aswally
aswally used Ask the Experts™
on
I just setup Mandrake 9, I have installed many different versions of Mandrake before without problems, but this time I couldn't get the machine to ping itself.  I tried pinging its hostname, IP Localhost yet none work, yet I can ping other computers on the network.  

Can anybody help???

Thank YOU

Aswally
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Gabriel OrozcoSolution Architect

Commented:
please post the output of "ifconfig"

it should have at least an interfase called "lo" and the eth0 interfase also.

from there, we can go forward with your problem.

Author

Commented:
ifconfig does not exisit on this system

I can tell you the config:

eth0: Realtek 8139 using the 8139too module, ip 192.168.1.6
lo: the usual ip of 127.0.0.1


Commented:
try /sbin/ifconfig

Normally ifconfig should be on the system

The pinging issue can be caused by a preloaded firewall (iptables)

If you have loaded a fw then put in the fw the following rule :

IPTABLES="/usr/local/sbin/iptables"

#Allow traffic on the local loop
$IPTABLES -A INPUT -i lo -j ACCEPT
$IPTABLES -A OUTPUT -o lo -j ACCEPT

Maybe this can solve your problem
Rowby Goren Makes an Impact on Screen and Online

Learn about longtime user Rowby Goren and his great contributions to the site. We explore his method for posing questions that are likely to yield a solution, and take a look at how his career transformed from a Hollywood writer to a website entrepreneur.

Gabriel OrozcoSolution Architect
Commented:
ifconfig should exist in your system.

if it is not there, then it seems like you forgot to install something.

try locating it:
locate ifconfig

maybe is not in your path, which in turn is another problem as ifconfig is part of the core linux networking utilities.

if that's all the problem, then add that path to your PATH environment variable in /etc/profile

also it can be the firewall problem. to clear (for a moment) your firewall, type
iptables -F
iptables -F --table nat
iptables -P INPUT ACCEPT

and then you should be able to ping. if that's the problem, then check your firewall settings.
Commented:
try

> cat /proc/sys/net/ipv4/icmp_echo_ignore_all

if that give '1' then your machine is configured to not reply to ICMP echo requests (ping). then try

> echo 0 >/proc/sys/net/ipv4/icmp_echo_ignore_all

and try pinging again.

--asem

Author

Commented:
Sorry People but this problem has been resloved.  

The non-ability not to ping is actually not a problem, as everything else works fine, its just an extra security feature.  

Thanks

Author

Commented:
I think I'll split the points among you all as this didn't go any where further

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial