My scanner doesn't work!!!

chriska
chriska used Ask the Experts™
on
I installed a scanner HP ScanJet 3300C on a computer running Windows 2000 Professional and connecting to a network.
The problem is that when a user logs on the scanner doesn't work but when the administrator logs on, the scanner works. I'm having two messages when a user tries to use the scanner. The first one is:
- There is a problem with the registry settings. One or more settings were reset to the default values. [2099]

And the second, which appears when I press the OK button in the first message:
- An error was detected in your scanning software settings, Please reinstall your scanning software. [2141]

I tried to reinstall the software but it still gives me the problem.
What should I do?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
give a user admin right log on
then reinstall
they that

Commented:
A possible cause could be that the user whom receives the errors, has insufficient rights on the folder where the software installed.

For testing purposes, try giving that specific user Full Access on the installation folder.

Commented:
It is also possible that you installed the software for the admin only and for the other users accessing the computer.
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

Top Expert 2007

Commented:
You need to give the user r/w permissions on the registry entries for the scanner.

I would chekc the HP site for any patches and suggestions on which entries need to be changed.

I hope this helps !
Make sure the scanner was installed under the admin ID.
You need to give the user admin rights to the printers registry.

Be carefule about this:

Go to Start -> Run -> type "regedt32"
select the HKEY Local Machine
Select hardware and find yor scanner.  
Give all users Full Control permissions under the security setting for your scanner
Is this a USB scanner connected to a hub? I have had a similar problem that resolved after I connected the USB cable directly to the computer instead of a hub. I don't know why it worked, but it did work.
I recently had this problem...
1)I logged on as Admin and installed the appropriate software
2)Included the executable in the all users file

This should allow anyone access to the scanner (you could incude it in the Start Menu to help)

This is what I did in our NT lab that is used for our yearbook class
Every kid can now use THEIR log-on to that machine and still have local access to the scanner.
-J

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial