Windows ME network problem

estg
estg used Ask the Experts™
on
I am trying to hoook a laptop to a peer to peer network comprising of 6 machines. The OS is Windows ME. The problem is that when the laptop boots, I cannot see my network, but if I log off and then login again, I am able to see the network. Can someone please suggest me a solution to this? I tried changing the network card and but no luck.

thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Are you running DHCP?  Make sure your settings are correct for TCP/IP and NetBEUI.

Commented:
what address does the laptop have right after boot. that will enable us know what it sees first time

Author

Commented:
No, I am not running DHCP, and my TCP/IP & NETBEUI settings are correct. Further none of the machines have IP addresses i.e. they obtain automatically.

thanks
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
from the dos command prompt, run ipconfig and copy down the ip address, subnet, and gateway.  Then change your tcp/ip from obtain automatically to manually specify.  Then go to one of the pcs on the peer network and then ping that laptop ip address.  See if it comes up.  Also did you set up network sharing option on the laptop?  Thats what you should do first.
Les MooreSr. Systems Engineer
Top Expert 2008

Commented:
>The problem is that when the laptop boots, I cannot see my network, but if I log off and then login again, I am able to see the network.
If you are not using WINS or LMHOSTS files, then you are depending on MS Browser function that builds the browse list based on machines sending out broadcasts that they have joined the network. One PC will act as the browse master. Each one that comes on will think it is also a browse master and force an election. Who knows which one will win, unless one is NT/2K server which always wins. If you can't see the network in network neighborhood as soon as you boot your laptop, just give it a few minutes. It can take up to 15 minutes for the process to complete and give you a complete browse list. Logging off and back on again simply gives the network that little extra time.
The problem is ME. You know why it is not on any corp networks and why it is not around anymore?

Can you get it to work? Yes
Will it always have problems? Yes

Anyone out there have a network full of ME machines? No

I know that this sounds like a copout but you should keep all your workstation the same, if posible. To simplify network trouble shooting.

Good luck with ME.
Top Expert 2004

Commented:
>No, I am not running DHCP
>Further none of the machines have IP addresses i.e. they obtain automatically.
Then you are trying to run dhcp, you just don't have a dhcp server
If the clients are checked to obtain an ip address automatically, this means they are set to use dhcp
>and my TCP/IP & NETBEUI settings are correct
your tcp is not set correctly, if you don't have a dhcp server
suggest this ip configuration
Mach #1
ip 192.168.0.1
subnet mask 255.255.255.0
gateway blank
disable dns and wins

Mach #2
ip 192.168.0.2
subnet mask 255.255.255.0
 gateway blank
disable dns and wins


mach #3
ip 192.168.0.3
subnet mask 255.255.255.0
 gateway blank
disable dns and wins

and so on for all the machnes

Author

Commented:
thank you very much

Commented:
While I agree that ME has many networking problems, this situation is not hopeless. This is a common problem.

Long Story Short, Windows is trying to logon to your network incorrectly, or with insufficient data.

If this is the case, it can be verified by doing the following:
1. Open your Control Panel
2. Goto Network
3. Change the Primary Network Logon to "Client for Microsoft Networks".  
NOTE:  If it is already set that way, change it to Windows Logon, reboot, log in, change it back to Client for Microsoft Networks and reboot again.

4.Go to Run in your Startmenu,
5.Type Regedit and click ok.
Navigate to the following:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Network\Real Mode Net

6.If you see AutoLogin on the right and it has a value other than 0, double click it and change it to 0 (zero).

7.Close the registry editor and reboot.

You should now get a logon screen at startup.  Assuming you are using no password, you can now change the Primary Network Logon back to Windows Logon, so it won't showup every time.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial