HD recognition problem on win98

zayedj
zayedj used Ask the Experts™
on
I bought a 40 GB Wetsern HD, and tried to put it as master with my old 13 GB wetern digital HD (the 13 GB is slave), on the bios everything is fine , and both are recognized but when I enter on win98 the 40 GB is recognized while the 13 GB is not seen at all,
I tried making the 13 GB the master and the 40 GB the slave and it worked fine , Why is that?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
This is NOT a Win98 issue.  It's a BIOS issue with your motherboard.

You need to do one of:

1) Get a BIOS update that supports hard drives larger than 32GB.

2) Use the WD supplied HDD overlay software.
Specialist 1
Commented:
Hmmm... No offense Jhance, but i dont think that will resolve his issue.  He can see both drives...but at different times.  So that does not sound like an overlay issue.  And to upgrade his bios to see more than 32gig, is not necessary if he can see the 40 gig but not the 13gig....as he stated.  

Zayedj,
While in Win98 with the 40 gig as master, can you go to a command promt(run, Command) and type in FDISK and see if it can see both drives via FDISK?

It is possible that the 13gig has some security measures like NTFS that will not allow it to be slaved and viewed by another system/drive?

Just throwing some suggestions out...
If your bios sees it properly, it has to be some issues with the way it is set up...or how it is being seen by the system.  

Commented:
Good call Wakeup.

In addition if it is not due to NTFS (New Technology File System ie.. NT), if that hard drive was one distributed from a proprietary PC company ie.. gateway, dell, or comcrap then they (on some older systems) write a special sector to the harddrive that does not allow it to be seen. They do this so that you have to use there special Boot Recovery CDs to get the system up and going again (try and keep you in thier support plan).
What happens is that the OS and all data associated to it (installed through it) is accually underlayered into a type of separate partition on the hard drive.  
What Ive always done in those cases is just flat out formated the drives to get away from there junk. Then goto there website and download the drivers for the board and installed them separately.

OK back to your question. To know if the Harddrive (13Gig) data is layed in under a layer, boot with a windows 98SE boot disk. At the C> prompt see if you can see any data there ie.. windows. Do a C:>dir  [enter]

Please report back with what you find on this.

Also you might try making sure that when you make the 40Gig the Primary that the Data cable connects to it first then ends at the 13 Gig.
Also double check to make sure you have the jumpers set correctly to Slave on it and not as cable select. Refer to the Western Digital website to get the correct jumper settings for that hard drive. I have had in the past a hard drive mislabled on the jumper settings and had to goto the site to get the correct one.

Author

Commented:
well thanks jhance and wakeup but it still doesnt solve the   problem
jhance,
the bios supports over 32gb , the problem is not in the bios

wakeup,
In the command prompt the partitions are not seen, though they are  fat 32 not ntfs ,yet I will try using fdisk as you said and I will keep you notified,
by the way when I transferred some files between them and then put the 40 GB as mster again the files were, when I put it  back as slave the files were there

again, Thank you for your time

Author

Commented:
Actually I dont know  what the problem is, though it is solved now , I just formatted both HDs and then everything went well , I guess they mut hve been partitioned using  different utilities , atleat I now one was partitioned  using EZ.

Thanks lot for the help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial