Raid Failesystem !!!

manjuravi
manjuravi used Ask the Experts™
on
we are placing problem while installing the Oracle. ie. When we excuted the oracle to create dbf,rollback,indexs... on raid filesystem. We found that battery of Raid has expired. We have storage A1000, we changed the battery and re-instated the expiry date with raidutl -c <device> -r command, rebooted the system but Unfortunately the device could not mount or not seen. Why ?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
The command option for reset the battery age is:

raidutl -c <device> -R

after your issued the command, you should see a message like:

raidutil succeeded!

on your screen.

use:
    rm6
    Sun Raid manager to check it out.

    PS: Replace the battery (need a few hours to allow the batter recharge). then run:
    raidutl -c <device> -R

    run rm6 - the recover guru to fix your problem.

Good luck.

Author

Commented:
Hi,

Thanks for u comment, we tried as u said, but unfortunately the raid file system is not seen by system,even after we boot.

when we check the msgs. we found that
rdaemon is not get loaded, while trying loading it give error Could not open RDACnode and error no = 6(no such device present)


Thanks & regard

Author

Commented:
Hello !!

No one out there to help me regarding this question !! or the question is not clear !!...... Pls i am in very much in need of answer for this question .


Thanks
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

It is very hard to tell you exactly what you need to do without knowing the details about your system.

eg, The OS version, and the Hardware platform.

I assume that your A1000 was working before.

I suggest that you boot up your systems from CDROM, and then run fsck to all your file system, then reboot it.

BTW, did you install any patch/software before the system failed ?

You can also search SunSlove for help,
http://sunsolve.sun.com/pub-cgi/show.pl?target=home

Or the Sun online support to ask them give you a hand on this.

Good luck!

Author

Commented:
We have sun e5500 server 2GB RAM 4 Sparc processor, with Solaris 7 and sun stoarge A1000 [12*10 GB] having Raid installed in it.

Yes we installed patches, successfuly rebooted the system it was running fine.

But After the installation of Oracle 8i ver 8.1.7, rebooted the system after this point the raid is not accessible. co-incidently the battery also failed, which was replaced, but still we find this following log msg;

rdaemon is not geting loaded, while trying loading it give error Could not open RDACnode, error no = 6(no such device present)


Under sunsolve when we check it recommends to do Boot -r, we tried the same but no luck.

Regards






Did you try to contact Sun? Or if you want more people on this site have a look at the problem, increase the points to 250-500. I'm on leave at the moment, not close to a box with a A1000.



Commented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

PAQ and refund

Please leave any comments here within the next four days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

liddler
EE Cleanup Volunteer
PAQed, with points refunded (25)

amp
Community Support Cleanup Moderator

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial