Can't change printing preferences locally

RiverMonster
RiverMonster used Ask the Experts™
on
Hi,

I have Windows 2000. I want to change the printing preferences for a shared printer. (Not the default preferences, just those used by me).

In the Printers panel, I choose the printer, right-click to choose Printing Preferences and then change the settings to suit my requirements. Then I click OK. However, when I repeat the steps to check the settings I see that they have reverted to the original values. Any idea why this happens?
 
According to the W2K Help, if a user has Print permission for a shared printer then he/she should be able to change the printing preferences for that printer. I do have Print permission.

Thanks,

Adrian
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
What you are experiencing is the new plug and play abilities for 2K+, you are most likely viewing the actual printing preferences from the server and those that you assign locally, to overcome this install a second printer on your local machine (don’t browse the network to connect to it) attached to LP1 then you go to the printer properties and select the port tab, add a new port, choose local and type the in the unc path (\\servername\printersharename).

After this you can change the settings to your harts content.

Author

Commented:
Thanks David,

I couldn't get your suggestion to work at first, but then I tried entering the IP no. of the printer instead of the \\servername\printsharename and it worked great.

Incidentally, I also found another solution:

i) Remove the network printer
ii) Remove all registry information concerning the printer
(see MSKB article http://support.microsoft.com/default.aspx?scid=kb;EN-US;135406)
iii) Reinstall network printer

Thanks a lot,

Adrian

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial