How to enable Bitmap Index feature in Oracle 8i Enterprise edition

hemasai
hemasai used Ask the Experts™
on
I'm using Oracle 8i Enterprise Edition.
I tried to import Datawarehousing sample schema
in Oracle8i.

It returned with an error saying
"BITMAP INDEX FEATURE NOT ENABLED".
In the Oracle 8i Documentation(error messages)
in the action part it was mentioned that
"DONOT USE THIS FEATURE" which I feel is not
correct as I'm using Oracle8i Enterprise Edition
and bitmap Index feature exists in this version.

Pls let me know as soon as possible as
HOW TO ENABLE BITMAP INDEX FEATURE IN ORACLE 8i.

Thanks & regards

ramana(hemasai)
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
eagerly waiting for an Answer.
CREATE_BITMAP_AREA_SIZE default is 8mb

BITMAP_MERGE_AREA_SIZE default is 1mb

Perhaps you could check to see if theses parameters are set and have sufficient values to accommodate your requirements.

Are you absolutely sure you are using 8iEE?  Also I can't find the any reference to 'DO NOT USE THIS FEATURE' in the error message doc, but the copy I have is about a year old.  What is the error number?

Author

Commented:
Thanks for the reply.

Yes I'm using Oracle 8i Enterprise edition Only.

Pls be patient and go through my entire text.

Do You mean parameters in init.ora file?
If so I have made the changes in the file as stated by
you in this manner.
CREATE_BITMAP_AREA_SIZE = 8
BITMPA_MERGE_AREA_SIZE = 1
I could successfully open the databse in SVRMGR utility.

It gave me the following error message when I tried to connect to Oracle session(SQLPLUS)

Error accessing DBMS_APPLICATION_INFO
ERROR:
ORA-00604: error occured at recursive SQL level 1
ORA-00067: invalid value 1 for BITMAP_MERGE_AREA_SIZE; must be atleast 65536.

Then I changed the value of BITMAP_MERGE_AREA_SIZE to 65536 and connected to SQL session. This time it didnot raise any error.

Then I tried to import a schema(warehouse example from Oracle documentation -- samplestar schema) which requires the creation of bitmap indexes. It gave me the same errors that it was giving before I made the changes as suggested by you.

The following are the errors during the import.
pls go through them carefully.

IMP: 00017 FOLLWING statement failed  with oracle error 439

CREATE BITMAP INDEX .........

IMP:00003 oracle error 439 encounterd.
ORA-00439: FEATURE NOT ENABLED : BIT MAP INDEXES



Clarification:

When you go to the Oracle error messages
it was given as below. please chech error number ORA-00439

ORA-00439:
Cause: The Specific Feature is not enabled
Action: Donot attempt to use this feature.


Pls find out a solution for enabling Bitmap Index feature and let me know as soon as possible.

Thanks & Regards
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

I did mean the parameters in the init.ora.  Furthermore the correct way to specify the parameters is shown below.  I apologize if that was unclear.

CREATE_BITMAP_AREA_SIZE = 8388608
BITMAP_MERGE_AREA_SIZE = 1048576
 
Check the parameter COMPATIBLE in the init.ora as well.  It must be set to at least 7.3.2 to use bitmap indexing.

There also seems to be some information leading to the idea that partitioning must be installed and enabled.  Check wether the partition option is turned on.

select * from v$option where parameter = 'Partitioning';

If partitioning is False, then you can install the partition option and give a try.

Optionally you could look at the banner in SQLPlus to see if partitioning was installed.

For example mine is:
Oracle9i Enterprise Edition Release 9.0.1.1.1 - Production
With the Partitioning option
JServer Release 9.0.1.1.1 - Production

Let me know how it goes and if you need more assistance.  


Author

Commented:
please Let me know How to enable
partitioning option as it was not enabled ?
You need to install it.  Run the universal installer and select this option for installation.  If it is a production db I would suggest looking into any repercussions.
Helena Markováprogrammer-analyst

Commented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:

Accept qhanrahan's comment as answer.

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Henka
EE Cleanup Volunteer

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial