Backup Exec not finding tape drive after working for years

wasser
wasser used Ask the Experts™
on
I'm running Seagate/Veritas Backup Exec v 7.01 on Windows NT 4 sp6,
The program has run mostly flawlessly since installed over 3 yrs ago.
Now all of a sudden, BExec can't see the tape drive.
I've done the following troubleshooting:
1)  reinstall BExec
2)  download and install new copies of the Tape device driver
3)  open the case, and re-seat the SCSI card (note the tape drive is the only thing running off that card), remove and reinstall cables
4)  check in Control Panel - the tape device is there, driver loaded and no conflicts exist
5)  if I stop all the BExec services, and run  NT Backup, that program can see the tape device
6)  if I stop all the BExec services, and run Segate tape diagnostics, the diagnostics run to completion successfully
6)  all of the BExec services, and the device drivers get started when they are supposed to @ boot up.

Why can NT Backup and the Seagate Tape diagnostics see the drive, but Backup Exec can't??

Any ideas much appreciated!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Things to check:

Has any software been installed recently? if so uninstall it.
Has the backup exec assigned user been deleted from the user database?
In my experience, if it isn't a hardware fault, things don't just stop working unless something has been changed, so review any changes to the system at all and see if they have affected the problem by undoing them.

Sorry it's not much of an answer but i know sometimes i need a kick to think of the obvious.

Marion
One thing you can check backup exec using its Media and Device database file  which might be corrupt and that could be reason backup exec not recognise the tape device.

have you tried to uninstall and reinstall the Backup exec. that will solve your problem. but make sure you removed the files and directory fron the installation path. And yes  make sure you have all backup jobs definations,catalogs and mediaset informations backup so you can use later once you reinstall the backup exec.

There is one *.mdb file it is using  to store all the information and its so frequent to get corrupt this file.
I faced same problem and able to solved this way. OR you can also check any body install MDAC updation or something liek that installation on the server. that will be one of the cause. soem of the MDAC  upgradation are not suitable .

best of luck.

Author

Commented:
ritupatel
Thanks for pointing me in the right direction!!

When I checked the pvl.mdb database using Access, I was able to open all the tables except the drive table.  Unfortunately I wasn't able to repair that table and all my attempts to recreate a complete set of tables (so I wouldn't lose all my media sets & physical media labels & tape rotation info) were in vain.  

However, once I replaced my pvl.mdb file I am again able to see the drive, and I have a backup currently running...

Other helpful resources for this problem:

What is the PVL.MDB and what considerations should be kept in mind when replacing it.
http://seer.support.veritas.com/docs/237368.htm
this is what I ended up having to do- replace it-

How to check the integrity of the Device and Media Database (PVL.MDB)?
http://seer.support.veritas.com/docs/241430.htm
tried this, but was unable to repair the database

How to modify the PVL.MDB file to remove all device information but keep all media related information intact.
http://seer.support.veritas.com/docs/244171.htm
tried this, and was able to see the drive, and keep my custom media sets etc, but even though I could also see the drive, backups failed...
The links also helped my situation.  After creating the ODBC source and the subsequent repair option, my tape backup is back online.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial