Exchange Server 2000 and .local using OWA

geof-c
geof-c used Ask the Experts™
on
We are running Exchange Server 2000, and as a security policy, only certain users are permitted internet mail. Those that do NOT require internet mail have email addresses in the form "johndoe@domain.local" and those that do have internet email have the address "johndoe@domain.com" .

We want to use OWA internally, however when a user has a .local extension on their smtp address, they are not able to access their email through OWA. The authentication doesn't seem to recognize them as members of our domain.

Any tips on either:
a: another workaround policy for not allowing certain users internet email so they keep their .com extension,

or

b: a workaround for allowing them to log in to OWA while they have a .local extension

???

Help!

Thanks in advance!

Geof-C

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
When yor users are logging into OWA, are the using their short domain name or their full smtp address as their usrename?

Author

Commented:
they are using their short domain name (OWA prompts for username, password, and domain).

This is strange, the SMTP address should have nothing to do with logging into OWA. If you add a .com address to one of these accounts, can you then log onto it?
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

Author

Commented:
they are using their short domain name (OWA prompts for username, password, and domain).

Author

Commented:
I just added jblow as a user. Gave him his own mailbox, and smtp address of jblow@domain.local AND one called jblow@local.com .

When I open up OWA, it prompts for the username, password and domain..

I tried jblow / password / domain  <-- Nope
I tried jblow@domain.local / password / domain <-- nope
I tried jblow / password / domain.local <-- nope.

*sigh*

Maybe my best bet is to find another way to restrict the internet mail routing from certain users, without having to change their smtp address from the .com to .local (This was a solution provided by Microsoft).

Geof

Author

Commented:
I also tried logging in to the OWA as
jblow / password / local ,
jblow@domain.local / password / local
jblow / password / local.local

All of which failed. :o((
You need to add the domain name in from of the username, ie domain\jblow

Author

Commented:
using the domain\jblow combination didn't work either...

But good idea...

I wish I had more points to "donate" for this, but being completely new here, thats all I have.

Geof

Commented:
Hate to tell you this, but your scheme is backwards to the way the authentication requires.  A subdomain of local.domain.com is the way to do it.  Local emails should then be via user@local.domain.com instead.  Otherwise you're going to run into this problem of the naming convention:  domain.local is a completely different place while local.domain.com is a subset of the same place, see?  I can't think of any way to get it to accept domain.local...  Does this help at all?  Is it too late to rearrange your name plan?
Try leaving the domain field blank. Type domain\user for the username.

Author

Commented:
The name plan is in place, and the .local policy settings were direct from Microsoft.

I just tried the domain\user for the login name and the password, using both
domain\johndoe and
domain.local\johndoe

Neither works - I still end up after 3 attempts getting the "unauthorized" message.

I'm almost ready to go buy a very large hammer.

Geof

Author

Commented:
Thanks, will check this out as well...

Commented:
This may be an abandoned question or perhaps forgotten?  
I will add this to a cleanup list to be reviewed by EE moderators.

<recommendation>
status of this question please?
</recommendation>


If anyone participating in this Queue disagrees with the above recommendation,
please comment in this queue for the moderators.

Thank you,
SB


Author

Commented:
It would appear I we are at a standstill... there seems to be no solution viable for this task. I am currently researching other avenues of limiting the internet mail, so thanks, but feel free to close this discussion... :o((

Geof
Refund PAQd.

SpideyMod
Community Support Moderator @Experts Exchange

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial