ADODB.Recordset Error

GerryRhodes
GerryRhodes used Ask the Experts™
on
I am trying to create a login page using an ASP dynamic page from Dreamweaver MX and connecting to an Access database.  When I set up the db connection and click "Test" it comes back OK but when I load up my browser and run the page I get "The Page Cannot Be Displayed" and the following error message:

Error Type:
ADODB.Recordset (0x800A0046)
Permission denied
/10_cms/WorkingFiles/10_cmsmanage/10_index.asp, line 14

Line 14 in 10_index.asp is:
MM_rsUser.ActiveConnection = MM_dbconn_STRING

I have been fighting with this for some time so I think it is a hard question but I suspect that it really is something simple that I need to do in terms of setting up rights in II or Access.

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
MHQ

Commented:
what is the value of the variable MM_dbconn_STRING?
Commented:
Make sure the web folder your page resides in is setup for the authentication you are using.

Are you using integrated windows authentication (using your windows login info) or basic (username and password)?

To view or edit your folder settings
in windows 2000:

Control panel/administrative tools/internet services manager>
browse to folder & right click>
select properties>
directory security tab>
edit button>
 
cant you just recreate your connection?

or you can create a 2nd connection right?

Commented:
1. The folder with your site (and db) must be webshared
2. The folder must have read permissions fot IUSR(machinename)
3. The folder must have read/write permissions form IWAM(MACHINENAME)

The easiest way to achieve this is to go to start>programs>administrive tools>Internet Services Manager.
Expand the tree untill you see the specific site.
Right click. Choose all tasks. Choose Permissions Wizard.
Select security settings from Template. Choose Public website.

If that doesn't do it. Go to Win Explorer, find the folder in your wwwroot. Right click. Choose properties. Click the Websharing tab. Make the folder shared. Clich the security tab. Add the users i mentioned above. Give them the right permissions. If you are not on a public machine you might choose to sacrifice some security for quick result and give them temporarily full control. (If your site works again, lower the permissions level again)
Click on advanced. Check Reset permissions on all child objects etc.

This is the order to do it. I have been in the hell you are several times and believe me, i know. Win2000 has the tendency to reset permissions withour asking after applying some upgrades, after installing webrelated software like the DotNet Framework and so on. Very annoying!!!


Author

Commented:
thanks for your help . . . i changed to integrated windows authentication and it worked!  thanks to the others who responded too . . . u guys are all a lot smarter than me and i appreciate your comments . . .

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial