upload files to ftp server

irelandone
irelandone used Ask the Experts™
on
Hi my problem is that I am unable to upload files to the ftp server.  OS is Windows XP PRO
Have installed IIS opened ports 21,22 on router and forwarded them.
created user, that user has been made part of admin group because the "add site administrator" button was grayed out.
on the IIS manager I have set Read Write rights
I have try both allow anonymous access and not allow.
When I try to connect I get prompted for username/password
doesn't matter what I enter it gets bounced.
I have shared the complete drive or must I share the Specific folder for ftproot?

Thanks for you help


Tom


Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2004

Commented:
try sharing the specific folder
give the administrator username and password
check the permissions on inetpub\ftproot
Just a simple rule of thumb when dealing with IIS and permissions. If IIS requires full contol, give the rights in IIS - full control. But, use the NTFS permissions on your files/folders to lock down the permissions you want for access to the folders. Most people get confused by the permission settings in IIS. IIS permissions are ONLY for IIS, they DO NOT apply to NTFS file permissions.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Hi,

try also forwarding port 20 (ftp-data) on the router, since 21 is only the control-port and 22 is ssh

ftp-data        20/tcp
ftp             21/tcp
ssh2            22/tcp


Commented:
The webserver should work with anonymous access easy enough. Note that is no user of NTFS. AND it is not only not recommended, but a major hole. Still, it did no work? Likely then your OS has it blocked, I vote keep it so.

I do not run IIS since it is viewed as too exploitable. So I dunno, But I'll suggest that you allow access to your known users in IIS, and for Windows server to allow your defined users to access over the remote connections. Let XP handle the authentication for all sides.

Commented:
Have IIS utilize NT authentication.
Hi,

create one user called samples in active directory

Install iis and in iis manger create ftp site called samples and specifi the folders path like d:\samples.

not set the ntfs permission for d:\samples folder and give everyone ---------none
system---------full
administrator-----full
samples ( user ) -----full


and then tell me


narendra

Author

Commented:
Not really sure what the problem was however going through it again and not setting any actual permissions seem to work.  So now I'll work around setting up actual permission for users and see if I can recreate the problem.
Thanks for the input.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial