the memory could not be written/read

loyaliser
loyaliser used Ask the Experts™
on
having a serious problem w/ explorer.exe.

i keep getting the same error as described here:

http://support.microsoft.com/default.aspx?scid=kb;en-us;267858

also get same error, but says "could not be written" instead.

each time explorer dies, i have to run it again via task manager, but then crashes again the moment i open my computer, my documents etc. somtimes explorer.exe keeps crashing continuously no matter how many times i restart it.

i thought it was laptop overheating, but turned it off for a few hours, cooled down, and booted up only to have same problem immediately.

but i have SP3 installed and all the latest patches... even ran a scandisk!!! what's going on... any advice?

also, i checked the notes in the KB article above and verified that .dll file... it is a later version.

thanks...
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
just tried some things:

1. went into safe mode w/ networking... same problem occurs the moment i go to start/documents
2. disabled all the web features for explorer (single click on files, active desktop etc.) and still have same problem...

came back into windows, in normal mode... looks fine actually and not having any trouble... did just going into safe mode fix it???? is that possible?

Author

Commented:
well, spoke too soon... restarted laptop again into normal mode and the problem returned.

my best guess is some other application is using memory space for explorer.exe, or vice versa... right? is that what the error is about?

so how do i find out which application it is?

Commented:
No, this means that Explorer is reading (or writing) to an area of memory it does not have permission to access, which causes the crash you're seeing. Unfortunately there are so many possible causes of this problem it's difficult to know where to start--personally I'd run a virus scan on the machine to start with.
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

Commented:
Many people mistakenly believe that this message indicates a RAM problem on the machine.  But, in fact, that has nothing to do with it.

As pjknibbs noted, this is caused by a PROGRAMMING ERROR in whatever application is faulting and really means that somehow the program has become confused about where it can read/write data in memory and has hit an area that is protected by Windows.

You really are not in any position to debug such a problem since you don't have access to the source code.

Since EXPLORER.EXE is causing this, it MAY be EXPLORER.EXE itself but most likely it's being caused by an EXTENSION or other Windows Shell "hook" that you've installed.

My advice is to UNINSTALL all applications that you've installed recently and get back to a state where things were working properly.  You should also try running the Windows 2000 System File Checker (SFC.EXE) and see if it picks up any corrupted or mismatched DLLs or other system files.

If all else fails, you may need to wipe this installation out and re-install a clean copy of Windows, but I wouldn't go there until I've exhausted all other possibilities.

Author

Commented:
to jhance:

that is a very thorough and good comment... thanks.

after a few more hours of working on this problem last night, i reached similar conclusions.

questions:

1. instead of uninstalling things i have installed prior to the error, is their a way in win2k to boot up in a debug mode? i noticed that option during F8 boot-up... will this help locate the problem?
2. what does sfc.exe do exactly? i need a good online guide for it... w/ screenshots etc. so as to know what to expect etc. it could find many dll files, question is which to restore!
3. isnt there a way to dump this error into a log file and send that to MS to be debugged, and possibly locate the problem? assuming the log file would contain some kind of memory dump...

thanks again.

Commented:
1) I've found that Windows "SAFE MODE" is not useful for this type of issue.  EXPLORER still loads its extensions in "SAFE MODE" and so the problem may persist.  Even if it doesn't crash, however, I don't see how that will help you.  Unless you're going to continue to run in safe mode forever, you must somehow get rid of the problem.

2) Open a CMD window and type:

SFC /?

this gives you a list of options.  I suggest running it like:

SFC /SCANNOW

3) Yes, you can enable DRWATSON on your system BUT Microsoft DOES NOT ofer this free.  You'll have to open a support call and pay IN ADVANCE with your credit card.  It's not inexpensive and there is NO guarantee that they'll fix your problem.  Plus, it's quite likely that Microsoft code is NOT the issue.  Then, you'll be out the money and still without resolution.

Author

Commented:
to jhance:

thanks on those answers... something else i would like u to see is a post that may be related to this problem:

http://www.experts-exchange.com/Operating_Systems/Win2000/Q_20404984.html

im thinking that this basesrv warning may be the problem??? please let me know what u think... thanks.

Author

Commented:
more information...

i kinda pinpointed something... when using windows explorer, after i browse into a folder containing image files, the explorer window crashes with same error.

i then rename the files to something like .jpgold or .gifold etc. (so they r recognized as non-image files)... then browse into the same folder and it does not crash.

i have tried this using the different views available: large/small icons, details etc. all with same effect.

any thoughts on this?
Commented:
Sounds to me like you have a Shell Extention column handler that is failing.  For example, a column handler for JPEG may read in the the JPG and extract the length/width of the picture and such.  One for DOC files may read Author information, etc.  

To troubleshoot, you could rename GUIDs so they don't get loaded.  

From
HKEY_CLASSES_ROOT\Folder\shellex\ColumnHandlers\{24F14F01-7B1C-11d1-838f-0000F80461CF}

To
HKEY_CLASSES_ROOT\Folder\shellex\ColumnHandlers\{24F14F01-7B1C-11d1-838f-0000F80461CF}-Disabled


To read more about how column handlers work.  Take a peek in the MSDN.

Creating Column Handlers
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/shell/programmersguide/shell_int/shell_int_extending/extensionhandlers/columnproviderhandlers.asp

Author

Commented:
DebugNT:

that sounds plausible, and an interesting approach... however, last night i found a fix for the problem... not a very good fix though.

apparently, image files that were buried too deep in folders (e.g. that path to the files was over 90 characters or so), when browsing those folders win explorer dies... and basically any application the uses a dialog box to open these files.

so i renamed the folders to shorter names and now it works fine?!?!?!

could this be related to Shell Extension column handler issue that u suggest???

thanks for the input...

Commented:
Yes, definately.

Does this reproduce with a Default install of Windows 2000 without other graphic programs and such?  If it does, then I'd be curious to see if I could reproduce it.

My thought is that it doesn't, and you have installed another program that installed a Shell Extension and it is messing up.

Programs incorrectly processing long path names is a common bug.

Author

Commented:
debugnt:

right... it must be another program's installed shell extension that is causing this, because now it works fine after i shortened the folder names containing these image files.

i suspect it is adobe photoshop, because it adds this tool so u can see what the image looks like when browsing a folder... instead of seeing the default file icon for it.

windows has a similar feature, but with thumbnail viewing, however photoshop has added this extra feature to see what an image looks like in any folder view (e.g. detailed, small icons, large icons etc.

if this is the problem, i need to find a way to disable this feature photoshop added, and re-lengthen the folder names... and test again.

maybe adobe has a fix, gotta contact them...

alternatively, i could disable columnhandlers as suggested in your last post.

thanks for help... looks like we may have pinned this problem down.

Author

Commented:
thanks to everyone else for their suggestions. apparently the problem was linked to this column handler issue for image files.

the windows column handler for adobe photoshop's feature of viewing image files in a thumbnail-like view by default was casuing troubles in folders that had long path names.

so the fix was to disable the thumbnail feature for photoshop files by:

1. right-click on file
2. properties
3. photoshop image tab
4. uncheck generate thumbnails

since windows already has a built-in image thumbnail viewer and previewer in windows explorer, it's not that bad to lose this photoshop feature. besides, it took up time displaying a folder with many image files.

thanks again!

Commented:
FYI:
I had this same error, with i.e.6 sp1.

My scenario was that I was editing online scripts on my webserver. Normally, when I click the save button, the window would close after the save.  However, with this error, I.E. would say "instruction @ 0x77f85c41 referenced at "0x00000010" could not be written....and the error would occur, causing the need to close the browser.
After reading the above comments, and reading the suggestions on msdn.com for this type of error, I determined that perhaps it was my Google toolbar that was trying to access the same memory location.  After deleting the Google toolbar, the problem hasn't occured.

In my case...it had nothing to do with file name length, but rather, an application (Google toolbar add-on) that integrated with I.E. and was competing for the same memory resources.

Hope this helps others!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial