CRViewer problems with ASP

jnoxel
jnoxel used Ask the Experts™
on

We're trying to use Crystal Reports 8.5 to show reports on the company intranet.  The web server is running Windows 2000 Professional, and the clients are running a mix of mostly Windows NT workstations and some Windows 2000 Professional.

We're using ASP to access the reports, and we want to use the ActiveX CRViewer control to view them.

We're facing two problems:

1)  On PC's with Crystal installed, the CRViewer frame comes up, but instead of the report, we only see a gray box.  

2)  On PC's without Crystal, the CRViewer control is not downloading automatically to the client.


We know that the report works because it comes through when we use the HTMLViewer.

We thought that it might be an old version of CRViewer, but when we look in C:\WINNT\Downloaded PRogram Files we don't see it.  Are we looking in the wrong place?  As far as the client downloading, do you think it's a security problem?  Shouldn't we be prompted to download it at least?  We tried playing with the file permission on the web server... no luck.

Any ideas?  We obviously need to answer ALL of our questions.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
Two things:  First, verify that a file named rptserver.asp is in the directory where the report and ActiveX viewer ASP resides.  What you described sounds like your script cannot find this file.

Second, we had a similar problem with the ActiveX Viewer, and found that the Users running the Application did not have Admin rights to their machine, so could not download the Viewer.  Have someone with Local Admin rights log on to the machine and run the report.

Let me know if this doesn't solve the problems.

Author

Commented:
Hey dbirdman,

I've verified that all of the files are in the same directory, so there should be no problems there.

Secondly, the developers have full admin rights on their own PC's so we should at least be able to view the reports.  Still no such luck.

Any other suggestions?  I appreciate the help...

Commented:
Have you seen this link?  It's a long shot since you're running 8.5 and this is for 9.0. However, you might want to verify that all of the virtual directories were created correctly.

http://support.crystaldecisions.com/library/kbase/articles/c2011492.asp

Here's a document regarding Web installation:

http://support.crystaldecisions.com/communityCS/TechnicalPapers/docs_web.pdf.asp

It's not a direct answer, though maybe it will help.

Are you running IE 6.0?
http://support.crystaldecisions.com/library/kbase/articles/c2011168.asp

See if this applies:
http://support.crystaldecisions.com/library/kbase/articles/c2005860.asp

Just some shots in the dark.

Regards
OWASP: Forgery and Phishing

Learn the techniques to avoid forgery and phishing attacks and the types of attacks an application or network may face.

Have you fixed this?

Author

Commented:
Nope... still working on it.  The documents that have been suggested are certainly educational, but I haven't been able to track down the problem yet.  The trouble is that I'm not getting any errors that I can debug.  I'm simply getting a gray screen.  Any suggestions are welcome...
Have you checked everything in regard to the Web installation (dbirdman's doc)?

Commented:
Crystal Reports over the Web has its quirks.  You may have already combed the Crystal Web Site, though in case you haven't seen these, go to the below link and search on "gray screen".  Some of the problems listed are very specific issues, like custom HTTP headers, or running the Apache Web Server.  Hopefully the answer to your problem is in there somewhere.

http://support.crystaldecisions.com/library/kbase.asp

Good Luck.

Author

Commented:
OK, here's the solution to the two original problems that I posted.

1)  For some reason, having rptserver.asp in the same folder as the SmartViewerActiveX.asp wasn't working.  We had to go into the code of SmartViewerActiveX.asp and change the relative path to a fully qualified path.  I.e. from:

CRViewer.ReportName = "rptserver.asp"
webSource.URL = "rptserver.asp"

To:

CRViewer.ReportName = "http://servername/ReportPath/rptserver.asp"

webSource.URL = "http://servername/ReportPath/rptserver.asp"

where servername was the website name, and ReportPath was the folder structure off the root of the website to get to rptserver.asp


2)  The second problem was because the PC had already had a copy of CRViewer.dll installed and registered from another application.  The Crystal Reports web component detected this file and assumed that all of the dependecy files (Swebrs.dll and Sviewhlp.dll) were also installed.  Therefore, it didn't attempt to install any of the components of the ActiveX Viewer, and attempted to load the report witht he existing CRViewer.dll.  The solution was to:

1) unregister the file using: regsvr32 /u "C:\WINNT\System32\CRViewer.dll"
2) reboot the computer
3) view the report again to download the viewer files.

Author

Commented:
dbirdman was the most helpful on this one... thanks

Author

Commented:
The document on the Crystal website that ended up being the most helpful was called "Troubleshooting the Installation of the ActiveX Viewer"
Hi, Just to let you know this posting has helped me as well. Something i could'nt quite understand is when i was using my development server i did'nt have a problem with the report not loading. It was only when i put the stuff on the production server the problem started to happen? Anyway its working fine now so cheers

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial