MSHOME is inaccessible

Eliotk
Eliotk used Ask the Experts™
on
When I try to view my workgroup computers, I get an hourglass for a long time, then a dialog box that says, "Mshome is inaccessible, perhaps this user does not have permission..."

What can be done about this.  XPPro is the operating system.

These are brand new computers and they have never been able to see each other.

I seem to recall a similar problem once and someone suggested I set the permissions somewhere. I cannot recall exactly where I was sent to do this.

Help
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2004

Commented:
first how do you have the ip's set up?

Commented:
have you seen this?

How to Troubleshoot TCP/IP Connectivity with Windows XP
http://support.microsoft.com/default.aspx?scid=kb;en-us;314067

hope this helps!
guidway
Sounds like a firewall problem to me.  Did you install Norton's or are you using the XP firewall?  (advanced tab of your network properties.)
JavaScript Best Practices

Save hours in development time and avoid common mistakes by learning the best practices to use for JavaScript.

Commented:
Well, what are you using in the network?  A router, hub, or a direct connection from one computer to the other.
Try disabling the web client service.  Go to start->run and type "services.msc" in the window that appears find the "WebClient" listing and double-click it.  Then change it's startup type to disabled.  Restart, and try again.

That error shouldn't have anything to do with permissions, unless you're setup for a domain.  These articles describe how to disable simple file sharing and set permissions:

       HOW TO: Disable Simplified Sharing and Password-Protect a Shared Folder in Windows XP
       http://support.microsoft.com/default.aspx?scid=kb;en-us;307874

       HOW TO: Set, View, Change, or Remove Special Permissions for Files and Folders in Windows XP
       http://support.microsoft.com/default.aspx?scid=kb;en-us;308419


Also try disabling the Windows XP firewall:

Click Start, Control Panel, double–click Network Connections, select the Local Area connection,  Network Tasks, Change settings of this connection, Advanced tab, Internet Connection Firewall, uncheck or check the Protect my computer and network by limiting or preventing access to this computer from the Internet check box.

Commented:
Well, what are you using in the network?  A router, hub, or a direct connection from one computer to the other

Author

Commented:
I am using a linksys router and all three computers are having no problem accessing the internet.

The firewall is disabled.  The other suggestions did not seem to work either, as of yet.

You do have the computer setup to join a workgroup, not a domain, right?

Try enabling the guest account on all your computers in the User Accounts control panel

Commented:
well, if you are just using a router then you wom't be able to see each other.  What kind of linksys router?
Top Expert 2004

Commented:
Huh??? I have a d-link router, and I can see all mine
the router should hide the LAN from the WAN, but not the machines on the LAN from each other

they all should be on the same network
please post the results from ipconfig /all (run from a prompt) here
Top Expert 2004

Commented:
the only reason a router should prevent file sharing is if there were a filter set in it to do specifically that.  And I'm not sure if it can even filter internal traffic.  Have you checked the router's filter settings?

Commented:
Id a router is not made to also act like a hub or switch (most of them are but some aren't) then you won't be able to share files.

Commented:
In a nutshell:

If you want to set permissions, all you have to do is right click on the folder or drive, click on "sharing" and you see "permissions".  For example if you want to give 2 computers access to a third then set the permissions in that third computer.

I would suggest that you only give "permissions" for folders that you want the other computers to have access to.  It is NOT advisable to give permissions to your root directory c:\ or anything with your system files and folders in it.

Crash2100's included some good links...if those are too much for you, you may want to consider asking someone (who's done this sort of thing before) for help.

Author

Commented:
My ips are setup as 192.168.1.100, 101 & 102

I am on a workgroup, not a domain.

I am using a BEFSR81 router, which is designed for bot wan and LAN use.

The actual message is:

"Mshome is inaccessible. You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have access permissions.

The list of servers for this workgroup is not currently available."

The router's filter settings are blank, not set at all.

The sharing on the drives are all set to full access.

The guest accounts are all enabled.

The WebClient has been disabled.

What is the next suggestion?

Commented:
In a DOS prompt type in "ping 192.168.1.1"

Your Router should respond with 4 valid ping replies. A single valid reply looks like this: "reply from 192.168.1.1: bytes=32, time 10ms TTL=128."

Next try pinging the other computers.  Use the same command (ping ) with the certain computers IP.

Please Tell Me What IT Said So I Can Advise You On Your Next Steps
Top Expert 2004
Commented:
Are all the OS's XP Pro?
Try disabling the web client service. Go to start->run and type "services.msc" in the window that appears find the "WebClient" listing and double-click it. Then change it's startup type to disabled. Restart, and try again.


also If all are not XP/w2k then make sure to log on to the other machines using "client for M$ networks"
and add the username and password to the XP Pro box, and then give that user permissions to the share (right click on the folder in windows explorer, choose sharing, then security, and add the user)

Author

Commented:
Both computers are pinging to the router , themselves and the other computer, almost identically.  The TTL is different. 150 to the router & 128 to the computers.  Both are XP Pro.

Please advise.
Top Expert 2004

Commented:
set up identical user accounts on both machnes, and give the accounts permission to the shares
also try an lmhosts file
http://www.realcomputerguy.com/lmhosts.htm
and
http://support.microsoft.com/default.aspx?scid=kb;en-us;314884

Author

Commented:
I have solved the problem!!!

I went to the network adaptors properties in my network connections and uninstalled the client and everything else that I could.  I then removed the adaptor from device manager.  When I rebooted, it returned.  I then added back the client etc.  After running the network wizard, it suddenly saw the other computers, and all is right with the world.

Please let me know if any of your suggestions are close enough to deserve the 100 points and I will distribute it accordingly.  Thank you for the help.
Top Expert 2004

Commented:
Glad it's working for you!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial