SB AudioPCI 64V Issue

ehundrieser
ehundrieser used Ask the Experts™
on
Not sure if the printout (below) poses obvious IRQ issues. I'm unable to get my Creative SB AudioPCI 64V card to work on a Win98SE Dell Dimension L733r.

No luck to make it work after installing the "sb-9xeng.exe" driver from Dell's site.
I've tried just about any combination of installs. I've not moved the card to a different slots. There are only two cards; the other being a 3Com EtherLink PCI card. It's separated by one PCI slot.

The SB driver was downloaded from Dell because SB 64V was part of the original OEM install (came with the PC - Dimension L733r). Dell's so called "ResourceCD," is not available.



If necessary, additional info is available. Thanks

DMA 01 Undetermined SB AudioPCI 64V Legacy Device
DMA 02 Undetermined Standard Floppy Disk Controller
DMA 03 Undetermined EPSON Printer Port (LPT1)
DMA 04 Undetermined Direct memory access controller

IRQ 01 Undetermined Standard 101/102-Key or Microsoft Natural Keyboard
IRQ 02 Undetermined Programmable interrupt controller
IRQ 03 Shared 3Com EtherLink 10/100 PCI For Complete PC Management NIC (3C905C-TX)
IRQ 03 Shared ACPI IRQ Holder for PCI IRQ Steering
IRQ 04 Exclusive Communications Port (COM1)
IRQ 06 Undetermined Standard Floppy Disk Controller
IRQ 07 Undetermined EPSON Printer Port (LPT1)
IRQ 08 Undetermined System CMOS/real time clock
IRQ 09 Shared Intel(r) 82801AA USB Universal Host Controller
IRQ 09 Shared ACPI IRQ Holder for PCI IRQ Steering
IRQ 09 Shared SCI IRQ used by ACPI bus
IRQ 0A Shared Creative Sound Blaster AudioPCI 64V
IRQ 0A Shared ACPI IRQ Holder for PCI IRQ Steering
IRQ 0A Shared Intel(r) 82801AA SMBus Controller
IRQ 0B Shared ACPI IRQ Holder for PCI IRQ Steering
IRQ 0B Shared Intel(R) 82810E Graphics Controller
IRQ 0C Undetermined Microsoft PS/2 Port Mouse
IRQ 0D Undetermined Numeric data processor
IRQ 0E Exclusive Primary IDE controller (dual fifo)
IRQ 0E Undetermined Intel(r) 82801AA Ultra ATA Controller
IRQ 0F Exclusive Secondary IDE controller (dual fifo)
IRQ 0F Undetermined Intel(r) 82801AA Ultra ATA Controller

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
If you havent tried this already.......

Remove the card from your system then boot up, remove all instances of the driver/software, then re-install the card a reload driver.


Hope this helps
lawboy

Commented:
Boot into safe mode (F8 while booting) and look in the device manager.  You will probably see multiples listed.  In all cases where you see multiples delete all occurrences.  Now reboot and it will redetect.  You will need your 98 CD and driver CDs for whatever you delete.

Author

Commented:
lawboy373 & slink9: Been there, done that... :-) Any problems with the IRQ settings?
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Are sure you are using Creative Labs SB AudioPCI 64V, and not Creative Labs Sound Blaster 64 PCI?

Author

Commented:
These are the "Device Manager" entries:

Creative Sound Blaster AudioPCI 64V
SB AudioPCI 64V Legacy Device
Have tried to install the PCI driver?

Commented:
Should we keep guessing at things that you have tried unsuccessfully or would you like to give us a list of things already tried so you can get this solved rather efficiently?

Author

Commented:
slink9: Thinking... No! I won't match the tone of your remark, except to say that in my opinion I've given adequate information as to what I've done so far. In my original post I referred to "just about any combination of installs." I should probably expand on that:

Deleted SB from Add/Remove
Deleted SB entries from Device Manager
Deleted SB entries from Device Manager in Safe Mode
Removed SB card
Rebooted without card
Reinstalled SB card
Reinstalled SB Driver from Dell's site

My original post indicated the possibility IRQ conflict that I needed someone to look at. Thus far, no comment from anyone on the IRQ list. I also offered additional information that might be necessary to resolve this issue.

Cheers

P.S. lawboy373: I have not tried to install (reinstall?) the PCI driver. Where would I find it? Thanks.
P.S. Try the diagnostic as well!!!

Hope this helps you
lawboy :)
P.S. Try the diagnostic as well!!!

Hope this helps you
lawboy :)
If cant access via link go to https://support.dell.com/register.aspx
go to
OR- Choose Product/System Type
Select: "Dimension L___r"
Select: "Downloads"
Then Select your operating system and Select a download category which would be "Audio Drivers" then click go.

There you will find the driver for the Creative Labs Sound Blaster 64 PCI as well as Creative Labs Audio PCI64V Diagnostics.

lawboy :)

Author

Commented:
lawboy373: I was looking at that file yesterday. Is this an update to the driver, and is this (below) the proper order of installation?

1) sb-9xeng.exe
2) Creative Labs Sound Blaster 64 PCI, v. s6_02upd, A01RCD

Thanks.
No it is R31894.EXE
It is the complete Driver

You dont want sb-9xeng.exe!!!!

Description:
 Creative Labs Sound Blaster 64 PCI, v. s6_02upd, A01RCD
File Date: 10/10/2001
Newest driver and applications package designed to automatically detect the Operating System, and the Language.
 
 
Just install R31894.EXE
after you have removed the other driver.

lawboy

Commented:
There was no mention of any yellow marks on the devices in system properties, so I'm assuming there is a conflict that windows isn't detecting,that may be present and new driver install fails,my best guess would be to run win98 setup again,I would run it from windows ,be sure to dissable antivirus and cotrol+alt+del all programs except explorer,this should reinstall all drivers from scratch,no programs or any other info should be effected,reason being its more likely that window will correct the resource issue. p.s. if you choose to do so and have anti-virus software their may be a message that comes up about writing to the boot record press continue.

Author

Commented:
lawboy373: OK, I got it. I've been installing the sb-9xeng.exe.  I don't know how I was mislead. Will attempt the driver reinstall later this evening or tomorrow (hopefully). I'll let you know the result as soon as I finish the install.

DARRYL: No conflicts (yellow marks) there. I had already checked that. If lawboy733's advice does not heal the issue, then I may attempt your solution.

Cheers!

Author

Commented:
lawboy373: Do you recommend that I install this driver in Safe Mode, or will it not make a difference?
Here you go ehundrieser

Installation instructions
1. Download/save this file to your desktop.
2. After the download has completed, minimize all windows and double click
the icon labeled R31894.EXE
3. Click the "Continue" button.
4. A screen will open indicating where the files will be extracted and
placed on your hard drive (C:\dell\Drivers\R31894\); click the "OK"
button; files are extracted and copied.
5. After all the files are extracted and copied to the correct location on
your hard drive, a screen will open indicating "All files were
successfully unzipped"; click the "OK" button.
6. The SBSetup will run; select the action you wish then click the "Next"
button.

Anytime you wish to re-run the driver installation process, run the file
SETUP.EXE (located in C:\dell\Drivers\R31894\)

If desired, the icon R31894.EXE may be saved to another location or
deleted from your desktop.  

lawboy
P.S. Taken From Dell's Website!!!

Hope this fixes your issue

(:

Author

Commented:
lawboy363: Thanks for the info. I'm a bit concerned migrating from Step 5 to Step 6. I take it I should not necessary "wait for the setup to begin automatically." In other words, if nothing happens after the extraction, I should manually locate the "setup.exe" in the R31894 folder and double click on it? Seems logical to me. :-)
You are absolutely right.....
If nothing happens within a resonable amount of time (a few seconds) after you have extracted...then I would browse to the folder where the files were extracted and run "setup.exe"!

Author

Commented:
Well, I'm back again, and NOT so well.

The install of said driver (R31894.exe) went smooth, however, still no sound. The card is recognized, etc. The Sound icon appears after the driver install, but disappears with the next reboot, so do some of the tabs in the sound card properties.

I thought I'd switch cards and use a SB512PCI. Same issue. No sound. I get a "Sound card in use" message with this card as well as the SB64V PCI card mentioned (first paragraph). Disappearing Sound icon and property tabs issue occur with the SB512 as well.

 
Top Expert 2007

Commented:
OK, I would next try using safe mode to change the IRQ of the SB card to use IRQ 5 which is not in use. Also check the BIOS to see if any IRQ's are reserved.

Other options include turning off PNP in the BIOS and using manual settings.

I hope this helps !
Glen A.IT Project Manager

Commented:
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

Accept: lawboy373 {http:#7524176}

Please leave any comments here within the next seven days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

AlbertaBeef
EE Cleanup Volunteer
EE Page Editor, Desktops/Microchips TA's

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial