Rnaapp - mind of it's own

AutumnRae
AutumnRae used Ask the Experts™
on
Recently i have been getting Rnaapp.exe popping up whenever it seems to feel like it. I 'end task' it and it jumps back into play at ALL times.
I have read a little trying to figure out what is going on and have come across the idea that it COULD be that someone has gained access to - or thru -  my tcp/ip ...?
Have tried replacing the file with a new one from the disc and it is right back to loading with about any program i call up -- OR NOT !!!!
I do know that it is only needed when i'm connected to the internet - so why is it popping up even at start up and  -- like i said -- seemingly having a mind of it's own??
ANY help on fixing this problem will be GREATLY appreciated !!!!!  :)
This started suddenly a couple of weeks ago ....
I am NO EXPERT but usually fix my own PC problems after a fair bit of research --- and being lucky enough to find people willing to help with answers.
THANK YOU in advance.
All i have is 75 points -- they are yours --- will this get me any answers?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
What OS are you using? Is there a modem installed? Try looking in HKLM\
SOFTWARE\ Microsoft\ Windows\CurrentVersion\ RunServices and delete the references to RNAAPP.exe
This may also help >

http://www.modemhelp.net/newsletter/dun/combatrnaapp.shtml

Author

Commented:
I am running W-98 SE with a 56k v90 modem
will go and check the HKLM etc. as well as the link you supplied -- THANK YOU!!!!!!! -- will let you know :) "C"

Author

Commented:
BogieB --- There were no instances of Rnaapp in the area you suggested. But Thank you very much for the attempt .... :)C
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

Sounds to me like some application (there are tons) is attempting to access the internet.  How about Quickbooks (2000 and later - qbdagent.exe), Antivirus software, spy software (get SPYBOT or Ad-Aware).

I would primarily suggest running Ad-Aware or Spybot first and seeing if that solves your problem.

Another suggestion is if you have, say, automatic windows update software running in the background.. That could also be it, or Instant Messenger (MSN, AOL, Yahoo, etc.)....

If, after cleaning the system with Ad-Aware or Spybot, it still happens, there is another way to get to the bottom of it.

ZoneAlarm (personal firewall software) will allow you to allow/deny access to programs that are trying to access the internet, or something from the internet trying to access your computer.

If you run Zonealarm, it will monitor (and prevent, if you wish) programs from accessing the internet.

Hope that this helps.

PB

Author

Commented:
Thank you PB, i will go and do the things you suggested.
I do run Zone Alarm Pro --- do not have anything to do with any of the instant messaging programs -- do not do chat rooms etc.
The thing that baffles me is that i have had no problems until about 2 weeks ago -- and changed nothing as far as programs etc .....
Zone Alarm is wonderful and does a great job --- only problem being that being on AOL --- i have had it asking if waol can access -- after being on line for a while already -- i say no and it shuts me off ........
Finally one time i said yes so i could finish what i was doing -- ever since them i have this 'bull'
AGAIN --- THANK YOU --- i will definately try the things you've suggested.
I, very much, appreciate your help ..... :)
"C"

Author

Commented:
Have gone and done the ad-aware as you suggested ... cleaned all it found ...
Still have rnaapp.exe doing whatever it likes ....
Based on your post on 12/06, it seems as though Zonealarm asked to let the naughty application through, and you told it to, indefenately.

So, what you have to do now, is look at the "allowed applications" (I forget the terminology that zonealarm uses) and remove those that are not obvious from the list.

I'll bet that it's one app that Zonealarm is let pass through that is causing your problem.

pb

Author

Commented:
I would think your right --- but i had gone in an checked this out -- looking for unfamiliar programs that have been allowed... even before discovering this site and posting my question here. >  There are none ..! ...? ^*$%^ ... :)

I have been trying to find out about this thing for a while now -- had this very problem before and did a reformat thinking that will get rid of it ... got everything back up and running only to have the rnaapp.exe show up 2 days later -- so thinking it was something they could embed on the hard drive i replaced that -- happened to have one here waiting to go in anyway ...ended up with new motherboard and the whole nine yards and have been rnaapp free for about 4 months -- till now ...........

It is appearing to me that it is associated with just about any program i may pull up --- i end task it and if i just do a random check sometime while working on pictures etc ....  it is there -- will end task it again and sure enough - sometime later it's back -- this is happening when i'm not online ... ! ... and sometimes i haven't even called up any other programs -- other than maybe filters \ plugins in my imaging program ...

I DO greatly appreciate the time you've spent thinking about this on my behalf .... i will just keep on trying to find an answer -- should i ever get it figure out i'll be sure to post it here ...

I ran into a referrence to rnaapp being used by hackers in some way -- believe i read that on Steve Gibson's site - GRC.com -- but haven't been able to find it again .........
I ran into the same problem after investigating a post about an hour ago and I've fixed it.

Someone visited a website and it was always changing their homepage to that site.  It turned out to be a script that they fixed by deleting a registry key.

However, when I visited the site, it did not mess up my homepage, but Rnaapp kept making America Online load up and sign on.  I tried CTRL+ALT+DELETE to end Rnaapp several times and it kept coming back up.  I checked the registry and found nothing.  So I went into my IE properties and reconfigured my LAN connection (basically just set it up like I had never used it before).  I didn't see anything unusual with my ZoneAlarm.  I checked my WIN.INI for anything unusual... nothing.  Then I restarted.  

I noticed some extra dialup connections in my IE properties that looked unusual and deleted those.

Now everything works great.

Hope this helps,
Jake

Author

Commented:
WOW --- you have me hopeful !!!!!!!!!!!!!!!
Thank you so much ... and i will let you know..ASAP .. :)
"C"

Author

Commented:
TopDollar --- so sorry it has taken me so long in getting back to you -- i am a bit of a novice in this stuff -- don't know what would be normal or not in the WIN.INI etc..
... have a lot of strange things going on but don't know enough about it all to know for sure where to look ...
I SINCERELY THANK EVERYONE FOR YOUR ATTEMPTS AT HELPING ME.
IF IT WERE POSSIBLE TO GIVE THE POINTS TO ALL I WOULD DO THAT .........
Not sure what to do in a case like this - so i'll wait to hear maybe from someone in charge.
I've checked for trojans etc. to the best of my ability ---
also did a netstat check and came up with what looked real strange to me -- but agian i don't understand enought to know for sure or not.... I have taken the chance of  pasting this into this comment -

C:\WINDOWS>netstat -a

Active Connections

  Proto  Local Address          Foreign Address        State
  TCP    CLDelaney13@aol:0      0.0.0.0:0              LISTENING
  TCP    CLDelaney13@aol:8431   0.0.0.0:0              LISTENING
  TCP    CLDelaney13@aol:1045   0.0.0.0:0              LISTENING
  TCP    CLDelaney13@aol:pop3   0.0.0.0:0              LISTENING
  TCP    CLDelaney13@aol:1027   0.0.0.0:0              LISTENING
  TCP    CLDelaney13@aol:1027   berp-mw08.dial.aol.com:13784  ESTABLISHED
  TCP    CLDelaney13@aol:1108   0.0.0.0:0              LISTENING
  TCP    CLDelaney13@aol:1108   >>>>this one had the IP address<<< mine, i'm assuming<                  ESTABLISHED
  TCP    CLDelaney13@aol:1122   VTOT.proxy.aol.com:80  TIME_WAIT
  TCP    CLDelaney13@aol:1130   VTOT.proxy.aol.com:80  TIME_WAIT
  TCP    CLDelaney13@aol:1133   VTOT.proxy.aol.com:80  TIME_WAIT
  TCP    CLDelaney13@aol:137    0.0.0.0:0              LISTENING
  TCP    CLDelaney13@aol:138    0.0.0.0:0              LISTENING
  TCP    CLDelaney13@aol:nbsession  0.0.0.0:0              LISTENING
  UDP    CLDelaney13@aol:1045   *:*
  UDP    CLDelaney13@aol:nbname  *:*
  UDP    CLDelaney13@aol:nbdatagram  *:*

C:\WINDOWS>

Rnaapp.exe is what Windows uses to dial up a network connection.

It is true, then, that you also have AOL on this computer?  It seems as though perhaps this port TCP 1108 is associated with the AOL connection.

Once you let that WAOL through, then it's free to dial up (own RNAAPP) as it chooses.

Not meaning to be difficult, but I would say that perhaps it's the AOL software that is doing this to you, and reinstalling it probably won't do the trick.

If you look at Zonealarm and see the WAOL on the "allowed" list, by turning this off, your apparently random dials to the internet should stop; however, this probably won't cure your problem.

Either AOL is connecting to retrieve some sort of updates or you have another piece of software (Automatic Windows updates) or spyware trying to connect to the internet.

I am assuming that you have downloaded and run SPYBOT.  If you haven't, please do so.

Merry Christmas!!

pb
AutumnRae:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
PAQed - no points refunded (of 75)

Netminder
EE Admin

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial