MS-DOS game and Win98

sonic92f
sonic92f used Ask the Experts™
on
dear Friend,
     Can anyone help me by telling me how to run my favorite DOS based game Red Storm Rising?
      I have a Hewlett-Packard Pavillion 8550C (1999), Celeron Processor(500MHz), 17GB drive, 95MB RAM, Win98, DOS 6.x
I tried starting the game in DOS and using my computer's boot-disk and then I put the 3.5 disk game into the A:\ drive and type "REDSTORM" as required by the manual. The manual also requires DOS 2.11 to 3.31
    Then I get non-stop beeps and wierd symbols in my DOS screen. I also tried starting the game in Windows by clicking onto the 3.5 disk icon and then click .exe symbol with the sprocket inside the little box. I get an error DOS little windows saying that there was an error running DOS. I'm at my wit's end, please help!
Thank you
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
I think you may need a Univibe(VESA) universal hi-res video driver. there is a patch for Red Storm Rising, here http://www.gamesdomain.com/patches/p5upd.html

<<my home brew solution to avoid using a boot disk>>
If you are running win98, I used to run a batch file that renamed my c:\windows directory to c:\nowin and setup config sys and autoexec.bat files. That way you don't need to use a boot disk. don't forget to have a batch file that renames the C:\nowin back to c:\windows and replaces the custom config.sys and Autoexec.bat files.

Author

Commented:
    I downloaded the VESA from the website and I still couln't get the Red Storm game to work. I went to DOS and A:\REDSOTRM and I get a few lines of wierd symbols but nothing else.
     I haven't tried running a batch file because I don't know what to include let alone how to do it. My file names haven't changed:  c:\windows and config.sys and autoexec.bat files
Please let me know what else I can do, thanks

Commented:
have you tried messing with the emm386 settings ?
Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

Commented:
add to the config.sys file

Device = C:\dos\emm386.exe noems

Author

Commented:
So by changing the emm386 setting the DOS game may work in a DOS 6.22 enviroment?
How can I change the settings back if the line change doesn't work or alters my computer?
Will a Boot-disk change the settings back if needed?
How can I change the DOS lines?
Do I go into DOS and then do what after I get
C:\windows\      
Thanks in advance

Author

Commented:
I tried using a DOS 3.30 bootdisk (3.5") when I started in MS-DOS, then I typed A:\REDSTORM and the A-drive continues to read the game disk but does not stop or begin the game. I hoped that using a DOS version required by the game (DOS 2.11 - 3.31) would make the game work

Commented:
can you ,make a dos 6.x boot disk
(6.x = 6.0,6.1,6.2 etc)

Author

Commented:
  I tried using a DOS 6.22 disk, and then I tried editing the DOS lines you suggested, but I get errors. I tried to edit the emm386 line, but when I went to the config.sys file in DOS from the 3.5", I saw error messages and wierd symbols. Some of these lines said:
emm386/windows interface failure. emm386 will remain off
emm386 DMA buffer is too small Add D=nn parameter reboot $
   Then I tried my HP's DOS boot disk and I was able to get into normal looking files. Nothing weird. I changed the emm386 line and tried starting the game A:\ with and without the original emm386 line. When I included the emm386 line (with the original emm386) and I booted the computer, I get a message that says:

Error XMS driver not installed
An Extended Meomory Manger is already installed
Without the original emm386 line I get:
Error in line 3 (or similar)
My boot emm386 line is:
rem the following line give you more ram, but no ems
Device=C:\WINDOWS\emm386.exe RAM NOEMS

Thanks in advance
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
- Points to Novahux
Please leave any comments here within the
next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER !
pbarrette
Commented:
PAQ and points refunded.

Last comment indicates problem isn't solved

modulo

Community Support Moderator
Experts Exchange

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial