Very Slow IDE Performance

boltUpright
boltUpright used Ask the Experts™
on
I think I know the answer to this question, but I am trying to avoid that for a bit and wonder if there could be anything else.

First of all, my hardware specs:
Asus P3V4X MB
P3 800e
1G PC133
Maxtor 30GB (PM C: & E:)
Zip250(PS)
Plextor 12x10x32 (SM)
Maxtor 30GB (SS D: & F:)
Matrox G400MAX 32MB dual monitor
Philips PSC706 Soundcard
Clean install Win2k + WinXP Pro Upgrade

The problem is the SS hard drive, which runs very very slowly.  I know it is probably going to die on me but no data is corrupted, no bad clusters from scandisk and the drive doesn't make any noise.  I am in the process of making backups right now, and it takes literally 4 or 5 hours to copy 2GB to the other drive.  When the system boots it takes almost 3 minutes after the WinXP splash screen for the login screen to appear... After that everything is fine unless I do something with a file on that drive.  With the drive unplugged the system boots normally.

Assuming it was the drive going bad, I purchased a Maxtor 80GB drive for a little replace and upgrade action.  Not being one who likes to wait, I unhooked the existing drive, put the new one as primary master and booted from a new WinXP Pro CD.  I partitioned the drive (20GB for OS) and formatted NTFS in XP Setup.  OS installed perfectly and ran fine.  I installed all my applications and transferred my emails and everything from the old OS installation (manually) and went to bed.  This morning, I was greeted by an error stating that Norton Antivirus could not verify its subscription info and that I needed to reinstall it.  I uninstalled it, restarted and got a boot disk failure.  I hooked up the drive with my old os, making the new drive the slave and booted up.  This old drive still works fine so I went into disk administrator and deleted the 20GB partition on the new drive, re-created it and started formatting...  After 4 hours it was only on 75% complete and two hours later it finally finished up.  Now I get a SMART message on boot saying 'Failure is Imminent' for that drive.  

Is it possible that something in my system or something I am doing is frying these drives or did I just get a bunk drive?  I find it suspicious that a new drive begins to exhibit the same behavior as the one it is supposed to replace, but if there was a lottery for bad luck, I would have the winning numbers almost every time.  

Thanks for taking the time to read all that... Any light someone could shed on the situation would be greatly appreciated.  
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Well, let's try to narrow this bad boy down a bit.

Some possibilities:

1) You have a bad (or dying) Maxtor 30GB (SS) drive
2) You have a bad (or dying) Maxtor 80GB new drive
3) You have a bad or intermittent IDE cable
4) You have IDE controller (Motherboard) problems.

This may be compounded by thermal intermittancy. If I read you correctly, it seems like the new drive worked okay when you first installed it, but after it ran a while it failed.

The drive that is running slow is probably re-trying numerous times.  This could indicate a drive, controller, or cable problem.

To test some of these things, let's try simplifying the system down to nothing but your new 80GB drive on the primary channel.  Disconnect all other IDE devices.  Let the system cool down, and then try operating the system with nothing but the 80GB drive installed.  If you get a SMART error with a cold system, try swapping the IDE cable with another one that you know is good.  Try again.
If the system works, see if it fails after it gets good and warm.  If you still get SMART errors, you probably do have a bad drive.

We need to isolate what happens to the system without the SS drive installed, and how the 80GB drive behaves without the SS drive in the system.   It is possible, perhaps likely, that this drive is doing something that is causing the other drives connected to its chain to run slowly.



a failing power supply could be a culprit too.

Author

Commented:
Mr. Spock... thanks for the suggestions.  Here is what I have come up with so far:

>>The drive that is running slow is probably re-trying numerous times.  This could indicate a drive, controller, or cable problem.

I would think that numerous retries would result in a bunch of read errors, or at least error log entries under XP.

New 80GB drive: cold, new cable, only device in system besides floppy.  I was able to partition and format the drive.  MaxDiag3.04 Advanced Recert. Test passes after scanning all blocks.  Basic test fails SMART self test.  SMART warning still flashing on boot.  I am going to assume the drive is bad... SMART error should get me an exchange since its only 2 days old.. If not, Maxtor will def replace.

Existing 30GB Drive: cold, new cable, tried on both IDE channels.  MaxDiag 90 second basic test takes 2 hours to complete.  I stopped the Advanced test after 4 hours... Very Very Slow scanning blocks.  Also tried test on both in different computer, same results.  I assume this drive is bad also and will continue trying to backup data at a snails pace.

New error this morning from cold boot 'System Hung from Improper Processor Speed on last try'  I haven't ever seen this error before, but then again, this computer has been re-booted more times over the weekend than it has since I built it 2+ yrs ago.  System uptime was 10K+ hours before I shut it down Friday to replace the drive.  

legsandlouie:  I checked the output of the PS and it is solid.  
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

I agree. Looks like you might have two drives bad.  The SMART failure should get you a swap from the place of purchase.

Lot of retries will not necessarily register errors.  The drive itself has retry capabilities built in that the OS will not see -- except in slowness.  

The way to tell this for sure is to listen to the drive. When you attempt to read or write a file, stick your ear near the drive.  You should hear quick and sporadic movement from the head.  The sound is hard to describe, but one could call it a "chattering" type sound.  When a drive is working properly, the chattering should sound quick, decisive, and somewhat irregular.

When a drive is retrying, you will hear a brief chatter, followed by three or four rhythmic and slower head movements.  This is the drive attempting to "recalibrate" the position of the head.  It does this by moving the head positioning mechanism back to Track 0, and stepping back in to where your file is located.  It will do this a few times before giving up.

I suspect that if you listen to your drive, you will hear this retrying sound a lot.  It is probably having trouble reading a large percentage of the time.


The second error you received is a common one.  Systems that can configure your CPU core speed and multiples via BIOS will exhibit this problem.  If your computer does not complete some portion of the BIOS initialization, it will assume that it failed to boot because of improper CPU speed settings.  It will then default them back to a "safe" setting to get the machine to boot.  All you need to do is reset the speed and multiple to the correct values and you'll be up and running.

The only thing that worries me is that there is a small chance that something in your system is damaging the drives.  I find this to be highly unlikely.  In fact, in all my years of dealing with PCs, I've only seen this happen once -- and that was on a hot-swappable SCSI backplane.

However, to be sure, when you get the replacement 80, put it in a different system first, then format it by itself on your system.  If you could find someone with a sacrificial lamb (like an old 2GB drive they're going to throw away anyway), you could eliminate this...
Top Expert 2007
Commented:
I would check both  / all drives

I would recommend that you download a diagnostic disk from your harddrive manufacturer's url. This will tell you right off where you are at and if
   you can recover from it. It may be under warranty, the hard drives are usually covered for three years and you can make out the RMA on their site
                     also. Depending on the manufacturer of the hard drive, you can download diagnostic utilities from their sites to check the drives.
  www.maxtor.com 

In addition, replace any cables, and if the drives are OK, I would suspect an IDE controller/ motherboard problem.

Make sure you get the latest IDE/ chipset drivers !

I hope this helps !
Glen A.IT Project Manager

Commented:
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

Split: MisterSpock {http:#7586517} & SysExpert {http:#7597153}

Please leave any comments here within the next seven days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

AlbertaBeef
EE Cleanup Volunteer
EE Page Editor, Desktops/Microchips TA's

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial