Cannot access webpage over local LAN

Troyh
Troyh used Ask the Experts™
on
I wish to set up a private LAN for Testing CGI scripts locally.
I have been successful in getting APACHE working on my LINUX server and can view the test page by simply typing:
http://infoserve.com/ or http://infoserve.com/index.html
in the location browser (infoserve is my server name)

I now wish to access this page over my LAN using a Win98 Machine. I am using
Netscape Navigator 4.6 and have set it up with a "Direct Connection to the internet" under Edit -> Preferences -> advanced -> Proxies.
Note: I also use this PC with a dial up connection for general browsing of the internet.

I have set up my Linux machine as a router with the following details
when I run the command: netstat -r

Dest Gateway Genmask Flags     MSS Window irtt Iface
10.0.0.0 * 255.0.0.0 U 40 0 0 eth0
127.0.0.0     * 255.0.0.0 U 40 0 0 lo
default infoserve.com 0.0.0.0 UG 40 0 0 eth0

My Linux Server has the IP ADDRESS 10.0.0.1 and is called infoserve.com, alias = infoserve

I have also set up my TCP/IP connection within windows to use this gateway and DNS Server

PROBLEM: I can't see the test page from my win98 PC. I try the following URL's

http://infoserve.com
http://infoserve.com/index.html
http://10.0.0.1
http://10.0.0.1/index.html

I'm not sure if I am approaching this the correct way, maybe I should be using a Proxy Server

Any help would be great,
- Troy
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
1) What is the IP of your Win98 box?

2) Can you ping the linux box by IP?

3) Can you ping the linux box by hostname?

Author

Commented:
Win 98 Box details:

Configuration
  TCP/IP -> ND01X Ethernet/Fast Ethernet PCI Bus Adapter
    DNS Configuration    
      Enable DNS ->
      Host:winpc
      Domain: infoserve.com
      DNS Server Search Order: 10.0.0.1
    Gateway
      Installed Gateways: 10.0.0.1
    WINS Configuration
      Disable WINS Resolution
    IP Address
      Specify an IP Address
      IP Address: 10.0.0.2
      Subnet Mask: 255.0.0.0
    Bindings
      Client for Microsoft Networks
      File & Printer sharing for Microsoft Networks
    Advanced
      Allow binding to ATM: No
    NetBIOS
      "Noting selectable"
   
  Identification
    Computer Name: winpc
    Workgroup: Workgroup
    Computer description: Gateway PC
 
  Access Control
    User-level access control
      Obtain list of users and groups from: INFOSERVE

1. Win 98 IP address = 10.0.0.2
2. Yes I can ping the linux box by IP address
3. Yes, I can ping the linux box by Hostname

- Troy

Commented:
Okay, try this from your Win98 box...

Open a DOS window, type:  telnet 10.0.0.1 80

Do you get connection refused or does it go blank w/blinking cursor?

If the latter happens, type:  GET /

(Disclaimer: Win98 built in telnet sucks, so this might not even work...if you have a better telnet app, use that!)

Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Author

Commented:
The connection gets refused with the following error
"Could not open a connection to 10.0.0.1"

- Troy

Author

Commented:
The connection gets refused with the following error
"Could not open a connection to 10.0.0.1"

- Troy

Commented:
Okay, so that means there must not be a web server listening.  So now do this on your Linux box:

netstat -ln | grep :80

If you don't get anything, just do:  netstat -ln

What you are looking for is what interface(s) Apache is listening on.  I have a feeling it is stuck on 127.0.0.1:80 and that's why you can get to it from the server itself but nothing else.

Author

Commented:
The output of the netstat command is as follows:

netstat -ln | grep 80

tcp     0     0 0.0.0.0:80     0.0.0.0:*     LISTEN

Proto     RefCnt     Flags     Type     State          I-Node     Path
unix     2     [ACC]     STREAM     LISTENING     2041     /tmp/orbit-root/orb-150746215318030646


Plus 6-7 other lines similar to the last one, i.e. unix 2 etc

Commented:
Okay, so maybe "could not open a connection" isn't the same as connection refused.  This is definitely odd.

If you do the "telnet 10.0.0.1 80" from a Linux shell, does it connect?  If so, what does a "GET /" return?

Author

Commented:
I simply get:

I get "telnet 10.0.0.1:80: Name or service not known"


- Troy

Author

Commented:
Ok...so some progress!

I fiddled around with some settings on my linux box and am now able to run the telnet command.

"telnet 10.0.0.1 80" returns the following

Trying 10.0.0.1...
Connected to 10.0.0.1
Escape character is '^]'.

Running the "GET/" command then returns:

<DOCTYPE HTML, etc. with the error
Method not implemented, GET/ to index.html not supported, Invalid methor in request GET/

Connection closed by foreigh host.


Running the telnet command from my PC (winpc) just calls up the dial up adapter. SO I removed it completely but I still can't connect it just times out with the same error as before. I'll post my TCP/IP settings later when I get them together although I have no problem pinging either machine!!!

- Troy
Commented:
You get a "method not implemented" because there needs to be a space between GET and / but nonetheless it is at least a response from apache for sure.

But having made sure it is listening on the right port and the right interface, but still not being able to connect from the other machine is definitely odd!

When you use the Linux box, are you directly on the console?  If so, can you just telnet to it normally from the Win98 box using the default port?

Did you try using ip address in your browser,
http://10.10.10.1.

Commented:
prasadklk: Read the original post again, yes that was tried and it didn't work.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial