Dissapearing NTFS Rights on quorum drive (Windows 2000 Advanced Server Cluster)

DjProzac
DjProzac used Ask the Experts™
on
We currently have a problem on our cluster server machines. It's a compaq CL380 machine installed with Windows 2000 Advanced server. Cluster services (Active/passive) installed. Latest Hotfix/sp level.

We have 3 such machines. 2 of them are used as homedrive for users. (*\Homedrives\%username%). I'll call these server A and B.

After an automatic reboot last sunday we had the problem that on the quorum drive on server A all %username% and %username%\*.* folders ALL NTFS right were GONE! (After Reboot).

Only Administrator and System were mentioned on the security tab, but NO rights assigned (all boxes empty). On the advanced tab "Administrator" and "system" had full control.

I wrote a batchfile to automate Rights assignment for system, administrator and user (xcacls) to the specific folders. This worked. So problem solved we thought.

BUT

TODAY the same thing happened to server B. Again after a reboot. ALL NTFS rights GONE. Again on the homedrives folder. Exact same symptom as on server A.

As we want to prevent this problem from re-occuring WHAT could be the problem here????? I have absolutely NO idea.....
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Are you saying the access control lists were gone or the shares and share level permissions?  The reason why I ask is that we have a 380 and one thing I noticed about it is that anytime that we reboot, we have to re-establish the shares (We're not using MS Cluster Service).  

Author

Commented:
We had the same problem 2 years ago (didnt have the cluster service installed then either)

The reason your shares on the quorum Drive are dissapearing is that it is a medium with two possible owners. An "external" scsi raid drive.

As shares are stored on the local computer, this information is lost when the other node of the 380 becomes owner of the quorum drive. Strangly so, this also happens when you reboot the node (without the other node being active).

If you install cluster services and create the shares in cluster manager, your shares will not dissapear.

The problem we have is that the NTFS (and thus the ACL) permissions on the directory and all subdirecties and files dissapeared....
Commented:
have you recently moved/copy a large amount of data to/from the 2 nodes?  did your servers automatically (or manually) run chkdsk /f when they rebooted?

Author

Commented:
Matt023

Yes, this was the case and yes CHKDSK /f started automatically after we had these problems.

I wrote a batch file that automatically gets userinfo from the active directory and puts the neccesary NTFS rights back in place. This batchfile runned for 3 hours (120Gb) and now everything seems to be working again.

I still have NO idea what caused the problem or what to do to prevent it from re-occuring, but as you were closest to the problem, you get the points..

Regards,

Prozac

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial