LINUX Startup into gnome

got2try1
got2try1 used Ask the Experts™
on
I'm new to Linux. I've been messing around with it 2.4.19 lately.
Once I install I add the patches via the redhat agent. It seems after I reboot my system it will not start the xwindows session. The login prompt comes up the the screen flickers. It looks like the screen fickering is affected more so when I move the mouse. Not sure what to do here. I have reloaded thinking it was hardware ran through the same steps and here I am again.
I've tried the linux.bak profile, that gives the same results. What's funny is everything was working fine until I rebooted.

Help?????
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2005

Commented:
To the best of my knowledge RedHat isn't using the 2.4.19 kernel on any version of RedHat. So running that kernel and using the RedHat updates is pretty much an unsupported configuration and it's hard to say whether you'd run into trouble doing that.

The problem could be with the kernel you are playing with or it might be some incomptability between one or more of the updates and your kernel. I'd suggest installing the latest kernel from the RedHat errata, if it isn't already installed (check with rpm -qa | grep kernel) and boot that kernel. Then run up2date again and see if anything needs to be updated. It's possbile that will cure the problem.
Top Expert 2005

Commented:
BTW, what version of RedHat is this? And what video card are you using?

Commented:
it may be your X server uses a special kernel module, e. g. when you use a graphics card with an nvidia chipset, which doesn't work with your new kernel or is not present in the modules directory anymore (/lib/modules/`uname -r`). in this case you should try to obtain the sources for the module from the vendor of your graphics card and build it for your kernel.

otherwise look into the X logfile (/var/log/XFree86.log) for details about the failure.

--asem
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Commented:
It may be your hostname. I've had this happen before. Boot the machine and then ctrl-alt-F5 to bring up the terminal Then log in as root and set your hostname:

hostname yourhostname

I've found that if Xwindows can not resolve the host name it will not work. You may also want to check to make sure that your localhost is set in your /etc/hosts file:

127.0.0.1   lo    localhost

!-- zippyjr --!

Commented:
Yes, I've seen the hostname problem too.
got2try1:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is to:

Be PAQ'd/Points No Refunded

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Paul
EE Cleanup Volunteer
PAQed - no points refunded (of 50)

SpazMODic
EE Moderator

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial