shut down/power down in windows 2000

robert_b
robert_b used Ask the Experts™
on
I recently upgraded my windows 98 to windows 2000 pro. (Actually it was a clean install on a formatted HDD.) Now the problem is when I try to shut down, the system wont power off. I get a message saying 'it is now safe to turn off your computer'.
Prior to installing win2000, my computer would automatically power off when shutting down.
I have check my bios and ACPI is enabled. I tried checking with my motherboard vendor, but have had no succes there either. I even tried enabling APM but that too didnt seem to work.
I have heard this to be a problem with winNT but not win2000. How can I get it to automatically power off instead of manually pressing the on/off button?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
You need to go into BIOS and reconfigure Power Management. On some older motherboards 2000 will automatically change the settings for you in the BIOS to disable it. This is because it doesn't seem to recognize that it is supported. However should work for you once it is reenabled.
I had this once myself on a new install of Win2k Pro. If i remember correctly you need to open the Power Options in the control panel - Start>Settings>Control Panel>Power Options.

Now select the APM tab and make sure there is a tick in the checkbox to 'Enable Advanced Power Management Support'

Hope that helps mate.

Author

Commented:
Nope...I checked the bios, everything related to Power management is enabled. I even tried disabling, restarting, then again reenabled them. No luck.
As for the APM support, I tried that earlier too. When I shut down I get the blue error screen so I have disabled that function.
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

Sorry to break this to you, but it is definately the checkbox on the APM tab that will shut your machine off automatically. I just checked it out.

If all the settings in your Bios are okay, I'd suggest you check APM again and if the Blue screen of death comes up make a note of what it says....the win2k blue screen tends to be a bit more informative than the win98 one.

Commented:
If our ideas didn't fix it either you are overlooking something or your motherboard and 2000 aren't going to cooperate. Check Microsoft HCL (hardware compatibility list) at http://www.microsoft.com/hcl/default.asp 
If your board's not listed good sign you won't get it working soon.

Author

Commented:
Okay, here is the error message I get with APM enabled:
***STOP 0x000...
IRQL_NOT_LESS_OR_EQUAL
***Address 8046856f base at 80400000 Datestamp 3d366b8b - ntoskrnl.exe
Beginning dump of physical memory.
Physical memory dump complete. Contact system admin...

As for HCL, I do not see my board listed. Compatability could be a problem, but I was hoping it was something else since I had no problems with win98.

Commented:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\powerdownaftershutdown




check out this reg key..

change the value from 0-4

i cant remember which one does which but one of them will shut down correctly..

i think the option should be 2 but i cant remember..

Commented:
actually if your chicken to find out ..

www.winguides.com has a registry page which has the details you need relating to this key ..

Check the following links......it may be worth your while installing and running the apmstat.exe tool as suggested in the first link, this will at list give you an idea of the compatibility with your BIOS, as this is what I think is giving you the stop error.
Other than that the registry key suggested by huckey, set to '1' is probably your best bet.

http://support.microsoft.com/default.aspx?scid=KB;en-us;q242495

http://support.microsoft.com/default.aspx?scid=kb;EN-US;242414

Author

Commented:
Well, I tried the reg key, read the winguides. No change. Same problem. I also ran the apmstat program. It says everything is fine. No known compatability problems. I tried updating a few of my drivers and now I really screwed up my system. Instead of going through safe mode and all that nonsense, I'm just gonna reload everything and hope it works out better. Thanks for your help guys.

Commented:
robert_b,
No comment has been added lately (110 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: PAQ/Refund

Please leave any comments here within 7 days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Thanks,

cempasha
EE Cleanup Volunteer
---------------------
If you feel that your question was not properly addressed, or that none of the comments received were appropriate answers, please post a request in Community support (with a link to this page) to refund your points. http://www.experts-exchange.com/Community_Support/
per recommendation

SpideyMod
Community Support Moderator @Experts Exchange

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial