network

bala_pune
bala_pune used Ask the Experts™
on
i want to connect 2 pcs (windows 98se) via 10/100 fast PCI ethernet through RJ 45 cable. Can someone help me configure the network so that i can share the cable modem to access net from both the PCS. I tried myself to configure it but encontering lots of problems. The 'entire network' does not show the other PC, but shows only the work group name which is empty. Is it a configuration problem. How do i go about assigning the IP address/gateway for the client/host? One of the PCs is hooked to 128kbps/broadband  net thru a USB cable modem.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
What you need to do is get yourself a hub and run your modem into the uplink port and your 2 systems into any other ports, i suggest a net gear 5 port hub.
Commented:
Set the protocols. I suggest TCP/IP. Then set up Internet Connection Sharing on the computer that has cable modem (Control Panel > Add/Remove Programs > Windows Components > Internet Components > Internet Connection Sharing (have no win98 machine here so I'm speaking from my memory) and set sharing (Control Panel > Internet Settings > Connections > Sharing). Configure TCP/IP protocol as follows:

computer that has modem:
  IP: 192.168.0.1
  subnet mask: 255.255.255.0
  dns: set your dns address(es)

computer that has no modem
  IP: 192.168.0.2
  subnet mask: 255.255.255.0
  dns: set your dns address(es)
  gateway: 192.168.0.1

That's all. I suggest you set protocols and network settings first, then check if the two computers see each other (Start > Run > Command > OK > PING 192.168.0.x, where x is 1 on computer #2 and 2 on computer #1). If they do see each other, sharing should work, else not.

Now I'm not completely sure what RJ45 cable is; I know it's UTP, but I'm not sure if it's 1-1 or crossover. If you want to connect two computers directly (without a hub/switch), you need a crossover cable. Check out colours of wires inside the cable - they should NOT be in the same order on both sides.

bye
matija polajnar

Commented:
maticek wrote perfect. Besides if you want to share resources just add File and printer sharing in your networking settings, set workgroup names on both computers (like: sam) and then (restart computers and) share your files/folders. Also you should be able to view your computers using network neighborhood.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Thank you for the comments guys, i was out of town and could not reply, sorry.
 Anyway, my network is still not up. I tried what maticek has said. But the problem is the computers are not seeing each other. The cable is a crossed one and everything looks fine. PC1(with cable modem) does not ping the PC2 but PC2 pings the PC1, confusing! One more thing when the PC2 is reset, till it reaches the windows logon dialog. box, PC1 shows the PC2 in network, but not after that.
Do i need to assign DNS?.
In PC2 'entire network' folder is empty' why?

 The TCP/IP config is as follows
PC1(with modem)IP: 192.168.0.1
 subnet mask: 255.255.255.0
PC2
 IP: 192.168.0.2
 subnet mask: 255.255.255.0
  gateway: 192.168.0.1
What should i do to get on to network?

Author

Commented:
Thank you for the comments guys, i was out of town and could not reply, sorry.
Anyway, my network is still not up. I tried what maticek has said. But the problem is the computers are not seeing each other. The cable is a crossed one and everything looks fine. PC1(with cable modem) does not ping the PC2 but PC2 pings the PC1, confusing! One more thing when the PC2 is reset, till it reaches the windows logon dialog. box, PC1 shows the PC2 in network, but not after that.
Do i need to assign DNS?.
In PC2 'entire network' folder is empty' why?

The TCP/IP config is as follows
PC1(with modem)IP: 192.168.0.1
subnet mask: 255.255.255.0
PC2
IP: 192.168.0.2
subnet mask: 255.255.255.0
 gateway: 192.168.0.1
What should i do to get on to network?

Commented:
No, if you ping IP address, you don't need to assign DNS. DNS stands for Domain Name Server and comes into play only when you ping addresses (for example www.microsoft.com - your computer would first contact your DNS to check, what IP does www.microsoft.com have, and then it would contact that IP; if you have IP specified, it doesn't need DNS).

It's strange that one computer pings one, and that one cannot ping back. I would say it's a bad cable but in this case even PC1 would not get ping reply from pc2. It's even more strange about that PC1 sees PC2 while it's booting windows (if I got you right). However, when pings will work, windows networking should also begin to work (if you have set up sharing, put something in share, make sure that both computers are in the same workgroup etc etc etc... :)

First, try to ping PC1 from PC1. Yes, you got right, PC1 should ping itself. That's for making sure that correct IP is set. Hummm.. I'm out of ideas :). Is ping from PC1 to PC2 perfect (0% data loss)? If not, it's gotta be a hardware failure. If yes, I have no more ideas again :).

Oh, in Windows sometimes deleting your network card and all protocols, clients and other stuff you see in network properties helps. Then restart computer and let Windows install network adapter again. Then install all protocols again, set up IP addresses one more time and give PING one more try. Oh, of course, do that on both machines.

And, none of those computers use firewall, does any?

bye
matija polajnar

Author

Commented:
oh,thats a quick reply, matija, u seem to be a net(work)-addict. Anyway coming to the point, both the PCs are pinging themselves perfecly. PC1 does not ping PC2, but PC2 pings the PC1's IP  with 0% loss. Sharing is done, both PCs r in same work group. once i tried deleting all protocols and reinstalling them, including adaper driver in PC2 not PC1. problem persists. What i really don't understand is PC2 does not show the work group/PC ID in the 'entire network' folder.

Let me know if more clarification needed.

Commented:
Unfortunately I have a dial-up line (nothing more available around here, but I would like at least ADSL :( so I can't be online all of the time, but I have got SMS notification for new emails. When you posted that it was around midnight here, but I couldn't sleep, so I decided to look what's new :)

The problem with networking in windows (at least in 98) is that you can never fully understand why something is working or something is not working. I've set up networking many times in our company (actually mom has a company and I am only a student :). 3 computers with win98se to be exact. And if something wasn't working, I was installing, uninstalling, reinstalling ... untill it worked :) Of course I first checked if cards light the "link" led. But I don't think that would be your problem.

Ouch, I misread. I thought that PC1 can ping PC2 but PC2 can't ping PC1. So, PC1 replies with "Request timed out."? Good, now let PC2 ping itself :) But this should work.

About showing icons in network neighborhood - in a perfect situation every PC would see itself and all other computers in network that have workgroup the same, in network neighborhood directly. Entire network lists all workgroups so you can access computers on network with different workgroup names. However, Win98se (and previous versions of Windows) are not the perfect operating sistem for networking. Usually computer doesn't see even itself for some time (let's say a minute). So, try to wait. But still, ping should work immediately.

Why why why .... Out of ideas again :) First check if PC2 can ping itself.

bye
matija polajnar

Author

Commented:
Thank yoou for the reply.
As i said, PC2 is pinging itself (192.168.0.2) as well as PC1(192.168.0.1), PC1 pings itself but not pinging PC2. No clues. Today i changed the network card and cable (confirmed that its twisted)with new ones one after another, still same problems. I do not understand how to check the PCs for firewalls. No geting clue of where things are going wrong. protocols TCP/IP, NETbeui,Client for MS windows, file/print sharing all are showing OK.
help!!!

Commented:
Huh, even more strange. Firewall can be a piece of hardware or (in this case I meant that) a piece of software which protects your computer from unauthorized access. It monitors network traffic (from network card / modem or any other communication device) and decides which signal to accept and which to block.

This, for example (many more different uses are possible), blocks all unneeded traffic, which could even communicate with a trojan or worm in your computer. But I see no reason why PC2 would have firewall. And, of course, Microsoft implemented a simple firewall in Windows XP - previous windows versions do not have firewall built in. So, if it's your computer and you're sure that nobody installed firewall (not even you, of course :), then there's no firewall. And then I'm again out of ideas :)

Perhaps you should try some additional testing. If it's possible, try to connect PC1 with some other computer and try if it works. Try the same with PC2. Of course you have to make sure that computer you are connecting to does not have the same IP number, because then (in this windows version) both computers will shut down networking (of course with a big warning).

bye
matija polajnar

Author

Commented:
thanks for the info. I am writing this from PC2. Yeah ! after 3 hrs of slogging installing/reinstalling got the connection thru. The problem was with the netbeui config on the PC1. Infact PC1 had lots of protocols/services/adaptors but netbeui was not found for the ethernet adaptor but for cable modem. that was the culprit. When i installed it the file and printsharing worked fine. Had to spend couple of hrs to get the ICS (with all that TCP/IP settings etc) done, finally its working fine. I really appreciate the effort people take in solving others computer problems. Great service.Thanks.

Commented:
You're welcome. When I'm very very lazy and I am even to lazy to go to sleep, I usually help people solving their computer problems :)

bye & enjoy your new networking :)
matija polajnar

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial