How To define my http://localhost to start a web ASP.NET app

fmichail
fmichail used Ask the Experts™
on
when I try to open a new project of type web ASP app, I get the following message:
the project folder at http://localhost/Myapp can not be opened with the path c:\inetpub\wwwroot\myapp.

The file path c:\inetpub\wwwroot\myapp does not correspond to URL http://localhost/Myapp. the 2 need to be mapped to the same server location.

The message indicates that my localhost is not c:\inetpub\wwwroot. I reinstalled IIS (my operating system is WIN 2000), the problem is still there.

Could someone please help me solving this problem (I am not experienced in Web development).
Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
I forgot to mention that the Personal web manager indicates that my home Directory is "c:\inetpub\wwwroot"

I hope this may help
Thanks
If you have a proxy server running, it may be redefining the IIS defined localhost. If that's the case, goto the Internet Options of IExplorer and select, Connections, LAN Settings and set the Bypass proxy server for local addresses checkbox.
Check for Proxy server as Derek mentioned. If that doe snot help, then add an entry in hosts file if its missing

127.0.0.1       localhost

This file will be in <system folder>/WinNT/Drivers/etc folder.

Author

Commented:
Thank you DerekHordle
I followed your advice, but I did not find the mentioned checkbox, rather i found another checkbox (automatically detect settings) which I unchecked and it looks OK now.
I think that was because I am using router (If that means I am not using proxy).
again Thanks a lot. Excellent fast answer.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial