Palm m515 USB cradle and Windows XP

Posted on 2003-01-06
Medium Priority
Last Modified: 2010-04-29
I have a palm m515 with the USB cradle.  I recently changed laptops from a Windows 2000 machine to a Windows XP machine.  I've tried just about everything including a bunch of suggest ideas that are out on the web and some extra driver installs but nothing seems to cause the XP machine to recognize the cradle/palm.  I can sync through IR (so the palm desktop software does work), but that is not the preferred due to speed and convenience.

I've tried the original CD with Palm Desktop 4.0.1 and a downloaded version of Desktop 4.1 with no luck on either.  Everything in the Control Panel System indicates that the USB is working fine and I have tested the USB port with a USB SmartCard reader that I have for my camera's cards.  I tried force adding new hardware and selecting palm but even when I get that hardware force added, it indicates that it doesn't know about the device.

Any thoughts?

Any more questions?
Question by:quietyakr3
LVL 17

Expert Comment

ID: 7691083
I had same problem with a Palm i705 and I tried everything but it would not work, then as soon as I give up (shutdown and reboot) then it would work. I don't know what I did different because I had rebooted several times before with no results to show.

Expert Comment

ID: 7695813

Unfortunately there is no one answer...and I have tried for many many hours troubleshooting to find the root cause and solve this problem...there is a Common tag that is being given to this problem (SUDS...Suddenly USB Doesn't Synch...)and there may even be a class action suit against Palm...
However, I believe it is not a Palm Issue at all but an XP/USB issue...
If you find the answer I believe that the world will be a better place for all PIM USB users...

Please let me know if you find the cure...thanks.

Expert Comment

ID: 7704339
1. Uninstall Palm Desktop.
2. Boot into safe mode and check you device manager for ghost USB device drivers and get rid of them.
3. Reinstall Palm Desktop.

Just try.
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.


Expert Comment

ID: 7716798
Will give that a try...I will be forwarding this to several people that are having this problem...Thanks...

Accepted Solution

dhickey earned 2000 total points
ID: 7746923
Ok palm and handspring folk alike I hope this helps. Please read entire post before proceeding. Print it out if need be.

I will assume everyone has tried the basics if not please do them before attempting anything else at this point.


1. Soft reset the unit
2. Exit the Hotsync manager on the PC
3. Open the hotsync manager on the PC
4. Make sure Local USB is checked or Local sync for palm folk
5. Plug the cradle directly to the computer, no hubs or port replicators or docking stations.
6. Push down on the unit while pressing the hotsync button. Close your eyes and count to ten. No happy hotsync sound :( .. continue

Please be careful with the rest of this.

WinXP Instructions. (DO NOT ATTEMPT ON 98, ME OR 2000)

1. Click Start | Run type regedit
2. File | Export
3. Enter a filename | Make sure the Export range is set to "All"
4. Hit "Save"

5. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB

6. Expand the Folder "USB", Now depending on which device you are using Palm or Handspring you may see one or two of the following

vid_082d&PID0100  ---- handspring
vid_082d&PID0200  ---- handspring
vid_0000&PID0000  ---- all
vid_0830&PID0001  ---- palm

Please note the numbers after "PID" may be different than the ones shown.

Whichever one you have DO NOT EXPAND THE FOLDER. Right click on the folder and chose "Permissions".

From the permissions window, check on the box to "ALLOW" "FULL CONTROL". Hit Apply and then OK

Now be careful here, delete the VID Key you allowed full control to. Again do not open the folder, simply right click and chose delete. You will need to duplicate these steps if you have multiple vid keys from the list above. If you are not allowed to delete the key simply move to the next one.

Ok, next navigate to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Enum\USB

Repeat step 6

So you made it this far, good.

Unplug all and any USB device and restart the computer. Once the computer has fully booted plug back in the USB cradle directly to the computer (very important). Check your basic settings, soft reset the unit and attempt to hotsync.

If you are prompted to find a driver, navigate to whereever your palm or handspring folder is located and highlight the drivers folder and click OK. You do not need to specify the driver it will find it by itself if the correct folder is chosen.

Please re-post if you have questions or concerns. One more thing to add. If you really want to make sure you are deleteing the correct VID key you can search your computer for a file called 1. PalmUSBd.inf or 2. VisorUSB.inf
Both of these files have a list of the correct vid keys. Just open the file using Notepad.

If you need steps for 98, ME, 2000, OS 7.5 - 9.2 or OS X please repost.

If anything goes wrong double click on the backup registry file you made and import your old settings.


LVL 14

Expert Comment

ID: 10414887
quietyakr3: No comment has been added lately, so it's time to clean up this TA
I will recommend this question to be:
  - sent to PAQ database with acceptance of dhickey's answer
My recommendation is based on the posts I read in this thread, and might change if a fairly reason arises.
Please leave any comments here whithin the next four days.

If the asker is a newbie here and doesn't know how to close quesstions, then I can point him towards: http://www.experts-exchange.com/help/closing.jsp

Experts-Exchange - Page Editor

Expert Comment

ID: 11688982
Thanks dhickey,

After hours of frustration, your solution seems to have done the trick!

Thanks again.


Expert Comment

ID: 13940248

I am having the same problem on my laptop running Windows 2000. Could you please post your solution again specifically for Windows 2000?

Thanks a bunch. I have been DYING using IR all this time with my Palm Tungsten... :P

Hope to hear from you!

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

If you use the Google Now Launcher, as an aftermarket add on, have a Samsung Note 5 and are worried about power consumption be wary of using the ultra power saving mode.  Here is what happened to me when I made the mistake of trying this out...
This article summarizes the problem of addictive cell phone usage that college students across the country are facing. It covers the issues with obsessive cell phone addiction, reasons why this is happening, and what we can do to solve this problem.
Planning to migrate your EDB file(s) to a new or an existing Outlook PST file? This video will guide you how to convert EDB file(s) to PST. Besides this, it also describes, how one can easily search any item(s) from multiple folders or mailboxes…
In this video I will demonstrate how to set up Nine, which I now consider the best alternative email app to Touchdown.

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question