Unlock a Western Digital HDD

Adam Mason
Adam Mason used Ask the Experts™
on
I have a WD80EB HDD that I purchased on-line.  I believe it is locked, and do not have either the user or master password to unlock it.  How would I get this thing unlocked so I can re-format it?  I've tried Data Lifeguard Tools from WD, and that won't even let me do a low-level format.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
How to lock / unlock the hard disk drive:
http://www.experts-exchange.com/Hardware/Q_20517922.html
CrazyOne,
   I think U really have gone crazy. Whats the idea copying the URL of the same question & posting it here ?
Please act in your complete senses.

Regards,
Zubin

Commented:
It was mistake in fact I don't remeber why I copied that url to begin with.

http://www.computerhope.com/issues/ch000355.htm 
"Whats the idea copying the URL of the same question & posting it here ?"

LOL!
hmp? wonder why it can be low level formarted. its the lowest of the lowest format possible. it should erase everything. ok with fdisk, an error should occur. but with low level format? hmmp?
follow CrazyOne steps first on how to unlock the hardisk.
if this doesnt fix the problem,
Email the site where you purchase the harddisk.
may probably get a warranty for this.

Commented:
Are you sure it is "locked"?
Is it seen in the CMOS setup correctly?

Is this a new HD? maybe it is bad out of the box? dropped and damaged maybe?
WOW Im just impressed or shock well maybe just simply amazed that crazy one makes errors like the rest of us

Commented:
I think he did it on purpose just to test to see if anyone actually looks at the posted links.

Test complete
:>)

Commented:
Hehehe see Ray knows my methods. Actually he is my tutor. LOL
Hi majestikm00se,
  Have U tried Partition Magic? Sexy tool. Well, another thing, Intels Dos based DiskManager is quite compatible with hdds of many companies as long as U dont mess around with the track 0 or MBR programming/ device drivers.

Try it out. Am sure it will eliminate any chances of software config being the cause.

I kinda believe this has its roots on the hardware side.

Regards,
Zubin
Just a thought, try installing another known good hard drive as master and that drive as slave on the system get windows 9x or higher installed and try right clicking the
WD80EB HDD and then click format.

Commented:
What a strange command.

Lock ENABLES disk access and Unlock DISABLES direct disk access.  Seems backwards.

If the lock command doesn't work, perhaps the boot record is screwed up.  Try FDISK /MBR  to rewrite it and then try FDISKing again.

Author

Commented:
The drive shows up in the BIOS correctly, but when I run FDISK it says "Verifying drive integrity 0%" for about 30 sec then errors out.  Low-level format errors out on sector 0.  I'll try the /mbr switch w/ FDISK, but this is locked with a hardware type password, nothing on the software end.
Hi,
 Re: rewriting the MBR drivers? Be sure U use any WD compatible or pref WD utils. U never know cause some incorrect software might screw up Ur drive MBR

Regards,
Zubin

Commented:
try using the free diagnostic utility from the Western Digital to check for problems with the disk.

Western Digital
http://support.wdc.com/download/
www.westerndigital.com 
HDD lock by LOCK command cant be FDISK or Formated. Email the site the where you purchase the HDD. Ask for instructions on how to unlock it.

You said there was a "hardware type password". what is the message? or error message?

Data lifeguard write zero's on hardrive(low level format) does not work??

If low level format wont work. return the hardisk for warranty and say you cant even format the HDD. Something is wrong with the hard disk. Give all the excuse you can give. Ask for warranty.

But Try this first.
Create a boot disk(from other computer) or if you have one
Boot from floopy. WIN98 bootdisk.
type unlock c:\

if this doesnt work.
DO a low level format
or
return the hardisk.
endif
Lock and Unlock is internal to command.com and only available in window's 98 and win95's command.com.
Not available on win2000 or nt
The WD80EB hard drive is used in the xbox game console. Western Digital does not even sell this drive to the public. I would suggest you look into xbox sites to solve your problem
Hi all,

Chances are, you're screwed. Return the drive if you can. If you can't, scream bloody murder to the owners of the site and the Attorney General of the state in which the store does business.

Harddrive passwords are notoriously difficult as they do not allow the system to boot without the correct password. You would require a hardware solution to bypass the HD password.

Look here for more information regarding this issue:
http://www.experts-exchange.com/Hardware/Q_20423260.html
http://www.xbox-news.co.uk/extracting_pass.htm

Or, if you happen to have a spare logic analyzer sitting around:
http://www.xboxhacker.net/index.php?do=article&id=7&page=1

pb
Hi All,

Update:
I just locked myself out of my laptop's HD for the past few days. I set the Master and User passwords for the HD, then locked it. An interesting note is that my laptop's BIOS doesn't support the ATA password locking, so I wasn't asked for a password when I rebooted.

Instead, the BIOS POST reported a HD error, and refused to boot. Of course, I was using my older 486SX/25 to practice on, and it has an external PCMCIA floppy (Compaq Aero 4/25) which I had misplaced, so I really had to try to hack into the HD.

The results? No go. Once the drive is locked, the ATA controller only allows a few commands to be executed:
Drive identification and geometry
Unlock with password
Erase with password

Luckily, I found my floppy so I didn't have to pull the HD and drop it into another computer. I unlocked it with the password I had set, then disabled the security.

Conclusion:
Without some serious knowledge of the ATA specifications and some rather expensive logic testing equipment, the drive will remain locked.

Alternative solution:
1) Replace the HD's controller card. This will give access to the drive, but you are left with a useless controller card.
2) Buy a new drive. They're cheap.

pb
Hey, its not worth spending to buy a new HDD !!
  I disagree, majestik. Id say U find out more about this issue. i am sure someone somewhre if not at EE wil be able to guide you. it sounds a bit stupid that a software locked hdd needs to be replaced. Good Luck. Dont loose hope.

Regards,
Zubin
Hi Zubin,

Again. It's not a software lock. It's a firmware lock that's actually built-in to all ATA3 compliant hard-drive controllers.
http://www.seagate.com/support/disc/manuals/ata/d1153r17.pdf

The HD controller doesn't allow read or write operations while the disk is locked. So, you can't format, you can't fdisk, you can't low-level format. You can't do anything. This is because the ATA controller will not allow it.

If you would like to review the ATA specifications yourself, please refer to:
http://www.seagate.com/support/disc/manuals/ata/d1153r17.pdf

Page 47 of the PDF document (Document page 30) describes the basics of ATA locking.

Page 160 of the PDF document (Document page 144) describes the device registers and ATA subsystem commands used to interface with the locking features.

pb
Thanx pb,
  Sorry folks, I agree, it sounds a bit too complex & seems bad luck is shadowing majestik. But still, Id say, hold on & find out from some other industry experts.

Regards,
Zubin
3) UNLOCKING THE XBOX HDD:

Since the XBOX HDD has the ATA Security feature enabled, you'll need to unlock it before you attempt to image it. This is the cable swap method. Setup your XBOX and your PC right next to each other, such that the PCs available IDE drive cable, and power connector can reach the XBOX HDD.

* Connect an available power connector from the PCs power supply to the XBOX HDD.
* Connect the IDE cable from XBOX to the the XBOX HDD.
* Power up the PC and hit the "Pause" key before it autotypes the drives.
* Power up the Xbox to the idle Dashboard.
* During the Xbox startup, the Xbox transmits the password via the ATA Unlock Command, and the drive is unlocked.
* Now, carefully disconnect the Xbox IDE cable from the Xbox hd.
* Plug the PC IDE cable into the Xbox hd.
* Hit any key on the PC keyboard to let it continue to boot.
* Now the drive is unlocked and reconnected to the PC, ready for read(/write?) operations.

majestikm00se:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
Dave PuseyIT Support Specialist

Commented:
>> Whats the idea copying the URL of the same question & posting it here ?

ROFL

Commented:
It's a bios setting...the password is a bios password for locking lowlevel disk write access...not a drive setting at all...


Peetoose

Author

Commented:
peetoose... It is NOT a BIOS password; read the accepted answer.  Unless you know a way around the ATA lock, I'm stuck.

Author

Commented:
I believe the backdoor password for a seagate drive is on the net.  I'm not sure what it is, but I did find some hits from google/yahoo/altavista.  The problem with these drive is that they are proprietary, meaning we as consumers should never see them.  TiVos, etc use your standard IDE drives too.  you may also want to search for that.

Commented:
Have you tried that old DOS trick.  fdisk /mbr

Author

Commented:
jrivera: Yup, no dice

Commented:
ozzmundo,
Your profane comments have been removed.

Nata
EE Page Editor
The WD80EB HDD you have purchased is a Xbox harddrive i have this very drive next to me with the same code.  Unfortunately you will not be able to unlock this drive without the original Xboxv system it came in.  This is because the Xbox's were made to recognize any hardware changes, such as harddrive swapping, and the unlock code has to be retrieved from the Xbox BIOS from which it came.    
Actually it is stored on the EEPROM(of the xbox), i was wrong, not the BIOS.   You can try using Liveinfo with UnlockX.
I may be stating the obvious here, but it may well be that either WD or XBox have developed a 'backdoor' solution to this, perhaps using debug from a DOS boot disk.

Good luck whatever.

Commented:
Sad to have read all this, for some reason my HDD locked up and my computer won't boot without the password, or unless I remove the locked HDD.

After reading all this, does that mean it's a lost cause and all data on the drive is basically gone and I should buy another drive?
If this is infact an xbox harddrive, depending on what the person before you did with it... it might be possible to unlock it.  I have 2 suggestions.  First you'll need

http://dwl.xbox-scene.net/~xbox/xbox-scene/tools/harddrive/atapwd.zip

put that on a dos boot disk... boot from it, and run the prog... once you do you should be presented with a list of hdd's on the system... select the locked drive from the list.

now you will be presented with some options...
(time for a side note: if this drive infact has come from an xbox, then there should be no master code set, the xbox only uses the user password option...)
so try setting a master password and then try unlocking the hd with it... (there might be an option for disabling lock, use if available since the drive will relock upon rebooting)

option number 2 (consider yourself lucky if this does) if the person you received the drive from has locked/unlocked it on an xbox with a utility called "ConfigMagic" the master password would be set to "TEAMASSEMBLY" <--CaSe SeNsItIvE

Hope this helps... only other way is with a copy of the eeprom of the xbox this drive came out of...
Dave PuseyIT Support Specialist

Commented:
SilverSurfRCBR, its too late now to be giving an answer as the question is already closed.

Also, why does an xbox hard drive have to have a password? Just seem to make things more complicated for you modders.

Author

Commented:
SilverSurfRCBR: Well... I'll try that.  I assume it was yanked out of an XBox with a defetive board, since the company I bought it from said the board wasn't available.  Give me a couple of days to tear my case open and I'll get back to you.

davepusey: 1) I had to close the question because the Admins asked me to; my comments posted 3/2 and 3/4 show that its not answered.  I gave pbarette the points since (s)he was the closest to an answer.  2) That's the point.  M$ doesn't want people modding their XBoxes.  And I mean "Billy"; they still have a legal right over them.  I believe part of the EULA says you won't modify the hardware or software, so dropping a modchip in violates the EULA and legally, you can't use the console anymore.
Dave PuseyIT Support Specialist

Commented:
>> and legally, you can't use the console anymore.

That wont stop people (just look at file sharing networks). It'll just void there warrentys.
Dave PuseyIT Support Specialist

Commented:
>> part of the EULA says you won't modify the hardware or software, so dropping a modchip in violates the EULA and legally,
>> you can't use the console anymore.

but why whould that involve locking the hdd. only the save files are stored on that arent they?

Author

Commented:
Actually, there was an uproar because M$ figured out who modded their XBoxes and banned them from XBxox Live.  And the reason for locking the HDD is to prevent exactly what I have here.  You can put a larger harddrive in the console, and then you're stuck with a paperweight.  There is much more on the harddrive than savegame data.  Its actually in (I think) 7 partitions.  There is downloadable content (extra levels), patches, etc. each stored in a desgnated partition.  Access to this would presumably give away something that M$ is paranoid about.
most xbox hard drives have 6 partitions... 1 - is the system files (Dashboard(the OS), 2 - savegame data which also holds patches, levels, etc, 3 - unused(only on unmodified hds), 4, 5, 6 are caching partions for game data. 7th is available when using a hd bigger than 120 gigs, and comes after 3.

there are plenty of ways to get access to the data on there, trust me ;)
and upgrading a HD can be done on the box without even having a mod chip, trust me on this one too ;)

>>Access to this would presumably give away something that M$ is paranoid about.
Yeah... holes in security

Author

Commented:
yeah... I breezed through the description of the HDD partitions.  I really didn't care about any of it, just wanted to know how to unlock the little #$%&er.  Its good to know something stuck.  :P

Commented:
I unlocked 5 of these last year without ever seeing the X-Boxes they came from...

Unfortuantly I don't remember *exactly* how I did it..

I do remember:
I searched for info on the "Gamer" sites and downloaded some utility.
It was tricky... Hot plugging drives type thing...

I know it's not much help but I thought you'd like to know it's DEFINITELTY possible to unlock it without an X-Box..

(( And in responce to another post: A BIOS is a program coded into an EEPROM chip. It is correct to call the EEPROM on an X-Box the BIOS chip. ))
I got the same problem with a brand new Maxtor 120 GB Hdd (DiamondMax 10)........

Can't do ish with that thing, altough i have the right hdd pass (from eeprom.bin)........
when i want to unlock it, it just don't takes the pass.....
it's like i mistyped it when locking the drive with hdlock.exe... :(

so what i want to know........
what can i do about this *ISH*???

can't do anything with the HDD now............ :-(((

Can someone help me????

PLEASE???


Greetz & Thnx

oiOIoi
Several things that I would like to add.

Toshiba L305 does not have the option of removing and reinserting BIOS battery.  The error is "Enter Built-in HDD password."  

It cannot just be put into another laptop because that drive will not show up as a drive at all (it's locked).  Data cannot be read at all.

No one put the password in the laptop. Backdoor passwords do not work.  

BIOS has the HDD password option grayed out so it cannot be changed in the BIOS.  

Any other suggestions?

OH, bythe way, Tohiba wants 485 bux to "fix" it.  

Commented:
Whoever told you the CMOS battery isn't removable was a liar.
They are for sale for that model all over the internet.
- But that won't help anyway.

'Locked'
-
When the system first starts a 'what are you' signal passed globally from the BIOS.
The various devices answer by telling the BIOS what they are.
[This is all early during BOOT/POST.]
-
With a locked drive instead of giving the BIOS that info, the drive asks the BIOS a question.
It asks the BIOS for a key code.
-
That key code was created earlier based on the drive's serial number and 'some' serial number in the computer and then stored both in the BIOS and in the drive's firmware.
-
Without that key the drive's on-board firmware won't allow access to the drive.
It does that by not telling the computer's BIOS what is is.
-
The BIOS in a different computer will not have the correct key stored.
Wiping the BIOS by removing the CMOS battery won't put the correct code into the BIOS either.
.

Unlocking methods. [In general]
-
If you can figure out how to clear/reset the firmware ON THE DRIVE, you might get somewhere.

Capturing the code and then sending it to the drive long enough to clear the password works with some drives.
[A hacker-built program is needed from wherever for that drive.]

Some can be wiped by shorting certain pins on the drive's PCB.

---

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial