?
Solved

xp can access internet but can't ping router or other computers

Posted on 2003-02-18
21
Medium Priority
?
637 Views
Last Modified: 2012-06-27
Everyone is stumped!! Situation:  Linksys Router BEFSR41  with 3 computers, xp,win 98 and win 2000.  All computers in same workgroup with unique computer names, assigned Ip addresses by DHCP on router.  All computers can access internet and see each other.  BUT XP COMPUTER CAN ONLY SEE ITSELF AND IS UNSEEN BY OTHER COMPUTERS EVEN THOUGH IT CAN ACCESS INTERNET.

Brought laptop and plugged it in where xp is located and no problems.

So the problem is with the XP Computer.

Here are results of ipconfig/all for XP computer:The only thing different when I run ipconfig/all on the other computers is the Node Type which on the other two reads Broadcast and the Ip addresses.

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

E:\Documents and Settings\Melissa>ipconfig/all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : Office
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 13:

        Connection-specific DNS Suffix  . : ph.cox.net
        Description . . . . . . . . . . . : NETGEAR FA311 Fast Ethernet Adapter
        Physical Address. . . . . . . . . : 00-40-F4-6C-DF-E8
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.102
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 68.2.16.30
                                            68.2.16.25
                                            68.6.16.30
        Lease Obtained. . . . . . . . . . : Tuesday, February 18, 2003 9:34:39 A
M
        Lease Expires . . . . . . . . . . : Wednesday, February 19, 2003 9:34:39
 AM



Here are details of the Network connection on the XP Computer
     

General      Client for Microsoft Networks
          File and Printer Sharing
          TCP/IP
            Obtain IP address automatically                           Obtain DNS server address automatically
            DHCGeneral  enabled
            Append primary and connection specific DNS suffixs
            Enable LMHosts lookup
            Net Bios: Default
            TC/IP filtering: permit all

Authentication
     Enable network access control usine IEE 802.1x
     Smart card or other certificate
     Authenticate as computer when computer information is           available

XP firewall is disabled and no other firewall software is on computer.

I can ping loopback and local host.
I cannot ping router, other computers, dns servers, wan ip address.
I removed all programs from startup with msconfig.  Did not solve the problem.
IPSEC is not enabled

Any suggestions???????
0
Comment
Question by:mtoc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 14
  • 4
  • 2
  • +1
21 Comments
 
LVL 3

Expert Comment

by:Opera362
ID: 7980535
First of all, make COMPLETELY SURE that the Subnet Mask is equal to all three computers. It has to be, but test it.

And the addresses are on the same subnet:
192.168.1.102 for your XP, named "Office" computer
192.168.1.x for others?

If all fails, you can also "reinstall" TCP/IP in your XP computer. Since TCP/IP is now part of the WindowsXP, it can't be uninstalled as before, but you can follow this steps:
http://support.microsoft.com/default.aspx?scid=kb;en-us;299357
(How to Reset Internet Protocol (TCP/IP) in Windows XP)

In addition, I encountered some problem once with Windows XP with an ADSL router (the same as you, but the computer didn't have internet access either). The only solution I found was uninstalling the net card (unplugging it), and then reinstalling. But before reinstalling, I had to manually delete all references of it from REGEDIT... If you want the steps I follow, I will post them later, I'm currently at work and that info is at my home.

Anyway, good luck!! ;-)
0
 

Expert Comment

by:pembers
ID: 7983325
Spooky - i've got the same problem but different. Two node XP peer-to-peer network, but installing HP's Laserjet 1200 screwed it all up. I can connect to my ISP and get authenticated but can't ping out even though no firewall is installed. I can share folders on the two machines, no problem.

Was advised by my man-who-knows that this is a known prob and that I should try the 'remove the network card and reinstall' solution, but, ah-ha, I have onboard Ethernet.

So, I will apply HP's fix tomorrow and reset the TCP/IP stack.

Let's crack this one together.

Stuart

0
 
LVL 3

Expert Comment

by:Opera362
ID: 7984784
Pembers, you can probably "unplug" your onboard Ethernet disabling it in the BIOS :-)
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 

Expert Comment

by:cdsmark
ID: 7984788
Had this happen to me before with a new xp pc and existing 98 stations on the same workgroup.
Removed networking from the 98 pc's and reinstalled.
After that, everyone could see everyone!
0
 
LVL 3

Expert Comment

by:Opera362
ID: 7984840
To mtoc:

These are the steps I followed to "revive" the internet connection in my XP computer (they are RISKY, because you have to use REGEDIT... so take care, make backups of the registry folders before deleting them)


At REGEDIT's main screen:

Go to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}

-> look for some branch "0000", "0001", etc. in which "DriverDesc" corresponds with your Ethernet Adapter and then delete it.



Go to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
\Control\Network\{4D36E972-E325-11CE-BFC1-08002BE10318}\Descriptions

-> Delete line with description of the ethernet adapter



Go to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
\Enum\PCI\

more tedious-> Look *again* for description of ethernet card, inside *EACH* subfolder of the "VEN_xxxx&DEV_xxxx&SUBSYSxxxx, etc". When you have found it, delete the "VEN_xxxx&DEV_xxxx&SUBSYSxxxx, etc" main folder.



Go to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\
\Services\


difficult-> Look for network card driver, and delete (in my case it was "rtl8139")


Maybe some of this steps are not needed. But I can say that, AT LEAST one, it's needed. I tried unplugging the netword card, and reinstalling drivers from scratch, and no solution. But following these steps I was able to gain internet access (and file sharing) again.

Good luck!!!!!
0
 
LVL 3

Expert Comment

by:Opera362
ID: 7984858
cdsmark, were you able to ping the router with XP computer? I even tried to do that with ONLY the ADSL router pluged to the XP computer (with a cross ethernet cable) and EVEN THAT didn't work... :-(

(and after all the above steps I wrote, it worked)
0
 

Author Comment

by:mtoc
ID: 7990542
Ok - I've tried everything!  

Yes, subnet mask is the same on all computers and they all have the same address 192.168.1.x assigned by DHCP server on Router

In this order I:

1.  reset the tcp/ip with netsh - no results

2.  removed networking from 98 pc and reinstalled - didn't work

3.  used regedit and removed all the keys , turned off computer, took out network card, restarted computer, turned it off, reinstalled network card and rebooted - still same situation.  Can access the internet but can't ping router or see other computers.  They can't ping me either.

I keep thinking that maybe there is some kind of service running in XP that is causing this problem.  What else can it be?

Thanks for all the suggestions. I've got to solve this problem short of uninstalling xp - although I did consider it. I've searched the knowledge net at Microsoft but can't find anything relevant that has worked.
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8002732
mtoc, try getting a cross over ethernet cable, and link directly the computer with XP and some other one.

Then assign temporaly two statics IPs to both of them (like 192.168.0.1 and 192.168.0.2, subnet 255.255.255.0 for both) reboot and do a ping test.

If the computers can ping (find) themselves, then the fault its whithin your ROUTER (and not the XP computer) maybe it need to be restarted or something like that.

Let's no advance anything. Just test the PING with a cross over cable.

(by the way: a cross over cable is a LAN cable used to directly connect two computers, or to link two Hubs, switches, etc. it's not difficult to find, is a "standard" cable).

By the way, you said that:
"All computers can access internet"

But, at the same time, you said:
"I cannot ping router, other computers, dns servers, WAN IP ADDRESS"

It's important that you CAN'T ping a WAN IP address, but you have internet access... so? how does it translates?

I mean, can you do this from XP computer?:
PING www.experts-exchange.com

or this?
PING 206.169.61.185

Maybe the fault it's "only" with the DNS server, sometimes you can't access anything if the DNS is bad configured. Let's check that too. And what do you mean by "internet access"?

Good luck!!!! ;-)
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8002763
By the way, excuse me if I told you to do some tests you've already done. I know this is an "angry" error (when my network card didn't work I was crazy trying to recover its internet connection) ;-)
0
 

Author Comment

by:mtoc
ID: 8003576
To Opera 362:

I linked my xp computer to my laptop with a crossover cable after giving each a static ip address in same subnet mask. Couldn't ping other computer and I tried from both the laptop and the xp computer.
Just to make sure, I linked my laptop to the win 98 computer doing the same thing and was able to successfully ping from both computers.

So I think this narrows it down pretty much to something on the xp computer.

To answer your questions:
When I say "internet access" I mean that I can use the internet from the xp computer, receive email, no problem BUT I cannot ping a dns name such as www.experts-exchange.com or the ip address 206.169.61.185.

Thanks for the continued help.  I'm not offended by suggestions to do any tests.  Obviously I'm missing something.  Another thing I did do that I might not have mentioned.  I searched for any remnants of zone alarm but the files were all deleted.

So...any further brainstorms?  
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8004046
Ok mtoc, so this definitely narrows the origin of the error, as you said, to the XP computer.

I think it *has* to be something with external firewalls or the internal XP firewall. You've mentioned Zone Alarm... maybe you deleted all the files, but some service is still running.

The PING uses an ICMP connection, make sure the XP firewall is completely off (in Local Area Connection properties, advanced tab, turn off "protect my PC...").

You can also try to enable it, then click on "Configure..." button and see if something it's marked there like "Deny echo", etc.

More things to do:
Download Adaware 6 (free for personal use) at:
http://www.lavasoftusa.com/

And do a system scan. Maybe you have some sort of spyware firewall who is blocking some things the internet access (this can be a possible solution).

I wait for your comments ;-)

Good luck!!!
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8004060
Sorry, regarding internal XP firewall, I wanted to say:
"you can try to enable it, THEN APPLY CHANGES, REBOOT AND AFTERWARDS, DISABLE IT" :-) I missed too many words, hehe... sorry.
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8004063
Also, did you ever installed some internet sharing program? or even the Windows internal internet sharing (ICS)?

This can also activate a firewall. So if you did this, try uninstalling it, or disabling ICS (internet connection sharing).

Good luck!
0
 

Author Comment

by:mtoc
ID: 8004523
Enabled ICMP, rebooted, disabled, rebooted  -  no good
Guest account is enabled
Computer Browser is started
No firewalls
Downloaded adaware, ran utility, found weatherbug and alexa and removed them but still no ability to ping.  

How can I get on the internet and not be able to ping?
0
 
LVL 3

Accepted Solution

by:
Opera362 earned 1600 total points
ID: 8005170
My God, this is a very strange problem (but not rare: see http://www.computing.net/networking/wwwboard/forum/10920.html)

First of all, ICMP is an internal protocol that Internet (well, TCP/IP) uses with some special tools like PING. So it could be possible (but I though not...) to be able to surf the web and receive email with the computer not being able to PING some other.

PING uses "ICMP Echo Requests" and surfing the web not.
(if you want to know more about ICMP: http://www.hippy.freeserve.co.uk/nopings.htm)

So, it seems that ICMP packets are discarded completely at your XP computer. Why? I don't know. Maybe because of a firewall being running there, but *very* hidden...

So, reinstall Zone Alarm, reboot and then set it to "no protection at all" or whatever it's called. Let's hope than now you can ping other computer. If it's the case, then try uninstalling Zone Alarm (maybe when installing it solved some configuration of TCP/IP error) and test again. If all ok, you're done!! ;-)

If installing Zone Alarm, and setting it to "no protection at all" does nothing... oh my God... what to do next? I don't know... let's hope that this helps and I'm be thinking of another solution in the meanwhile...

Good luck!! I mean, please, really good luck!! ;-)
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8005208
I've also found this:

"How to Troubleshoot TCP/IP Connectivity with Windows XP"
http://support.microsoft.com/default.aspx?scid=kb;EN-US;314067

While looking:
"Network Problems with a Router in Windows XP"
http://support.microsoft.com/default.aspx?scid=kb;en-us;315978

In the first one, there are a lot of possible causes and steps to test or fix them.

In brief, look at this paragraph:
"Checking Packet Filtering
Mistakes in packet filtering can keep address resolution or connectivity from working. To find out whether packet filtering is the source of a network problem, turn off TCP/IP packet filtering. Follow these steps:"
etc.
http://support.microsoft.com/default.aspx?scid=kb;EN-US;314067

Let's solve this problem!!! ;-)
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8005232
One last question, did you ever installed and run some "internet accelerator" software? (just curiosity)
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8005321
Some more hints about Zone Alarm (check them at the bottom of the page, they help about ALLOWING to PING other computer):
http://www.wown.com/j_helmig/noping.htm
0
 

Author Comment

by:mtoc
ID: 8006319
Congratulations - 2 heads are always better than one.  Thank you.  I had thought of reinstalling Zone Alarm, but dismissed the impulse because I had uninstalled it as thoroughly by searching for files and deleting them, and even deleting registry keys so as far as I knew, no trace of Zone Alarm was left on my computer.  Surprise, surprise.  Don't know where it was hiding but somehow it had something still on my computer.  Finally, I can get a life back.  This has been a major burden.  Thanks again.  Melissa
0
 
LVL 3

Expert Comment

by:Opera362
ID: 8007466
You're welcome ;-) I'm happy because the problem has finally been solved. Always learning from these cases.
0
 

Expert Comment

by:pembers
ID: 8007491
And my problem was ZoneAlarm hanging around too...

I cheated by reinstalling and reducing its security to zero. Then I uninstalled.

Well done all.

Stuart
0

Featured Post

WatchGuard's M Series Appliances - Miecom Approved

WatchGuard's newest M series appliances were put to the test by Miercom.  We had great results and outperformed all of our competitors in both stateless and stateful traffic throghput scenarios! Ready to see how your UTM appliance stacked up? Download the Miercom Report!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
This month, Experts Exchange’s free Course of the Month is focused on CompTIA IT Fundamentals.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Suggested Courses

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question