?
Solved

Fujitsu 40 gig format/partition problems

Posted on 2003-02-19
10
Medium Priority
?
626 Views
Last Modified: 2007-12-19
I am working on a friends box, IPC 1GHZ Celeron, 256 meg, with 40 gig Fujitsu drive (Chaintech 6VTA2 MB). I am no expert but am fairly comfortable with most aspects of computer service etc., software and hardware, both Linux and windows/dos based. This box crashed running XP OEM. No OEM preload just a licensed Win XP OEM copy. Has FAT 32 partition. Cannot format correctly, cannot reset to zero with Fujitsu ferase program. Fujitsu diagnostics not working correctly. Partition size errors, write errors etc. on scandisk. Removed partition with PMAGIC 8 and created new, did not work shows now as bad in PMAGIC. I have installed 1 gig WDC harddrive and installed win 98 to try and work around, works fine if Fujitsu drive installed as slave, once Fujitsu removed I get disk boot failure, insert boot disk? This is very puzzling, I am on my home LAN can read Fujitsu add and remove files although it is slow, both on LAN and from WDC/98 disk. It seems like a hardware issue but I do not understand why I need the Fujitsu disk to operate system with a separate (C:\) harddisk. What info is the computer after on the Fujitsu to boot and why can I not remove/replace it? Is there a non-Fujitsu program I can use to reset to zeros? Is this maybe a BIOS issue? Can anyone assist with this, I am too stubborn to quit until I find the correct problem/solution.
0
Comment
Question by:myke99
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
10 Comments
 
LVL 24

Accepted Solution

by:
SunBow earned 200 total points
ID: 7984011
I am confused, may need to read that again a few more times. In meantime, let me say this is what I think it is not:

a) OEM copy
b) Fat32
c) HD.

I am aware that at one time Fujitsu was putting out HD's that would fail in 1-3 months, at maybe a little over 50%. I think they were in 20-40 MB range, for certain models, but cannot recall if yours is one. Compaq was one of the OEMs, and nearly a year ago put out a teeny program to run a simple check of their machines, with a simple check for yes/no to ID such bad drive behavior for all drives n all their machines.

But you've added so much more to the puzzle, I am reluctant to suggest bad HD. But I'll make that my 1st bad guess anyway:

1) "It's the Hard Drive, replace it"

Here are two things you should do before any of that PMQ shenanigans (save that for after things are working well):

i) Boot XP. Use It's Disk Manager (under Admin tools, or right click MyComputer). Take the drive #2 and wipe it out, removing all partitions. Then, add its size back. Then make it as you like, preferably NTFS. Thaen give it any letter you like to.

ii) Troubleshoot w/XP. Boot CD. Say install to menus. As soon as you can select repair. Run its Recovery Console.  This one is different, has less and more options than prior repair versions. One of the things it handles better is situations such as yours, through a series of programs that can run like in DOS, namely, rather independent of health of HD. You can also make this an option on multiboot menu, and IMO that is advisable. Use these tools to make queries on configurations for all the HDs and partitions. This may give you the final clue you need to resolve.

Footnote: I am reluctant to push you to do things such as i) since it looks like you think d: has something needed for boot process. Maybe even the entire Operating System? Cache? Temp? Swap? Supposedly, Recovery console can help you fix if you botch this, but my preference would be to wait long enough to try a few more looksee and troubleshoot options.

For NT, all boot files are first on the drive first seen by Windows (though bios), and then on drive for multiboot choice (whether you see it or not). Menu Called Boot.ini

Try going to command prompt and run a quick Set command. See what it says re: c: and d: etc.
0
 

Author Comment

by:myke99
ID: 7985172
I have tried XP 6 floppy boot recovery console, fixboot, fixmbr, diskpart etc. to no avail. Tried bios change + boot from xp cd no luck locks up on both recovery and install. Tried single floppy (village idiot version) no luck.
Set command results =
tmp=c:\windows\temp
temp=c:\windows\temp
prompt=$p$g
winbootdir=c:\windows
path=c:\windows;c:\windows\command
comspec=c:\windows\command.com
windir=c::\windows
blaster=a220 I5 D1 T4
I have managed to remove and recreate a partition but cannot load an operating system or completely reset drive. The drive was Fat32 when I began this journey and I have left it since I am trying to use 98 to workaround the problem. I thought NTFS would make it more difficult. I am now just trying to reset the Fujitsu drive for a fresh install of XP. The fact that I cannot remove the problemm drive and still function is a real puzzle to me as well. Can access with my this box on Lan with XP home, cannot format diagnose etc. from here either. I will continue to search for a clue.
0
 
LVL 24

Expert Comment

by:SunBow
ID: 7989184
> I have tried XP 6 floppy boot

Hmm, I hadn't meant that. I might want to hear more of that for a canned OEM version I have.

I still feel I am missing something and need to reread a few more times. Or, can you say something more about the description of not booting? Exactly what is that? Messages?

> The fact that I cannot remove the problemm drive

For S/W, NT looks for its menu, boot.ini, on the first drive it finds, which it usually labels as c:, whether ntfs or fat. Inside that file, the menu option may redirect to the next drive, your so-called problem. It may also redirect to run Win9x instead of NT. I think this is red herring, for it appears you have formatted the drive, and that process should have killed any ability of 2nd drive to help to boot the first drive. Depending on how you did that. If you had NT At one time, it still may be there in the boot process.

Your set command looks as expected. Unfortunately, XP no longer defaults to \WinNT, it goes to \Windows now. But it doesn't fit well with Command.com.  I am still a little confused about when it is XP, When it is 98, and what failure is.  With Win9x there is more frequent use of an autoexec.bat - so, do you run one of those? If so, look there for references to a d: or even to CMD.EXE instead of Command.Com.

Try HW instead. Maybe the first drive is not set at master, so make it so. Maybe it is set at cable select, automatic configured, and that don't work well unless there's something else physically on the cable, maybe the drive is not so perfect.
0
What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

 
LVL 24

Expert Comment

by:SunBow
ID: 7989336
I'd like more info on bios. What exactly does it indicate about the HDs when booting with 1 vs 2 drives? This should be displayed right after the RAM test during POST. If not, get into bios configuration, and select all options to display messages AND to perform the POST. It seems many units now come with default to perform no checks or displays, as if the few milliseconds saved during bootup will convince consumers it's a good deal.
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 7998697
I'd go back to basics: Set the drive to master, not cable select. Install it as the only drive. Check your machine's BIOS boot sequence and set it to floppy - cd - 1st HD. Boot from a floppy and write the drive with a utility such as wdclear which will overwrite the boot block, utility partitions, etc. This will also give you an idea if the drive's functioning as a basic level. Then boot from the XP CD and try to do a standad install. Make sure this motherboard can see drives over 32GB! I couldn't find specs for this board but chaintech's last bios was 1999.
0
 

Author Comment

by:myke99
ID: 8000292
I have started again to try and provide more detailed info.
I set the original drive back to a single master configuration with CDROM as secondary master.
I tried with the recovery console - http://support.microsoft.com/default.aspx?scid=kb;en-us;Q307654
using both these disks -
http://support.microsoft.com/default.aspx?scid=kb;en-us;310994 and with the cd the winnt command in the I386 directory.
I have also tried to boot with the cd as well with no success.
I have tried both the Fujitsu supplied erase program and the WDClear program after booting form a win 98 floppy, with both failing to write.
The error I recieve with the WDClear program is -
ID not found, 101 times with a final -
Test stopped Since Maximum error count Exceeded. The Fujitsu program has this -
error code 13: drive not responding
A fatal error occured while a command is in progress.
This may be caused by a general device fault condition or your hard disk has stopped responding to the system and is not ready to accept anymore commands.
This program will be TERMINATED !
I think I will have to accept the fact that the drive is toast.
Still will not boot from WDC drive unless suspect drive installed and set as slave.
If I boot from floppy, fdisk will not even see WDC drive unless Fusitsu is installed.
I will attempt to install XP on it.  
0
 

Author Comment

by:myke99
ID: 8010255
I will have to agree with SunBow's original answer, even with the added puzzles which may dissappear with the installation of a single new drive. I have not been able to get the suspect drive to respond to any method of diagnostics or repair. I am very happy with the failure in one sense as it has, during my extensive searching for a solution, exposed me to this site which will definately be a great source of information and learning.
Thanks all.
0
 
LVL 24

Expert Comment

by:SunBow
ID: 8010632
Thanx.
>a great source of information and learning.

Agree, that got me here. This is new TA probably for dickering with network drives. If you look into, or pose Q's in the TA for Hardware, you'll probably get a better audience, or at least more versatile wider audience.

I am rather confused here yet, at least perplexed on HD dependency, but as fyi I've just been reading also in EE about HD PW, and how not having one for ANY drive can cause boot failure. While I do not think that applicable, maybe something similar to that as enabler? I don't want to think so.

Your comments are like when NTFS is on HD1, and HD2 is FAT, a boot of NT has HD1 being c:, HD2 d:, but a boot of Win9x will ignore HD1 and refer to HD2 as c: --- but I do not see you describe it that way. Interesting, and strange. One meager guess is that you've a condition where the power supplied is more stable with the help of the other drive, helping get the spin rate within tolerance.
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 8012622
Remember that when you have two hard drives on an IDE channel the controller of the master is used for both. It's plausible that the controller on the Fujitsu is bad and by using the controller on the smaller drive you could salvage the capacity. I'd try to slave the fujitsu, clear them both with wdclear and see what you've got.
0
 

Author Comment

by:myke99
ID: 8019675
SunBow - I have started to describe in detail all info from bios to boot etc. a number of times but feel I am wasting experts time as everything appears correct to me based only on my experience and general knowledge. I want to try and keep the info relevant, except for the first rant :), and clear. The bios settings, boot sequence, and info in the boot.ini file all appear correct. The dependency is puzzling still but I have asked my friend to purchase a new drive for his machine based on my failure to erase, low level format or partition his original correctly. I have selected your answer as best and correct simply because of economics, if my friend was paying for this repair he would have purchased a few drives by now in hourly rate alone. My investigation will continue for personal reasons until my friend can afford to purchase a new drive. I will continue to post any info that seems to be leading to a root cause of this failure and drive dependancy.

chicagoan - you have peaked my interest with your theory on controllers. I have failed to clear the fujitsu with any program yet as noted previously in this post but if the controller was bad in the WDC master drive, it is an old one I had in a pile in the corner with forgotten history, is it possible for control to revert to the slave drive controller? Is this prevented as a function of the jumper setting? If this is possible it may explain the dependancy. The WDC drive had been previously formatted fat32 so I checked it and installed 98 for testing and experimenting. I have never cleared it properly which I will do as soon as I get a chance. As I mentioned to SunBow I will continue to report my findings since you have both shown interest in the problems I have reported. The results may also help someone else in the future.
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question