Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 127
  • Last Modified:

Windows 2000/Active Directory Printing Services

I have a new Windows 2000 Server that I need to configure as a print server. We have about 15 printers on our network, most of them hooked up via JetDirect ports. I can run through the "Add Printer" wizard just fine, print a test page, etc from the server so I know that the communication between the server and the printer is fine.
Now here's the twist: When I try to add the new printers to the workstations (Add Printer -> Network Printer -> Server-Printer), sometimes they show up under the server name, sometimes they dont. Its an "all or nothing" thing, also - I can either see all the printers on the new server or none of them.
On the workstations that CAN see the new printers, they install correctly and print just fine.
Any suggestions as to why it would show on some PCs and not others when I try to browse to them?
(Side note: I also tried connecting to the server directly and get a "The referenced account is locked out and cannot be logged onto" error message on the machines that CANNOT see the new printers...)
0
QMan61832
Asked:
QMan61832
2 Solutions
 
daletianCommented:


<Any suggestions as to why it would show on some PCs and not others when I try to browse to them?

check your TCP/IP properties and make sure they are on the right subnet and have correct DNS and Default Gateway address

<The referenced account is locked out and cannot be logged onto

I'd check that the workstations in question have access rights to ur print server

0
 
Netman66Commented:
It's possible those machine accounts are somehow corrupted.

On one machine, try backing down into workgroup mode, deleting the machine account from AD and rejoin the workstation to the domain - if it works, you'll know it was the machine account.

If you can surf to them via My Network Places, right-click the printer and select Connect - it should install.

Advise.
0
 
QMan61832Author Commented:
Turns out it was a flaky DNS entry. The previous IT guy had some machines pointing to one server while others are pointing to other servers. Reconfiguring them all to point to the same server has fixed this.
I will try removing the machine accounts and rejoining - that was my next train of thought - thanks for the suggestions!

(Once I sat down and thought about it, it all made sense. Everything I found on Google pointed to registry settings and I just got frustrated!)
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
daletianCommented:
That's why we all try to work together here in XX



0
 
cempashaCommented:
This question is still open and getting old. If any of the comment(s) above helped you please accept it as an answer or split the points who ever helped you in this question. Your attention in finalising this question is very much appreciated. Thanks in advance,

****** PLEASE DO NOT ACCEPT THIS AS AN ANSWER ********

- If you would like to close this question and have your points refunded, please post a question in community support area on http://www.experts-exchange.com/Community_Support/ giving the address of this question. Thank you      

Pasha

Cleanup Volunteer


0
 
QMan61832Author Commented:
Sorry for taking so long to get back in here - I split the points because on some machines I had to modify the TCP/IP settings, and on others I had to fully back out and rejoin the domain. There really was no rhyme or reason to it that I could identify, but we are up and running now.
Thanks to all who assisted!
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now