?
Solved

cyradm: cannot authenticate to server with  as cyrus

Posted on 2003-02-21
9
Medium Priority
?
3,467 Views
Last Modified: 2007-12-19
I just installed cyrus-imap2 and cyrus-sasl2, the build went fine, and after some poking around and finding out you need to install the Perl modules by hand, cyradm will at least execute, however, it comes up with : cyradm: cannot authenticate to server with  as cyrus

I have made sure that saslauthd is runiing as well as master and I have built a new sendmail.cf file and restarted all services. I made all the imap.conf and cyrus.conf files with user cyrus listed as an admin.


I'm obviously missing something. PLz help.
0
Comment
Question by:psimation
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 7

Expert Comment

by:XoF
ID: 7996606
Hi psimation,

I had exactly the same problem when setting up cyrus2 and have been struggling around for several hours. then I did something unusual, yes, I've read the documentation...;-)
Unfortunately I cannot remember which exactly was the point, but the following worked for me:
- starting saslauthd
- assigning user cyrus a password via "passwd cyrus"
- "cyradm --auth login localhost --user cyrus"

( I think "--auth login" was the point)

Since you use RH as far as I remember, I could email you the complete SuSE-cyrus-Readme if the above shouldn't work for you.

HTH,
-XoF-

PS: for using "login" as authentication mechanism, you probably have to start saslauthd with the "-a pam" option.
0
 
LVL 17

Author Comment

by:psimation
ID: 8000032
Thanks, will try that.
I did see that cyrus didn't want to install before I gave it the ./configure --with-auth=unix ..
What does this means regarding my auth capabilities?
I'm used to cyrus "1"...
0
 
LVL 17

Author Comment

by:psimation
ID: 8000049
Well, at least I'm getting different errors...

[root@dell root]# cyradm --auth login localhost --user cyrus
IMAP Password:

Login failed: no mechanism available at /usr/lib/perl5/5.8.0/Cyrus/IMAP/Admin.pm line 114
cyradm: cannot authenticate to server with login as cyrus
[root@dell root]#
0
Get proactive database performance tuning online

At Percona’s web store you can order full Percona Database Performance Audit in minutes. Find out the health of your database, and how to improve it. Pay online with a credit card. Improve your database performance now!

 
LVL 17

Author Comment

by:psimation
ID: 8007377
Hi XoF

Any news?
I don't know if Kerberos is causing my headaches, but I tried to compile the cyrus-imap server with Kerberos as the auth , but it told me that it couldn't find the DES library, so I got the DES library, installed it, but now it moans about not finding kerberos, even though I have it installed in /usr/kerberos/
0
 
LVL 17

Author Comment

by:psimation
ID: 8016417
Hi XOF, are you still there?

I don't know what is happening.
I can use the newly installed cyradm to administer one of my webservers with
cyradm --auth login myserver.com --user cyrus
without problem, but as soon as it's localhost, it won't authenticate.
I did do a saslpasswd2 cyrus , and saslauthd is running...


0
 
LVL 1

Expert Comment

by:ives
ID: 8349215
psimation,

I've been struggling with this for weeks and it's been driving me NUTS!!!  So let's see if I can help out...

Which version of RH are you running?

What auth mechanism is being used by cyrus (from compile time)?  What auth mechanism would be your choice?  (as in do you want to use the separate SASLDB, or the OS authentication like PAM or shadow?)

Which version of SASL are you using?  Are you using the one that was preloaded, or did you compile and install a new SASL library?

Which auth is saslauthd set to use? (check run-time options with "ps ax |grep sasl")

You can also start by making sure you're setting the password for the cyrus user (or other users) in the correct version.  i.e.:

/usr/sbin/saslpasswd2 cyrus

check to make sure the user has been added by:

/usr/sbin/sasldblistusers

You may also need to make sure the following line is added to your /etc/imapd.conf file:

allowplaintext: yes


Start there, answer those questions, and let me know where you end up.

-ives
0
 

Expert Comment

by:CleanupPing
ID: 9087927
psimation:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9259372
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is to:

Be PAQ'd/Points No Refunded

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Paul
EE Cleanup Volunteer
0
 

Accepted Solution

by:
YensidMod earned 0 total points
ID: 9325401
PAQed per request/recommendation - No Refund

YensidMod
Community Support Moderator
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses
Course of the Month11 days, 18 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question