WinXP not sharing witn Win98

I've got 3 WinXPs and 2 Win98s in my household.  The Win98s can access shared folders on 2 of the WinXPs as guest. but not WinXP #3.  When the Win98s try to access WinXP #p ( \\Falcon ) they get this error: " You must supply a password to make this connection. Resource   \\falcon\IPC$"  

I've spent several hours trying options and comparing WinXPs to no effect. Guest account in enabled on #3 (Falcon) and #3 can access the Win98s.

All of these machines are inside a Linksys router.  They can all picg each other (Even the Win98s can Ping WinXP #3) and that can all access the internet. The Win98s can share folders on the other WinXPs without issue.

Any ideas?
LVL 1
rwgreeneAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:
xp pro or home?
you are sharing something on the xp box?
0
lrmooreCommented:
It looks like the guest account has not really been enabled, or the password was changed. The password should be blank.
Enable Netbios over TCP/IP on the XP boxes?

Some information networking XP to non-XP. XP has a whole new setup and must be adjusted to be backward compatible.

--------------------
First and formost, make sure there is no firewall software running! XP has built in PFW.Turn off the Internet Connection Firewall ICF in the advanced settings for the Lan Connection. Check for Norton Internet Security AV/Firewall, BlackIce, ZoneAlarm, et al.
-------------
Next, check your XP networking setup:
http://support.chartermi.net/support/pipeline/windows/winxp_network.html
Although this link says to set netbios over tcp/ip to "default", follow the instructions below...
-------------
Turn on "Simple file sharing" on the XP machine. Open explorer, click tools, click folder options, click the view tab and scroll down until you see "Use simple file sharing" then check the box..
----------------
For the duration of testing, enable the Guest account on XP. If all works, you can deal with that issue later (username/passwords for everyone on every PC)
----------------
Client for Microsoft Networks needs to be the primary network logon for all other machines
----------------
All machines are in the same workgroup


Enable NetBios over TCP/IP in WIndows XP
Step 1: Turn On NetBIOS over TCP/IP
Click Start, click Control Panel, and then click Network and Internet Connections.
Click Network Connections.
Right-click Local Area Connection, and then click Properties.
Click Internet Protocol (TCP/IP), and then click Properties.
Click the General tab, and then click Advanced.
Click the WINS tab.
Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
Click Close to close the Local Area Connection Properties dialog box.
Close the Network Connections window.
0
rwgreeneAuthor Commented:
Yes, it appears that the guest account is not setup.  I have reset Guest's password to nothing, and even tried setting the password to a real password.  This has no effect on the Win98s.

Here is a tid-bit:  If I log into the Win98s with a Uid/password know to the WinXP, then those Win98s can access the shares on the WinXP.  If just the guest account that fails to gain access.

All of the WinXPs are XP Pro with SP1.  

0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

stevenlewisCommented:
Run local security policy editor from control panel admin tools and set the local policy, Network Access: Let everyone permissions apply to anonymous users, to enabled
0
xmsCommented:
Try this on Microsoft Knowledge Base Article - 258938
at
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q258938
0
rwgreeneAuthor Commented:
stevenlewis: I thought you were onto something for a minute, but it didn't work out.  Changing the "Let everyone permissions apply to anonymous" didn't seem to change the activity.

xms:  Guest account is already listed as active, even though it does not seem to work.  I've disabled Guest, then Enabled it again to no effect.

Everyone, thanks for the help but I think this is hopeless. I'll force the kids to use UserID and Passwords added to the WinXP.  This is probably better anyway.

FYI:  The two WinXP Pros that allow Win98 guest access have full blown development environments installed on them, including DotNet and IIS.  The ailing WinXP Pro is a bare bones install.  Maybe something during development system installs changed the system and made Guest useable.
0
juliancrawfordCommented:
No comment has been added lately, so it's time to clean up this TA.            
I will leave a recommendation in the Cleanup topic area that this question is:            

PAQ/No Refund            
      

Please leave any comments here within the next seven days.            

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!            

JulianCrawford            
EE Cleanup Volunteer
0
moduloCommented:
PAQed - no points refunded (of 25)

modulo
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.