?
Solved

Cisco Router and VPN

Posted on 2003-02-21
13
Medium Priority
?
1,185 Views
Last Modified: 2010-08-05
Hello,

Is there anything special you have to do on a Cisco Router (2520 -- I believe), to allow VPN traffic (PPTP) to pass through the router and connect to a PIX box on the internal network?

What if you have NAT turned on at the router and the PIX, do you have to disable one of them?

Thanks
John Woods
0
Comment
Question by:andgroup
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
  • +1
13 Comments
 
LVL 11

Expert Comment

by:geoffryn
ID: 7995983
Why do you need NAT on the router if you are using the PIX?  If you have NAT on the router and are terminating the PPTP tunnel oin the PIX , you will need a static one-to-one NAT for the outside interface of the PIX.  If you can disable NAT on the router, do so, remove any access lists and it should pass packets to the PIX.
0
 

Expert Comment

by:rolojr
ID: 7996026
Not really.  If you just want to get the VPN tunnel to the internal network, just make sure you NAT points directly to the VPN.  For example, if the following is your layout,

internet <---> ROUTER <---> DMZ <---> PIX <---> internal

then you should have your router NAT a static IP from the outside directly to an IP address on PIX on the DMZ (demilitarized zone) side.  If I haven't confused you enough, take a look here from top-down...

   internet
         |
         |
      11.1.1.201 = outside IP address of PIX
   ROUTER (11.1.1.200)
         |
         |
   DMZ network (10.1.1.0/24)
         |
         |
      10.1.1.201 = inside IP address of PIX (DMZ side)
   PIX
      192.168.1.201 = inside IP address of PIX (VPN side)
         |
         |
   internal

I've never been good at drawing.  But the basic idea is to have your router NAT a static ip translation from 11.1.1.201 (on the internet side) to 10.1.1.201 (on the DMZ side).

0
 

Expert Comment

by:rolojr
ID: 7996047
geoffryn is right.  You would really wanna go with my way only if you wanted to keep two separate networks, one on either side of the PIX.
0
ATEN's HDBaseT Presentation at InfoComm 2017

Hear ATEN Product Manager YT Liang review HDBaseT technology, highlighting ATEN’s latest solutions as they relate to real-world applications during her presentation at the HDBaseT booth at InfoComm 2017.

 
LVL 79

Expert Comment

by:lrmoore
ID: 7997260
I agree with geoffryn. It all depends on how you have your router set up and how you're doing your double-nat. Do you also have good inbound acls setup on the router?
You have to:
1. clear the inbound acls (by "clear", I mean get packets past) for TCP port 1723 and for protocol 47(GRE)
2. create a static nat-map from one public IP address to the internal PPTP server.
3. clear inbound acl on the firewall, too

I'm not sure you'll be able to do it with a double-nat on both the router and the PIX, but you could try.
Example:
Router (for illustration purposes only)
 
  ||
Serial 0
  ip address 1.2.3.4 255.255.255.252
  ip nat outside
  ip access-group 109 in

 Ethernet 0
  ip address 2.3.4.5 255.255.255.0
  ip nat inside
 
 ip nat inside source static 1.2.4.8 2.3.4.6

 access-list 109 permit tcp any host 1.2.4.8 eq 1723
 access-list 109 permit gre any host 1.2.4.8
 access-list 109 permit ip any any established
 etc...

  ||

Firewall:
 interface outside address 2.3.4.7 255.255.255.0
 interface inside address 192.168.122.1 255.255.255.0
access-list 109 permit tcp any host 2.3.4.6 eq 1723
access-list 109 permit gre any host 2.3.4.6
access-list 109 permit icmp any any
etc..

access-group 109 in interface outside

static (inside,outside)2.3.4.6 192.168.122.122 255.255.255.255

 ||

PPTP server:
 192.168.122.122

Make sense?
0
 

Author Comment

by:andgroup
ID: 8016738
HERE IS A WORD PICTURE OF WHAT IS HAPPENING.  WE ARE USING HSRP BETWEEN ROUTER_A AND ROUTER_B, AND FAILOVER PIX AND PURPOSE OF THIS CONFIGURATION IS TO SETUP A REDUNDANT INTERNET CONNECTION.  HOWEVER, EVER SINCE WE SETUP THE HSRP THE VPN HAS NOT WORKED PROPERLY ON THE PIX.
 

COX ISP --> ROUTER A 10.1.1.3 -> 10.1.1.10 PIX (Primary)

                      HSRP 10.1.1.1

SPRINT  --> ROUTER B 10.1.1.2 -> 10.1.1.10 PIX (Failover)

 

Which ever pix is active uses the 10.1.1.10 IP address. 10.1.1.1 is the gateway for the pix. It is owned by the active router (normally sprint)

 

0
 

Author Comment

by:andgroup
ID: 8016759
One of the problems is that we had NAT turned on, on the router as well as the PIX.   So am I correct in that we need to create a ONE-TO-ONE mapping between, ROUTER_A and the outside interface of the PIX, as well as the ROUTER_B and the outside interface of the PIX?
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8016970
OK, as I understand what you are trying to do:
Provide failover to COX if Sprint goes down.
COX provides IP block X
SPRINT provides IP block Y
Routers must provide NAT services, definately disable at the PIX

Router A should have static NAT MAP for VPN pointing to PIX external address
Router B should have static NAT MAP for VPN

inbound acls on the routers must pass esp, isakmp and udp port 10000


Problem is in HSRP
Inbound packet from Internet (VPN client) source address 12.34.56.7
Going to PIX public COX address 67.89.54.2 - which gets forwarded to 10.1.1.10
PIX responds to 25.34.56.7 by going forwarding to the default gateway - 10.1.1.1, which is answered by SPRINT router which forwards with a different natted address so it comes back to the client with a different source address and dies.

If the VPN client points to the primary SPRINT ip address, AND HSRP is set to watch the serial interface, AND the client is setup with alternate VPN end-point address of the COX IP, if the Sprint line drops, then the COX router is the only active router and will handle two-way connection just fine.

HSRP is NOT, repeat NOT designed for load-sharing.
Am I missing anything?
0
 

Author Comment

by:andgroup
ID: 8018831
I am posting the configs...  Obviously certian pieces of information have been omitted for security reasons....

Thanks

-------------------------------------
SPRINT
-------------------------------------
SprintT1#sh conf
Using 1373 out of 29688 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SprintT1
!
enable secret 5 ######
enable password 7 ######
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
 description Connected to PIX
 ip address 10.1.1.2 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 ip nat inside
 duplex auto
 speed auto
 standby 1 priority 110 preempt
 standby 1 ip 10.1.1.1
 standby 1 track Serial0/0
!
interface Serial0/0
 description Connected to Sprint T1
 ip address 160.x.x.202 255.255.255.252
 no ip redirects
 no ip directed-broadcast
 ip nat outside
 no fair-queue
 service-module t1 remote-alarm-enable
!
router rip
 version 2
 passive-interface Serial0/0
 network 10.0.0.0
 no auto-summary
!
ip nat inside source list 1 interface Serial0/0 overload
ip nat inside source static 10.1.1.10 63.x.x.162
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip route 63.x.x.160 255.255.255.248 10.1.1.10 permanent
no ip http server
!
access-list 1 permit 10.1.1.0 0.0.0.255
snmp-server engineID local 0000000902000007EB6AB7E0
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 password 7 #####
 login
 transport input none
line aux 0
line vty 0 4
 password 7 #####
 login
!
no scheduler allocate
end
-------------------------------------------
COX CONFIG
-------------------------------------------
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname P-CoxT1
!
enable secret 5 ######
enable password 7 ######
!
ip subnet-zero
!
!
no ip domain-lookup
!
!
!
!
interface FastEthernet0/0
 description Connected to PIX
 ip address 10.1.1.3 255.255.255.0
 no ip redirects
 ip nat inside
 duplex auto
 speed auto
 standby 1 ip 10.1.1.1
 standby 1 priority 100
 standby 1 preempt
 standby 1 track Serial0/0
!
interface Serial0/0
 description Connected to Cox T1
 ip address 192.168.5.6 255.255.255.252
 no ip redirects
 ip nat outside
 no fair-queue
 service-module t1 timeslots 1-8
 service-module t1 remote-alarm-enable
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip nat pool natpool 66.x.x.170 66.x.x.190 netmask 255.255.255.224
ip nat inside source list 1 pool natpool overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip route 66.x.x.160 255.255.255.248 10.1.1.10 permanent
no ip http server
ip pim bidir-enable
!
access-list 1 permit 10.1.1.0 0.0.0.255
snmp-server engineID local 0000000902000007EB6AB7E0
snmp-server community public RO
!
line con 0
 exec-timeout 0 0
 password 7 070E2F48491B161007
 login
line aux 0
line vty 0 4
 password 7 070E2F48491B161007
 login
!
no scheduler allocate
end
-------------------------------------------------
PIX CONFIG
-------------------------------------------------
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password #### encrypted
passwd #### encrypted
hostname PIX
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
names
access-list 101 permit icmp any any
access-list 101 permit tcp any host 63.x.x.163 eq smtp
access-list 101 permit tcp any host 63.x.x.163 eq pop3
access-list 101 permit tcp any host 63.x.x.163 eq www
access-list 101 permit udp any host 63.x.x.163 eq isakmp
access-list 101 permit ip 172.16.1.0 255.255.255.0 10.100.10.0 255.255.255.0
access-list 101 permit udp any host 10.1.1.10 eq isakmp
access-list 101 permit tcp any host 66.x.x.163 eq smtp
access-list 101 permit tcp any host 66.x.x.163 eq pop3
access-list 101 permit tcp any host 66.x.x.163 eq www
access-list 102 permit ip 10.100.10.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list 110 permit ip 10.1.0.0 255.255.0.0 10.100.0.0 255.255.0.0
pager lines 24
interface ethernet0 10baset
interface ethernet1 10baset
mtu outside 1500
mtu inside 1500
ip address outside 10.1.1.10 255.255.255.0
ip address inside 10.100.10.1 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpn1 172.16.1.1-172.16.1.254
failover
failover timeout 0:00:00
failover poll 3
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
pdm history enable
arp timeout 14400
global (outside) 1 10.1.1.15
nat (inside) 0 access-list 102
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 63.x.x.163 10.100.10.53 netmask 255.255.255.255 0 0
static (inside,outside) 66.x.x.163 10.100.10.58 netmask 255.255.255.255 0 0
access-group 101 in interface outside
route outside 0.0.0.0 0.0.0.0 10.1.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 si
p 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
no floodguard enable
sysopt connection permit-pptp
sysopt connection permit-l2tp
sysopt ipsec pl-compatible
no sysopt route dnat
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map CRYMAP 10 ipsec-isakmp dynamic dynmap
crypto map CRYMAP interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp client configuration address-pool local vpn1 outside
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup pm address-pool vpn1
vpngroup pm wins-server 10.100.10.53
vpngroup pm default-domain ######.com
vpngroup pm idle-time 1800
vpngroup pm password ********
telnet 10.100.10.0 255.255.255.0 inside
telnet timeout 60
ssh timeout 5
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe 40
vpdn group 1 client configuration address local vpn1
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local
vpdn username ####### password ********
vpdn enable outside
terminal width 80

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8019182
Couple of obsrevations:
PIX
route outside 0.0.0.0 0.0.0.0 10.1.1.1 1
Suggest adding:
route outside 66.x.x.0 255.255.255.224 10.1.1.3
route outside 63.x.x.0 255.255.255.248 10.1.1.2

Without the routing changes, these entries will be highly dependent on which router is active:
static (inside,outside) 63.x.x.163 10.100.10.53 netmask 255.255.255.255 0 0
static (inside,outside) 66.x.x.163 10.100.10.58 netmask 255.255.255.255 0 0


Sprint router:
suggest adding
ip route 66.x.x.0 255.255.255.223 10.1.1.3

Cox router:
ip route 63.x.x.0 255.255.255.248 10.1.1.2


I would suggest that all NAT be disabled on the PIX and let the routers perform all NAT and have one static entry just like you have on Sprint:
>ip nat inside source static 10.1.1.10 63.x.x.162

But not on Cox. Suggest:
>ip nat inside source static 10.1.1.10 66.x.x.162


0
 

Author Comment

by:andgroup
ID: 8027455
LMoore,

I have been informed that adding those routes into the PIX will defeat the whole purpose of HSRP.  If you are creating static mappings, then what is the purpose of the VIRTUAL address, isn't it supposed to determine which router to direct requests to, based upon which router is up?

Additionally, I do not understand this comment...  We are not using the Cox external IP to get to VPN, we always use the SPRINT ip addresses.

Thanks....

--------------------------------------------------------
Problem is in HSRP
Inbound packet from Internet (VPN client) source address 12.34.56.7
Going to PIX public COX address 67.89.54.2 - which gets forwarded to 10.1.1.10
PIX responds to 25.34.56.7 by going forwarding to the default gateway - 10.1.1.1, which is answered by SPRINT router which forwards with a different natted address so it comes back to the client with a different source address and dies.

If the VPN client points to the primary SPRINT ip address, AND HSRP is set to watch the serial interface, AND the client is setup with alternate VPN end-point address of the COX IP, if the Sprint line drops, then the COX router is the only active router and will handle two-way connection just fine.

HSRP is NOT, repeat NOT designed for load-sharing.
Am I missing anything?
--------------------------------------------------------
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 600 total points
ID: 8028232
I suppose "trust me" isn't good enough here. This is what I do for a living as well as participating in this forum as a hobby.

If you ONLY use Sprint addresses for VPN, then what happens if the Sprint link is down? VPN's won't work. If you used BOTH Sprint and COX addresses for VPN, then it would not matter. I was assuming that was what you were wanting to do, and you have that capability.

Adding static routes will NOT invalidate the HSRP. The DEFAULT gateway still remains the HSRP virtual address. If you have specific addresses in nat pools - 66.x.x.x / 63.x.x.x, then the PIX should know which of the two routers "owns" which subnet, and the two routers should also know about each other's addresses since you are not advertising them through RIP. Each of your routers has a static route pointing 63.x.x.x/66.x.x.x to the PIX, but the PIX has no reciprical routes.

Hope this makes more sense...
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8442668
G'day, andgroup
It has been 69 days since you posted this question.
Do you still need help? Have you received enough information?
Can you close out this question?
Ways to close questions: http://www.apollois.com/EE/Help/Closing_Questions.htm
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 8725582
andgroup,
No comment has been added lately (44 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to lrmoore

Please leave any comments here within 7 days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

Thanks,

lrmoore
EE Cleanup Volunteer
---------------------
If you feel that your question was not properly addressed, or that none of the comments received were appropriate answers,
please post comments here where a Moderator will see it.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question