Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 306
  • Last Modified:

Connect to the internet through gateway

I am trying to set up a home network that allows internet connection sharing. I have a linksys router, which by default is setup to work as a gateway. I want to connect the gateway the internet as a broadband connection.

PCs---Gateway---Broadband---Internet

The file sharing on the network works fine, but the gateway just won't connect to my internet service provider (it says my username or password is wrong, but it works fine when i connect a PC to the broadband). I am using a PPPoE protocol and the connection does appear on the PCs as a PPPoE connection (but as disconnected).

Hope somebody can help!!!
Matt
0
matthedane
Asked:
matthedane
  • 3
  • 3
  • 2
  • +3
1 Solution
 
stevenlewisCommented:
OK, first get rid of the PPPoE, the router will provide PPPoE, all your pc's need is tcp
now linksys uses 192.168.1.1 by default
so the tcp info on the clients should be as follow (if not using the dhcp servier)
ip 192.168.1.(2-99 use a unique number for each machine)
mask 255.255.255.0
gateway 192.168.1.1
enable dns and use either the dns ip provided by your isp or 192.168.1.1
disable wins
0
 
BeermanCommented:
Does your cable ISP need your linksys mac address to identify you on there network.  Most in my area do.
0
 
wyliecoyoteukCommented:
I would go along with the Mac address answer.
The MAC, or Physical  address is a 12 digit number unique to your network card.
Type ipconfig /all at a dos prompt to read it.

Some cable companies allow up to 4 mac addresses to be registered (mine does), this would explain why the pc works,but the router doesn`t.
Some cable/dsl routers have mac address cloning capabilities, if yours has, enter the mac address of your pc's card and it should connect ok.
0
Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

 
matthedaneAuthor Commented:
I have changed changed the gateway the use a dynamic IP adress and the PCs the use a static IP. Now the only connection that appears is the LAN. When i look at the gateways status it still says 'disconnected'.

All the computers have a MAC adress and my ISP supports up to four, so that should work.
0
 
CosmoNutCommented:
matt your missing the point on the mac address,  you linksys has a WAN mac, this needs to be one of the macs given to your ISP or you need to change the mac to one that you have already given to them.  If your ISP requires ppoe connection (if your orginal pc was set up to use ppoe) then you will also need to set up the linksys to connect using ppoe on the wan port.  On the setup screen of the linksys once logged in, bottom of the screen "Wan connection type" ensure that it is set to ppoe and put in your username and password.  Realize I am only saying this is requed IF and only IF your isp requires ppoe.  The idea here is to set up your linksys exactly as your orginal pc was connected (or is) to the cable modem.  Once that is complete then connect the pc's to the lan. I am assuming your using one of those pc's to connect here. So set up your linksys to mirror that pc.  The exact location of all settings are dofferent for each of the linksys routers, and vary by firmware release.  Log into your router and the intial screen that comes up will be the setup screen.  Under the DOmanin and router name boxes you will find your firmware release.  If you reply with that information and the type of connection your cable modem requires to connect one single pc I can type up a walk through for you of all settings.
0
 
stevenlewisCommented:
>When i look at the gateways status it still says 'disconnected'
did you tell the router your username and password to connect to your isp? and did you choose PPPoE as the connetion type. You have to configure the router with the info so it can connect to your isp
read the manual, it should be on the cd that came with the oruter
0
 
matthedaneAuthor Commented:
Thanks for your many good idears. I'm not quite sure which connection I should set the gateway to use. The PC used to obtain an IP automaticly, however, when you select this option it dosn't ask for a ISP username like it does with the PPPOE (nor does it show the connection from the PCs).
In order to test the MAC theori i tryed to clone the MAC adress from the PC, but without result...
0
 
stevenlewisCommented:
Have you read the manual for your router? it should tell you exactly how to configure the router so it will connect to the internet. your machine connects tot he router, and your router connects to your isp

The PC used to obtain an IP automaticly, however, when you select this option it dosn't ask for a ISP username
It won't because it isn't connecting tot he ips, the router is
In your browser (IE or netscape)
type
 http://192.168.1.1
this will take you to the router login page, you then log in with the default username and password for the router, you will then be at the configuration page, this is where you configure the router to connect to your isp (supply the username and password for your isp
0
 
wyliecoyoteukCommented:
On a broadband connection, your router becomes a node on your isp`s network, and acts as a bridge between you home network and theirs.

Try to think of your router as a pc on a network.
All the login setup, MAC address setup etc., are done on the router, and the router is the only part of your network which can be "seen" by the ISP. In effect, the ISP network thinks the router is a PC. The internal network is effectively isolated by NAT (Network address translation) so that you can "see" out, but no-one can "see" in.

If they allow up to 4 MAC addresses, they will need to be registered  as each one is used, there will probably be a way of changing the 4 that are registered.
TeleWest allow it in their "selfcare" section on the website.



0
 
matthedaneAuthor Commented:
Thanks for all your advise. The problem turned out to be completely different from what i thought. It turned out to be a problem with the firewall, when I turned it off it worked!

Thanks,
Matt
0
 
CleanupPingCommented:
matthedane:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 3
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now