• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 158
  • Last Modified:

Damaged Partition Table after install of RedHat 8

Hi,

I have a Western Digital 100GB HD.  I recently installed Red Hat 8 and configured it to dual boot with my win98 partition.  Prior to the red hat install I had 3 20GB FAT32 partitions setup using partition magic 7.  Then while installing Red hat I gave 10GB to linux aswell as a boot partition and a swap partition.  The rest I made 5 GB fat32 partitions.
That was fine for a while, I was able to use Win98 and linux side by side, but then I tried to run partition magic 7.  It threw up a few errors to me saying there were some incorrect values in the partition table and asking if I wanted to fix them, so I said fine.  Then after fixing all them I got a 117 error message saying it couldn't get a drives letter.  And then whenever I tried to start PM it gave me that 117 message.  I tried to run fdisk, but it wouldn't let me run, it just hung.  So I upgraded to PM 8, and that made no difference, I still got the 117 error.  So then I decided to delete my linux partitions, so I started linux in rescue mode and deleted all the linux partitions. Then in windows again I was still getting the 117 error in PM, but could run fdisk, so I deleted all the empty partitions, which left me with 3 20GB partitions and a 5 GB one.  The drives were C,D,E and F, but my zip drive was registering as drive I, and my 2 CD drives were J and K.  So I started up Iomegas drive mapper and changed the drives to run consequetivly C-I.  And now I'm left with a machine that hangs when starting windows.  Although I can get it to start in Safe Mode, my zip drive isn't recognized, so I can't use drive mapper to go back to the C-F,I-K mapping that was booting for me.  While in safe mode I thought I'd try and remove as many of the partitions as I could, so I tried to copy stuff from the 5GB partition to my C drive, and I started to get access violations, so I ran scandisk and I got loads of errors about directories and lost files etc.
Thats about it, I hope I've given enough detail to give someone an idea as to what is wrong.  I would really appreciate a fast answer to this that doesn't requiere reinstalling Win98 as I have a programming assignment to have done for Tuesday (3 days away) and I  need to use my computer.

Thanks
0
amcgin
Asked:
amcgin
1 Solution
 
amcginAuthor Commented:
Turns out that if I disable the line in my autoexec that starts my virus scan software (McAffee 7) it boots up, and now with just the 3 20GB partitions I can start PM 8, however only 2 of the partitions show in PM, but I can still access the 3 partitions in Windows Explorer.
0
 
publicCommented:
Run the red hat installation to the point where it offers to manually partition the disk with fdisk. Run fdisk, and it will give you some idea of what is happening. Write down the partition start and end values, so that if you make changes you can go back.
0
 
CleanupPingCommented:
amcgin:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now