32 bit protected-mode disc driver problem !!!

I have been troubleshooting my son's dell comp(xpsr450 pent.II)and I came to the point where if I disable the primary ide controller it will will run, except C drive will go in MS-DOS compatability mode.So I put in a Promise Ultra TX2100 controller for the c-drive.I thought that would fix it,but no.Now the only way I can run it is if I disable 32 bit protected-mode disc drivers in the troubleshooting window.What would cause this to happen
the new controller seems fine. I had problems installing drivers for mobo that is why I went this route.
s10daveAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

stevenlewisCommented:

Did you disable the IDE controller in the bios?
whan enabled, are there any IRQ conflicts (or I/O or DMA)
You of course did load the drivers for the promise card
0
s10daveAuthor Commented:
I disabled the ide controller in bios and unchecked disable box for 32 bit protected mode drivers.Now I get this error message"fatal exception OE @ 0028:0000070f." then I ctrl-alt-del and it gave me "exception OE @0028:c0058155 in VxD".I did load the promise drivers.
0
stevenlewisCommented:
>Now the only way I can run it is if I disable 32 bit protected-mode disc drivers in the troubleshooting window
you do this for the promise card now?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

s10daveAuthor Commented:
Yes,and when I do that it gives me exclamation marks on
promise card,floppy disc,and secondary ide controller in the device manager.I have tried to disable each one to see if I can pinpoint where the problem is,but to no avail.Is there anything else I can do to troubleshoot this problem?I originally thought the prob was the primary
controller,I guessed wrong.The A drive and the C drive are both running in MSDos compatibilty.  
0
stevenlewisCommented:
To cause Windows to attempt to reinitialize the protected-mode IDE driver:
Click Start, click Run, type regedit in the Open box, and then press ENTER.
Locate and click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS

In the right pane, right-click the NOIDE value, and then click Delete.
Quit Registry Editor.
After you update the registry, restart Windows. Windows attempts to initialize the protected-mode driver for the controller. If Windows can initialize the protected-mode driver for the controller, the file system and virtual memory operate in 32-bit mode and Device Manager does not display an exclamation point in a yellow circle for the IDE channels.

If the protected-mode driver is not initialized properly, you receive an error message and the NOIDE value is re-created. Windows uses the MS-DOS Compatibility mode file system the next time that you start the computer.
Windows 98 Only
If you are running Windows 98 on your computer, locate the Tools\Mtsutil folder on the Windows 98 CD-ROM, right-click the Noide.inf file, and then click Install. When you do this, the NOIDE value is deleted if it exists. After you use this file, restart your computer.
MORE INFORMATION
This issue can occur if your computer has an IDE controller that requires serialization between the primary and secondary IDE channels. The protected-mode drivers for these IDE controllers may not be initialized if one of the following situations occurs:
If one IDE channel has a supported hard disk, and the second channel has a CD-ROM or another type of drive that requires Real-mode drivers. Because there must be serialization between the two IDE channels, Windows cannot access the hard disk in Protected mode and use the other device in Real mode. When this occurs, the Protected-mode driver is not initialized and the NOIDE switch is placed in the registry to prevent future errors. Both disk devices can then operate in Real mode.

-or-
If you manually remove the driver for the IDE controller from Device Manager and then reinstall it, or if you disable and then re-enable the protected-mode driver. Some PCI controller drivers are not designed for dynamic enabling and disabling, and can cause the Protected-mode driver to not initialize properly.
The Windows device drivers for the following controllers may cause this behavior:
CMD PCI-0640 PCI-IDE controller
Standard Dual PCI-IDE controller
Opti Dual PCI-IDE controller
Intel 82371 AB/EB Pci Bus Master IDE Controller
Ali M5229 PCI Busmaster IDE Controller
Other PCI IDE controllers that use serialization between the IDE channels may also cause this behavior.
0
stevenlewisCommented:
0
ZawngEKCommented:
Let me try to be as simple as possible. In most older computers (like those with Intel LX, ZX chipset), if you initialize (partitioning, formating, installing OS, etc) your HDD with 32-bit mode or BusMaster mode or both disabled in the BIOS, and you later enabled either or both from the BIOS, your computer will not be able to access the HDD or errors like the one described here could occur. So the solution here is:

1) To run the computer as it is, with 32-bit access mode or BusMaster access disabled if it was disabled from before. In this case, you will not be utilizing the full capability of your computer/hdd. That means  you will not be able to use Ultra DMA/ATA/33/66/100 mode even if your computer/hdd is capable of them.

2) Otherwise, you will have to remove everything and after enabling 32-bit/busmaster access mode from the BIOS, partition, format and reinstall everything, which should be used only as a last resort.

And of course, problems could always arise (esp with older computers) if two IDE devices on the same IDE cable uses different access mode (like a CD-ROM and HDD on one IDE cable). Always use different IDE calbes for HDDs and CD-ROM/CD-Writers, like put HDDs on the Primary IDE controller and CD-ROM Drives on Secondary IDE controller.

Hope you get something out of this...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
s10daveAuthor Commented:
It sounds like I have to live with the C drive running in compatability mode, since I have an older comp. and also an Intel 82371 AB/EB Pci Bus Master IDE Controller,which were both mentioned in last 2 comments.It seems like whatever controller I connect the C drive to it has a problem.Could there be a prob. with the HD,or is it because of the serialization mentioned previously? I thought if I disable one of the IDE onboard controllers which has the HD on it and connect the HD to the PCI-IDE
Promise card,that way I would be eliminating
one of the onboard controllers,and the HD would work off the promise card.Is this possible or just live with it??
0
s10daveAuthor Commented:
I guess thats the best I can do. If anyone has more ideas,
please let me know.Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.