• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 791
  • Last Modified:

Win XP and Broadband Winsock Error! Help!

I have been having major problems with XP and my internet connection.  I can connect through IE, however when I try to connect using any FTP software such as WSFTP or SmartFTP, I get the following Winsock error:
Winsock error 11001
Winsock error 11004
Connection failed! - connection refused

Can anyone help me with this?  I have been trying everything from re-installing XP, to re-installing my NIC card drivers, and nothing seems to work.  Oddly enough, if someone else connects from a different system they have no problem connecting.  I have also tried renaming the Winsock DLL, however XP just re-installs it again, and I am right back where I started.  I have gone to the MS site and the have no solutions to the problem, or at least not one that I could find.  BTW, I have cable modem.

Thanks in advance,
aj85



0
aj85
Asked:
aj85
1 Solution
 
stevenlewisCommented:
what firewall are you using?
0
 
dew_associatesCommented:
Generally a Winsock 11001 error is a dialup settings error, dialing up but not connecting, OR a "Host Unknown" error, in essence the host is unknown via your server. The Windows 11004 error is also usually associated with a dialup problem, but it also associated with whether or not there is a valid name or no data record of requested type, which means, that DNS server was unable to convert the domain name assigned to the Host property of IMS components, into the IP address. Check the spelling of the domain name, typos and incorrect FTP settings as well as Winsock problems are some of the common reasons for this error. Another reason, possibly, is your DNS server is having problems, your connection to the Internet is bad, or you are not connected to the Internet at all, but rather obtaining cached information. My guess is that there is NO associated reverse DNS (RDNS) lookup entry in the DNS database. Double check and make sure that any dialup connections you have installed are not corrupting the winsock, and then doublecheck the FTP starting with the installation right on through the settings etc to reach the FTP server.

Dennis
0
 
tedskyCommented:
Greetings!

If after trying Dew's suggestions yoou are still searching for results, feel free to try this, as there was a Windock fix added to the program that might get this happening for you.  Worth a try, anyway <smile>.

An EXCELLENT source for SpyBot Search & Destroy (SBSD) ...
http://www.lurkhere.com
<Nice Files>
<SBSD v1.1r4>

Install, then immediately ...
<Online>
<Update> then ...
<Check for Problems> then ...
<Fix Selected Problems>

Red-lettered items will be removed and backed up (you don't want these).
Blue-lettered items are merely usage tracks (you'll want to keep these).

One other link that will help explain the 5 categories of spyware ...
http://www.consumerwebwatch.org/news/articles/spyware_categories.htm

Hope all of this helps!
Ted, the Modem Mixer
0
 
Pete LongTechnical ConsultantCommented:
aj85,
No comment has been added lately (146 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: PAQ/No Refund

Please leave any comments here within 7 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

PeteLong
EE Cleanup Volunteer
0
 
dew_associatesCommented:
Pete, it's a DNS error, what's wrong with my comment?

If you're going to paq my reply, then issue the credit or delete the question.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now