?
Solved

mailto urls using hotmail and netscape!

Posted on 2003-02-23
18
Medium Priority
?
441 Views
Last Modified: 2013-12-24
i wish to use hotmail for my email.

currently when using netscape, when i click a mailto: url, it will open a new window in internet explorer and take me to my hotmail compose page.  is there any way that i can get it to open in my netscape browser (rather than ie browser).

After searching i found: www.hotmail.com/cgi-bin/start .  This takes me to the hotmail compose page, which is what i want when i click a mailto url.

Any ideas ppl?

Cheers Frosty
0
Comment
Question by:frosty12345
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
  • 2
  • +6
18 Comments
 

Expert Comment

by:Telkman
ID: 8003344
I'm not sure if this will work or not...

IN NS, goto preferences > Advanced > System and select the "mailto:" check box.
0
 

Author Comment

by:frosty12345
ID: 8003932
mailto isnt there, i think that it is only there if you install the netscape mail program (similar to outlook).  I want to be able to use the browser .. the same as IE does.

Im guessing that this change should be done in the registary? to change the program that uses the mailto's from ie to netscape.

Anyone??
Cheers .. Frosty
0
 
LVL 6

Expert Comment

by:night_monkey
ID: 8024051
I think you might need to change your default browser.

Open up Internet Explorer.  
Under the View menu, click Internet Options (in 4.x browsers) or Options (in 3.x browsers).  
In the dialog box that appears, click the tab labeled Programs.  
At the bottom of the dialog box you will see a checkbox that reads "Internet Explorer should check to see whether it is the default browser." Make sure this box is not checked.  
Click OK and close Internet Explorer.

Next, set Communicator to be your default browser:
Run Communicator by choosing Programs and then Netscape Communicator from the Start menu or by double-clicking the Communicator icon on your desktop.  
You should be presented with a dialog box that reads "Navigator is no longer registered to handle Internet Shortcuts. Would you like to register Navigator as your default browser?" Click Yes.  
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
LVL 3

Expert Comment

by:echobravo316
ID: 8046319
Nope, what you need to do is this:
Make sure your default e-mail application is selected in Internet Options.  I dont use Hotmail, but if it's not an application (if it's web-based) I dont think you can use it.  Netscape & Outlook you can.  Use the same link in HTML: the mailto:..... command.
0
 
LVL 6

Expert Comment

by:night_monkey
ID: 8046509
"Nope, what you need to do is this:"

hehe

echo, i think you need to read the questioners post more carefully. "...it will open a new window in internet explorer and take me to my hotmail compose page. is there any way that i can get it to open in my netscape browser..." he/she wants to use netscape to open his hotmail page, not internet explorer. this was a browser question, not an email question. if hotmail is already being opened automatically when he/she clicks on the mailto link, why would the email program need to be configured? it already is the default mail program. what needs to be changed is the default browser.

thanks for the effort, though.

-monkeyman

0
 
LVL 6

Expert Comment

by:night_monkey
ID: 8046523
and by the way, frosty, if this answers your question, please close out this question and award the points to the advisor that helped you the most. if no one has given you the answer you need yet, then post what further inquiries you have, and we'll go from there.
0
 

Author Comment

by:frosty12345
ID: 8047586
ok...
in internet options hotmail is selected.
netscape is default browser
i want mailto urls to open in netscape browser (not the netscape email client)

i think that i need to tweak the registary to change the default handling of mailto urls (but im not sure what to do)

to make it even more complex: if i log into hotmail using netscape, then click a mailto url, it opens in netscape!?!?

Advice please

btw. have contacted hotmail and they say configure ure browser
contacted netscape and they said you need the settings from hotmail

(just passing the blame)



Frosty
0
 
LVL 6

Expert Comment

by:night_monkey
ID: 8049724
sounds like my original suggestion may be what you need to do. as i could be wrong, i'm curious to know if you tried going to internet options and making your default browser netscape (by using the intructions i gave above).


also, try looking around in here: HKEY_CLASSES_ROOT\htmlfile\shell\open

but be careful in the registry, you don't wanna hose your system.

-nm
0
 

Author Comment

by:frosty12345
ID: 8052449
yeah ... i had already checked the default browser thing, as i was browing throught the registary i came upon:
HKEY_CLASSES_ROOT\Mailto\shell\open\command
it contains a key containing the following:
rundll32.exe "C:\Program Files\INTERN~1\hmmapi.dll",MailToProtocolHandler %1

I feel that this needs editing but what to??


Frosty
0
 
LVL 6

Expert Comment

by:night_monkey
ID: 8053908
i'm actually not sure, to be honest. but it seems that the change would be to the "INTERN~1" part of the key.

and i also found these keys that might be where to look:

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Hotmail\Protocols\mailto

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Hotmail\Protocols\mailto\shell

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Hotmail\Protocols\mailto\shell\open

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Hotmail\Protocols\mailto\shell\open\command

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Hotmail\shell

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Hotmail\shell\open

HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail\Hotmail\shell\open\command



it seems that doing this by modifying the registry is quite involved. i'd actually recommend trying to find an alternative method here.


maybe you should try upgrading both browsers to their latest version releases first, (if you haven't already. i know there's a sp1 for ie6 that was released not too long ago. also install whatever windows updates or service packs that you haven't already.

sorry, man.


0
 
LVL 18

Expert Comment

by:chicagoan
ID: 8056758
Have you tried
Tools > Internet Options > Programs > Email > hotmail

??
0
 

Expert Comment

by:raguv2000
ID: 8140641
In IE go to Tools->Internet Options->Programs->E-mail->Select Netscape Mail x.x

In Netscape go to Edit->Preferences->Mail and Newsgroups-> Check off the ox which says "Use Neetscape Mail as the default mail application.
0
 

Expert Comment

by:jayqaz
ID: 8362742
You can set up hotmail in outlook express, it would be alot quicker to write emails from it
0
 
LVL 4

Accepted Solution

by:
Frog357 earned 80 total points
ID: 8414981
You said:
i was browing throught the registary i came upon:
HKEY_CLASSES_ROOT\Mailto\shell\open\command
it contains a key containing the following:
rundll32.exe "C:\Program Files\INTERN~1\hmmapi.dll",MailToProtocolHandler %1

I feel that this needs editing but what to??



Backup the value, close all web browser windows and change this to read:

"C:\Program Files\Netscape\Netscape.exe" %1

And close the registry and give it another try.
You might need to change the location of the netscape executable..

The line you referenced earlier was just a command line like you would type in a dos prompt, you just need to figure out what the correct syntax is to cause Netscape to open the URL.

0
 

Author Comment

by:frosty12345
ID: 8415122
yeah, i know its that line that need changing, i tried changing it to that a while ago and it didnt work :(

Frosty
0
 
LVL 4

Expert Comment

by:Frog357
ID: 8415412
What error did it give you when trying to open the mailto link?  Or did IE still open as normal?
0
 
LVL 11

Expert Comment

by:turn123
ID: 10192264
frosty12345,
No comment has been added lately (271 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to Frog357 http:#8414981

Please leave any comments here within 7 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

turn123
EE Cleanup Volunteer
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

EE introduced a new rating method known as Level, which displays in your avatar as LVL. The new Level is a numeric ranking that is based on your Points. This article discusses the rationale behind the new method and provides the mathematical formula…
I've been asked to discuss some of the UX activities that I'm using with my team. Here I will share some details about how we approach UX projects.
The Bounty Board allows you to request an article or video on any technical topic, or fulfill a bounty request to earn points. Watch this video to learn how to use the Bounty Board to get the content you want, earn points, and browse submitted bount…
Where to go on the main page to find the job listings. How to apply to a job that you are interested in from the list that is featured on our Careers page.
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question