?
Solved

Can't browse web with Mandrake 9

Posted on 2003-02-23
4
Medium Priority
?
177 Views
Last Modified: 2010-03-18
Hi, I'm very new to linux and have installed mdk9 and setup my Conexant winmodem on /dev/modem.

I can query the modem OK and it seems to dial up to the ISP OK.

The problem is that when I try to surf or even ping a URL I get no resonse as it just times out saying it can't find any site.

Security is set to standard, and it is the same if I'm root or not.

I didn't put in any dns servers (optional) for my ISP because I don't know their IP's.

I'm all out of ideas, any help would be very appreciated.
0
Comment
Question by:stigmata53
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 17

Expert Comment

by:psimation
ID: 8006558
Well,I'm almost sure it's DNS related.

Try to ping google with it's IP number (216.239.39.101). If it goes, then you need to get a valid DNS server from your ISP, or you need to tell your dial-up to get one automatically from the ISP on connect.
0
 
LVL 2

Author Comment

by:stigmata53
ID: 8006611
I cant ping any external IP's.

I thought that it was getting servers automatically because I've selected that option (I think) and when I look at resolv.conf whilst the connection is alive it has  temporary DNS entries of external IP's that I never gave it.

When setting up the account it required a Hostname, I put in my ISP's domain name, is this correct?
0
 
LVL 2

Author Comment

by:stigmata53
ID: 8008732
I finally got it working :)

I found a tutorial on www.mandrakeuser.org that had my problem in it's troubleshooting section:

[quote]

Being offline, run /sbin/route -n as root. There shouldn't be any entry starting with '0.0.0.0'. Such an entry means that there already is a default route on your system. In this case, run /sbin/route del default. Try to find out what sets this default route.
 The 'Linuxconf' version distributed with LM 7 seems to insist on setting a default route, if you configure a local network and a dial-up connection with it. Check the file '/etc/sysconfig/network' and remove any lines which start with GATEWAY or GATEWAYDEV.


Check the entries in /etc/resolv.conf for correctness.

[/quote]

0
 

Accepted Solution

by:
SpideyMod earned 0 total points
ID: 8011457
PAQ'd and points refunded.

SpideyMod
Community Support Moderator @Experts Exchange
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question